From: Karunika Choo <karunika.choo@arm.com>
To: Boris Brezillon <boris.brezillon@collabora.com>
Cc: dri-devel@lists.freedesktop.org, nd@arm.com,
Steven Price <steven.price@arm.com>,
Liviu Dudau <liviu.dudau@arm.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Simona Vetter <simona@ffwll.ch>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/9] drm/panthor: Add 64-bit and poll register accessors
Date: Wed, 9 Apr 2025 14:00:54 +0100 [thread overview]
Message-ID: <d9a4aa99-2f00-4da9-9f7e-26729f7f8fda@arm.com> (raw)
In-Reply-To: <20250321084809.5f217049@collabora.com>
On 21/03/2025 07:48, Boris Brezillon wrote:
> On Thu, 20 Mar 2025 11:17:33 +0000
> Karunika Choo <karunika.choo@arm.com> wrote:
>
>> This patch adds 64-bit register accessors to simplify register access in
>> Panthor. It also adds 32-bit and 64-bit variants for read_poll_timeout.
>>
>> Signed-off-by: Karunika Choo <karunika.choo@arm.com>
>> ---
>> drivers/gpu/drm/panthor/panthor_regs.h | 55 ++++++++++++++++++++++++++
>> 1 file changed, 55 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/panthor/panthor_regs.h
b/drivers/gpu/drm/panthor/panthor_regs.h
>> index 42dc3fedb0d4..7ec4a1d04e20 100644
>> --- a/drivers/gpu/drm/panthor/panthor_regs.h
>> +++ b/drivers/gpu/drm/panthor/panthor_regs.h
>> @@ -238,4 +238,59 @@
>> #define gpu_read(dev, reg) \
>> readl((dev)->iomem + (reg))
>>
>> +#define gpu_read_relaxed(dev, reg) readl_relaxed((dev)->iomem + (reg))
>> +
>> +#define gpu_write64(dev, reg, data) \
>> + do { \
>> + u64 __val = (u64)(data); \
>> + gpu_write(dev, reg, lower_32_bits(__val)); \
>> + gpu_write(dev, reg + 4, upper_32_bits(__val)); \
>> + } while (0)
>
> We're not doing funky name concatenation in these macros, so I'd rather
> have them defined as static inline funcs in panthor_device.h. We
> probably want to move the gpu_read/write definitions there as well if
> we do that.
I see where you're coming from, and it makes sense. I was thinking it
might be better to keep it in panthor_regs.h since that's the file we
include when accessing GPU registers. That said, we could certainly
convert them to static inline functions if you prefer.
>> +
>> +#define gpu_read64(dev, reg) \
>> + (gpu_read(dev, reg) | ((u64)gpu_read(dev, reg + 4) << 32))
>> +
>> +#define gpu_read64_relaxed(dev, reg) \
>> + (gpu_read_relaxed(dev, reg) | \
>> + ((u64)gpu_read_relaxed(dev, reg + 4) << 32))
>> +
>> +#define gpu_read64_sync(dev, reg) \
>> + ({ \
>> + u32 lo, hi1, hi2; \
>> + do { \
>> + hi1 = gpu_read(dev, reg + 4); \
>> + lo = gpu_read(dev, reg); \
>> + hi2 = gpu_read(dev, reg + 4); \
>> + } while (hi1 != hi2); \
>> + lo | ((u64)hi2 << 32); \
>> + })
>
> I would name that one gpu_read64_counter and make it a static inline
> function. Note that we already have panthor_gpu_read_64bit_counter()
> which does the same thing, so maybe move it there and rename it along
> the way.
Happy to rename this to gpu_read64_counter in v3, if you're okay with
us keeping the macros/functions in this file.
Kind regards,
Karunika
>> +
>> +#define gpu_read_poll_timeout(dev, reg, val, cond, delay_us,
timeout_us) \
>> + read_poll_timeout(gpu_read, val, cond, delay_us, timeout_us, false, \
>> + dev, reg)
>> +
>> +#define gpu_read_poll_timeout_atomic(dev, reg, val, cond, delay_us,
\
>> + timeout_us) \
>> + read_poll_timeout_atomic(gpu_read, val, cond, delay_us, timeout_us, \
>> + false, dev, reg)
>> +
>> +#define gpu_read64_poll_timeout(dev, reg, val, cond, delay_us,
timeout_us) \
>> + read_poll_timeout(gpu_read64, val, cond, delay_us, timeout_us, false, \
>> + dev, reg)
>> +
>> +#define gpu_read64_poll_timeout_atomic(dev, reg, val, cond,
delay_us, \
>> + timeout_us) \
>> + read_poll_timeout_atomic(gpu_read64, val, cond, delay_us, timeout_us, \
>> + false, dev, reg)
>> +
>> +#define gpu_read_relaxed_poll_timeout_atomic(dev, reg, val, cond,
delay_us, \
>> + timeout_us) \
>> + read_poll_timeout_atomic(gpu_read_relaxed, val, cond, delay_us, \
>> + timeout_us, false, dev, reg)
>> +
>> +#define gpu_read64_relaxed_poll_timeout(dev, reg, val, cond,
delay_us, \
>> + timeout_us) \
>> + read_poll_timeout(gpu_read64_relaxed, val, cond, delay_us,
timeout_us, \
>> + false, dev, reg)
>> +
>> #endif
>
next prev parent reply other threads:[~2025-04-09 13:01 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-20 11:17 [PATCH v2 0/9] drm/panthor: Add GPU specific initialization framework to support new Mali GPUs Karunika Choo
2025-03-20 11:17 ` [PATCH v2 1/9] drm/panthor: Add 64-bit and poll register accessors Karunika Choo
2025-03-21 7:48 ` Boris Brezillon
2025-04-09 13:00 ` Karunika Choo [this message]
2025-04-10 13:28 ` Boris Brezillon
2025-04-10 16:49 ` Karunika Choo
2025-03-20 11:17 ` [PATCH v2 2/9] drm/panthor: Use " Karunika Choo
2025-03-21 7:53 ` Boris Brezillon
2025-04-09 13:07 ` Karunika Choo
2025-04-10 13:29 ` Boris Brezillon
2025-03-20 11:17 ` [PATCH v2 3/9] drm/panthor: Add GPU specific initialization framework Karunika Choo
2025-03-21 8:28 ` Boris Brezillon
2025-03-20 11:17 ` [PATCH v2 4/9] drm/panthor: Move GPU info initialization into panthor_hw.c Karunika Choo
2025-03-21 8:16 ` Boris Brezillon
2025-03-21 8:43 ` Boris Brezillon
2025-03-20 11:17 ` [PATCH v2 5/9] drm/panthor: Make getting GPU model name simple and extensible Karunika Choo
2025-03-21 8:02 ` Boris Brezillon
2025-04-10 13:20 ` Karunika Choo
2025-04-10 13:37 ` Boris Brezillon
2025-03-20 11:17 ` [PATCH v2 6/9] drm/panthor: Add support for Mali-G715 family of GPUs Karunika Choo
2025-03-21 8:34 ` Boris Brezillon
2025-03-20 11:17 ` [PATCH v2 7/9] drm/panthor: Support GPU_CONTROL cache flush based on feature bit Karunika Choo
2025-03-21 8:41 ` Boris Brezillon
2025-03-20 11:17 ` [PATCH v2 8/9] drm/panthor: Add support for Mali-G720 and Mali-G725 GPUs Karunika Choo
2025-03-20 11:17 ` [PATCH v2 9/9] drm/panthor: Add support for Mali-G710, Mali-G510, and Mali-G310 Karunika Choo
2025-03-20 19:03 ` Liviu Dudau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d9a4aa99-2f00-4da9-9f7e-26729f7f8fda@arm.com \
--to=karunika.choo@arm.com \
--cc=airlied@gmail.com \
--cc=boris.brezillon@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=liviu.dudau@arm.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=nd@arm.com \
--cc=simona@ffwll.ch \
--cc=steven.price@arm.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®