mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Jürgen Groß" <jgross@suse.com>
To: Teddy Astie <teddy.astie@vates.tech>,
	xen-devel@lists.xenproject.org, linux-kernel@vger.kernel.org
Cc: Stefano Stabellini <sstabellini@kernel.org>,
	Oleksandr Tyshchenko <oleksandr_tyshchenko@epam.com>
Subject: Re: [PATCH] xen: Rename xenmem_reservation_increase to xenmem_populate_physmap
Date: Mon, 28 Jul 2025 07:50:15 +0200	[thread overview]
Message-ID: <d9d19009-0597-4c5c-8214-ce6593f5330a@suse.com> (raw)
In-Reply-To: <d3bdb968d720db655314fd7d7c7c4bc181395cee.1753438001.git.teddy.astie@vates.tech>


[-- Attachment #1.1.1: Type: text/plain, Size: 551 bytes --]

On 25.07.25 12:12, Teddy Astie wrote:
> xenmem_reservation_increase currently calls XENMEM_populate_physmap.
> Rename the function to avoid confusion with XENMEM_increase_reservation.

Hmm, I'm not convinced this is a good move.

xenmem_reservation_increase() has the counterpart xenmem_reservation_decrease(),
which shouldn't change its name.

So for the caller the naming is consistent. It is just the implementation which
is using a different hypercall. IMO such a detail should not be propagated to
higher logical levels.


Juergen

[-- Attachment #1.1.2: OpenPGP public key --]
[-- Type: application/pgp-keys, Size: 3743 bytes --]

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 495 bytes --]

      reply	other threads:[~2025-07-28  5:50 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-25 10:12 Teddy Astie
2025-07-28  5:50 ` Jürgen Groß [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d9d19009-0597-4c5c-8214-ce6593f5330a@suse.com \
    --to=jgross@suse.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=oleksandr_tyshchenko@epam.com \
    --cc=sstabellini@kernel.org \
    --cc=teddy.astie@vates.tech \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®