From: Dan Carpenter <dan.carpenter@linaro.org>
To: Tree Davies <tdavies@darkphysics.net>
Cc: gregkh@linuxfoundation.org, philipp.g.hortmann@gmail.com,
anjan@momi.ca, error27@gmail.com, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 09/12] Staging: rtl8192e: Rename variable pBA
Date: Fri, 14 Jul 2023 12:53:11 +0300 [thread overview]
Message-ID: <da405689-d41d-4633-acdc-1c03d35cb871@kadam.mountain> (raw)
In-Reply-To: <ZK84sYjc9uHIWZcr@basil>
On Wed, Jul 12, 2023 at 04:35:13PM -0700, Tree Davies wrote:
> Rename variable pBA to pba in order to Fix checkpatch
> warning: Avoid CamelCase
>
> Signed-off-by: Tree Davies <tdavies@darkphysics.net>
> ---
> drivers/staging/rtl8192e/rtl819x_BAProc.c | 106 +++++++++++-----------
> drivers/staging/rtl8192e/rtllib.h | 2 +-
> 2 files changed, 54 insertions(+), 54 deletions(-)
>
> diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
> index 6b5da38353ee..43ee1bd4a6ed 100644
> --- a/drivers/staging/rtl8192e/rtl819x_BAProc.c
> +++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c
> @@ -10,17 +10,17 @@
> #include "rtllib.h"
> #include "rtl819x_BA.h"
>
> -static void activate_ba_entry(struct ba_record *pBA, u16 Time)
> +static void activate_ba_entry(struct ba_record *pba, u16 Time)
Here the "p" stands for "pointer". This style of naming is not allowed
in the Linux kernel. Just use "ba" as a name. This happens in a couple
other patches as well so fix those too.
regards,
dan carpenter
prev parent reply other threads:[~2023-07-14 9:53 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-07-12 23:35 Tree Davies
2023-07-13 21:54 ` Philipp Hortmann
2023-07-14 2:49 ` Tree Davies
2023-07-14 4:57 ` Philipp Hortmann
2023-07-14 10:10 ` Dan Carpenter
2023-07-14 9:53 ` Dan Carpenter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=da405689-d41d-4633-acdc-1c03d35cb871@kadam.mountain \
--to=dan.carpenter@linaro.org \
--cc=anjan@momi.ca \
--cc=error27@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=philipp.g.hortmann@gmail.com \
--cc=tdavies@darkphysics.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®