From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-m3294.qiye.163.com (mail-m3294.qiye.163.com [220.197.32.94]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 6895722D781 for ; Wed, 7 Jan 2026 11:20:28 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=220.197.32.94 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1767784832; cv=none; b=PSuqVs+fLFx5J21tYUBBues34KoPMfuTYdvEQRd5QKStQfjP6ZVCsZJITI+dZ9sbZY0wjPk5OQYsP4oXa0jQJMiVRZ8lUsalfjdjwTjMWhy+cMGrxRP1xCFqG//u971tpB4sPmnse952SUGxKsBkoRyNoCowbvZ5MjuyXknc85s= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1767784832; c=relaxed/simple; bh=KjlE08azu+pG+pCJryywUiYCFmRMTy1h+SiU5pN7O70=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=cx30hLcgjppB8+eFsp8dLgNftPUsGSiY4wpmNe4bH1tTCt6vcXdnVP8jC43FZyrh23w4fkef8l9GOaX/aLTPwgUptyQ7ND1oJPS/oOcU2ee+o5UAUgWEK1GBBLzFt4TNUFHGnRNLZltWRd9lYO5NO/eUzjL7gfqXf4yEVW4a8hc= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=rock-chips.com; spf=pass smtp.mailfrom=rock-chips.com; dkim=pass (1024-bit key) header.d=rock-chips.com header.i=@rock-chips.com header.b=Csu+8ZE0; arc=none smtp.client-ip=220.197.32.94 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=rock-chips.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=rock-chips.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=rock-chips.com header.i=@rock-chips.com header.b="Csu+8ZE0" Received: from [172.16.12.51] (unknown [58.22.7.114]) by smtp.qiye.163.com (Hmail) with ESMTP id 2fcfe245c; Wed, 7 Jan 2026 18:04:43 +0800 (GMT+08:00) Message-ID: Date: Wed, 7 Jan 2026 18:04:42 +0800 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v2 2/2] arm64: dts: rockchip: Add rk3576 evb2 board To: =?UTF-8?Q?Heiko_St=C3=BCbner?= , Chaoyi Chen , Alexey Charkov Cc: Rob Herring , Krzysztof Kozlowski , Conor Dooley , Quentin Schulz , Kever Yang , Jonas Karlman , John Clark , FUKAUMI Naoki , Jimmy Hon , Dragan Simic , Michael Riesch , Peter Robinson , Shawn Lin , Sebastian Reichel , Andy Yan , devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-rockchip@lists.infradead.org, linux-kernel@vger.kernel.org References: <20260107070322.323-1-kernel@airkyi.com> <20260107070322.323-3-kernel@airkyi.com> <2437891.BjyWNHgNrj@diego> <881548f1-7dd9-40bb-9267-e5a03fb97820@rock-chips.com> Content-Language: en-US From: Chaoyi Chen In-Reply-To: <881548f1-7dd9-40bb-9267-e5a03fb97820@rock-chips.com> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-HM-Tid: 0a9b97ea758003abkunmda7f342cdcde1e X-HM-MType: 1 X-HM-Spam-Status: e1kfGhgUHx5ZQUpXWQgPGg8OCBgUHx5ZQUlOS1dZFg8aDwILHllBWSg2Ly tZV1koWUFDSUNOT01LS0k3V1ktWUFJV1kPCRoVCBIfWUFZGR4YH1ZCS0seSUodHk4dSBlWFRQJFh oXVRMBExYaEhckFA4PWVdZGBILWUFZTkNVSUlVTFVKSk9ZV1kWGg8SFR0UWUFZT0tIVUpLSU9PT0 hVSktLVUpCS0tZBg++ DKIM-Signature: a=rsa-sha256; b=Csu+8ZE0U7sudqThazPqJ8qMKRTtF2M9R7Hmzm4Mr6Lw+8GhdhviTKYJo4Fs0F6WMWa/wMp4HBDl5Y9fOd75QotUsQ5FM2aCbH0edvtdUPH9i3y91mzTdKKUvVcZ3/8KWOhpx7e4cmi5ZJ7GbEsJEMybXJ8M/HS2hGcXlf5Bwv0=; s=default; c=relaxed/relaxed; d=rock-chips.com; v=1; bh=vfngUEu+5lUJU0zdatrZqi6JxVQ6DnTxJ3QXwkR4q8g=; h=date:mime-version:subject:message-id:from; On 1/7/2026 5:57 PM, Chaoyi Chen wrote: > Hi Heiko, > > On 1/7/2026 4:21 PM, Heiko Stübner wrote: >> Am Mittwoch, 7. Januar 2026, 08:56:04 Mitteleuropäische Normalzeit schrieb Alexey Charkov: >>> Hi Chaoyi, >>> >>> On Wed, Jan 7, 2026 at 11:04 AM Chaoyi Chen wrote: >>>> >>>> From: Chaoyi Chen >>>> >>>> General features for rk3576 evb2 board: >>>> - Rockchip RK3576 >>>> - LPDDR4/4X >>>> - eMMC5.1 >>>> - RK806-2x2pcs + DiscretePower >>>> - 1x HDMI2.1 TX / HDMI2.0 RX >>>> - 1x full size DP1.4 TX (Only 2 Lanes) >>>> - 2x 10/100/1000M Ethernet >>>> - 5x SATA3.0 7Pin Slot >>>> - 2x USB3.2 Gen1 Host >>>> - 3x USB2.0 Host >>>> - WIFI/BT >>>> - ... >>>> >>>> Tested with eMMC/SDMMC/HDMI/USB/Ethernet/WIFI/BT module. >>>> >>>> Signed-off-by: Chaoyi Chen >> >> [...] >> >>>> + vbus5v0_typec: regulator-vbus5v0-typec { >>>> + compatible = "regulator-fixed"; >>>> + regulator-name = "vbus5v0_typec"; >>> >>> This might better be renamed, given that last time you mentioned this >>> board doesn't have a Type-C connector. Perhaps regulator-vbus5v0-otg? >> >> Alternatively a comment above it. >> >> I.e. regulator-naming should always follow the naming used in the >> schematics, so that it gets easier to reference between schematics >> and devicetree. >> > > Thanks for the explanation. I will fix this in v3. > >> >>>> + regulator-min-microvolt = <5000000>; >>>> + regulator-max-microvolt = <5000000>; >>>> + enable-active-high; >>>> + gpio = <&gpio0 RK_PD1 GPIO_ACTIVE_HIGH>; >>>> + vin-supply = <&vcc5v0_device>; >>>> + pinctrl-names = "default"; >>>> + pinctrl-0 = <&usb_otg0_pwren>; >>>> + }; >>>> + >>>> + vcc12v_dcin: regulator-vcc12v-dcin { >>>> + compatible = "regulator-fixed"; >>>> + regulator-name = "vcc12v_dcin"; >>>> + regulator-always-on; >>>> + regulator-boot-on; >>>> + regulator-min-microvolt = <12000000>; >>>> + regulator-max-microvolt = <12000000>; >>>> + }; >>>> + >>>> + vcc1v2_ufs_vccq_s0: regulator-vcc1v2-ufs-vccq-s0 { >>>> + compatible = "regulator-fixed"; >>>> + regulator-name = "vcc1v2_ufs_vccq_s0"; >>>> + regulator-boot-on; >>>> + regulator-always-on; >>>> + regulator-min-microvolt = <1200000>; >>>> + regulator-max-microvolt = <1200000>; >>>> + vin-supply = <&vcc_sys>; >>>> + }; >>>> + >>>> + vcc1v8_ufs_vccq2_s0: regulator-vcc1v8-ufs-vccq2-s0 { >>>> + compatible = "regulator-fixed"; >>>> + regulator-name = "vcc1v8_ufs_vccq2_s0"; >>>> + regulator-boot-on; >>>> + regulator-always-on; >>>> + regulator-min-microvolt = <1800000>; >>>> + regulator-max-microvolt = <1800000>; >>>> + vin-supply = <&vcc_1v8_s3>; >>>> + }; >>>> + >>>> + vcc3v3_hubreset: vcc3v3-hubreset { >>>> + compatible = "regulator-fixed"; >>>> + regulator-name = "vcc3v3_hubreset"; >>>> + regulator-boot-on; >>>> + regulator-always-on; >>> >>> If this regulator supplies a soldered-on discrete hub and is required >>> to power it up, won't it be better to describe the hub in the device >>> tree (see binding at [1]), make the regulator its supply, and perhaps >>> drop the "regulator-boot-on/regulator-always-on" annotation here, >>> letting the regulator core deal with its enabling instead? >>> >>> [1] https://github.com/torvalds/linux/blob/master/Documentation/devicetree/bindings/usb/usb-device.yaml >> >> Yep, it would be nicer to it this way. >> A live example can be found in the Rock 5 ITX [2] >> >> [2] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/arch/arm64/boot/dts/rockchip/rk3588-rock-5-itx.dts#n1266 > > Thank you for the great example. BTW the hub used here is CH344. It > looks like we need to add a new binding :) > Typo... It is WCH CH334. >> >> >> Heiko >> >> >>> [snip] >>> >>> Other than these, LGTM - thanks for addressing my comments from v1! >>> Feel free to include my: >>> >>> Reviewed-by: Alexey Charkov >>> >>> Best regards, >>> Alexey >>> >> >> >> >> >> >> > -- Best, Chaoyi