mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Coly Li <colyli@suse.de>
To: Joe Perches <joe@perches.com>,
	"Gustavo A. R. Silva" <gustavoars@kernel.org>
Cc: Kent Overstreet <kent.overstreet@gmail.com>,
	linux-bcache@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Gustavo A. R. Silva" <gustavo@embeddedor.com>
Subject: Re: [PATCH][next] bcache: Use struct_size() in kzalloc()
Date: Fri, 19 Jun 2020 23:01:58 +0800	[thread overview]
Message-ID: <dc039b66-5967-381b-ea84-b411b74578a4@suse.de> (raw)
In-Reply-To: <48589b2a3ec33a6504d23d166a32e7820d2e0b70.camel@perches.com>

On 2020/6/18 13:42, Joe Perches wrote:
> On Thu, 2020-06-18 at 13:38 +0800, Coly Li wrote:
>> On 2020/6/18 06:27, Gustavo A. R. Silva wrote:
>>> Make use of the struct_size() helper instead of an open-coded version
>>> in order to avoid any potential type mistakes.
> []
>>> diff --git a/drivers/md/bcache/writeback.c b/drivers/md/bcache/writeback.c
> []
>>> -			io = kzalloc(sizeof(struct dirty_io) +
>>> -				     sizeof(struct bio_vec) *
>>> -				     DIV_ROUND_UP(KEY_SIZE(&w->key),
>>> -						  PAGE_SECTORS),
>>> +			io = kzalloc(struct_size(io, bio.bi_inline_vecs,
>>                                                      ^^^^^^^^^^^^^^^^^^
>>                                                      I like this :-)
>>
>>> +						DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),
>>
>> The above line seems too long for 80 characters limitation. Does
>> checkpatch.pl complain for this ?
> 
> No.  checkpatch has changed:

OK, then this patch is good for me.

> 
> From bdc48fa11e46f867ea4d75fa59ee87a7f48be144 Mon Sep 17 00:00:00 2001
> From: Joe Perches <joe@perches.com>
> Date: Fri, 29 May 2020 16:12:21 -0700
> Subject: [PATCH] checkpatch/coding-style: deprecate 80-column warning
> 
> Yes, staying withing 80 columns is certainly still _preferred_.  But
> it's not the hard limit that the checkpatch warnings imply, and other
> concerns can most certainly dominate.
> 
> Increase the default limit to 100 characters.  Not because 100
> characters is some hard limit either, but that's certainly a "what are
> you doing" kind of value and less likely to be about the occasional
> slightly longer lines.
> 
> Miscellanea:
> 
>  - to avoid unnecessary whitespace changes in files, checkpatch will no
>    longer emit a warning about line length when scanning files unless
>    --strict is also used
> 
>  - Add a bit to coding-style about alignment to open parenthesis
> 
> Signed-off-by: Joe Perches <joe@perches.com>
> Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

I see. My current monitor may display 4 terminal window with 85
characters width, expending the limit to 100 characters means I probably
have to change my current monitor with a good cause.

Thank you, for such good change.

Coly Li




      reply	other threads:[~2020-06-19 16:18 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-17 22:27 Gustavo A. R. Silva
2020-06-18  5:38 ` Coly Li
2020-06-18  5:42   ` Joe Perches
2020-06-19 15:01     ` Coly Li [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dc039b66-5967-381b-ea84-b411b74578a4@suse.de \
    --to=colyli@suse.de \
    --cc=gustavo@embeddedor.com \
    --cc=gustavoars@kernel.org \
    --cc=joe@perches.com \
    --cc=kent.overstreet@gmail.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®