mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Baolu Lu <baolu.lu@linux.intel.com>
To: "Tian, Kevin" <kevin.tian@intel.com>,
	Joerg Roedel <joro@8bytes.org>, Will Deacon <will@kernel.org>,
	Robin Murphy <robin.murphy@arm.com>
Cc: baolu.lu@linux.intel.com, Joerg Roedel <jroedel@suse.de>,
	Mika Westerberg <mika.westerberg@linux.intel.com>,
	Ashok Raj <ashok.raj@intel.com>,
	Chris Wright <chrisw@sous-sol.org>,
	Jesse Barnes <jbarnes@virtuousgeek.org>,
	"Mallick, Asit K" <asit.k.mallick@intel.com>,
	"iommu@lists.linux.dev" <iommu@lists.linux.dev>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 4/9] iommu/vt-d: Consolidate dmar state management and force_on logic
Date: Sun, 21 Jun 2026 09:45:14 +0800	[thread overview]
Message-ID: <dcab2d86-30e5-4d29-9640-bd56c6fc9cea@linux.intel.com> (raw)
In-Reply-To: <DM6PR11MB3690A320BEB82740F86424A18CE42@DM6PR11MB3690.namprd11.prod.outlook.com>

On 6/17/2026 3:14 PM, Tian, Kevin wrote:
>> From: Baolu Lu <baolu.lu@linux.intel.com>
>> Sent: Monday, June 15, 2026 1:01 PM
>>
>> On 6/4/26 13:15, Kevin Tian wrote:
>>> +
>>> +static inline bool dmar_is_enabled(void)
>>> +{
>>> +	return dmar_state > 0;
>>> +}
>>> +
>>> +static inline bool dmar_is_disabled(void)
>>> +{
>>> +	return dmar_state < 0;
>>> +}
>>
>> The helpers above seem to conflict with:
>>
>> 	extern int intel_iommu_enabled;
>>
>> Can we possibly make the interface consistent?
>>
> 
> Can you elaborate the 'conflict' part?
> 
> If dmar_state<0, intel_iommu_enabled will be 0 as no initialization
> will happen.
> 
> if dmar_state>0, intel_iommu_enabled may be 0 or 1 upon whether
> initialization succeeds.
> 
> they server different purposes.
> 
> or did you mean that the name dmar_is_enabled() may cause
> confusion with intel_iommu_enabled?

Yes, that is exactly my concern. dmar_is_enabled() might be misused as a
replacement for intel_iommu_enabled.

> 
> I could rename it to dmar_should_enable() and dmar_should_disable()
> to differentiate.

That's better. How about dmar_requested()?

/*
  * Track whether the system wants to use the IOMMU based on a
  * combination of command-line overrides, firmware hint, platform trust
  * or secure requirements, etc.
  */
static inline bool dmar_requested(void)
{
	return dmar_state > 0;
}

Thanks,
baolu

  reply	other threads:[~2026-06-21  1:45 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-04  5:15 [PATCH 0/9] iommu/vt-d: Support a new DMAR flag Kevin Tian
2026-06-04  5:15 ` [PATCH 1/9] iommu/vt-d: Fix no_iommu to disable platform optin Kevin Tian
2026-06-04  5:15 ` [PATCH 2/9] iommu/vt-d: Force requesting ACS when tboot is enabled Kevin Tian
2026-06-04  5:15 ` [PATCH 3/9] iommu/vt-d: Remove dead code when CONFIG_INTEL_IOMMU is not set Kevin Tian
2026-06-04  5:15 ` [PATCH 4/9] iommu/vt-d: Consolidate dmar state management and force_on logic Kevin Tian
2026-06-12 11:08   ` Baolu Lu
2026-06-17  7:05     ` Tian, Kevin
2026-06-15  5:00   ` Baolu Lu
2026-06-17  7:14     ` Tian, Kevin
2026-06-21  1:45       ` Baolu Lu [this message]
2026-06-04  5:15 ` [PATCH 5/9] iommu/vt-d: Use dmar_can_force_on() for platform optin Kevin Tian
2026-06-12 13:16   ` Baolu Lu
2026-06-17  7:17     ` Tian, Kevin
2026-06-04  5:15 ` [PATCH 6/9] iommu/vt-d: Call dmar_can_force_on() for tboot optin Kevin Tian
2026-06-12 13:57   ` Baolu Lu
2026-06-17  7:19     ` Tian, Kevin
2026-06-21  1:53       ` Baolu Lu
2026-06-04  5:15 ` [PATCH 7/9] iommu/vt-d: Remove the 'force_on' variable Kevin Tian
2026-06-12 14:16   ` Baolu Lu
2026-06-17  7:22     ` Tian, Kevin
2026-06-04  5:15 ` [PATCH 8/9] iommu/vt-d: Remove dmar_disabled Kevin Tian
2026-06-12 14:26   ` Baolu Lu
2026-06-17  7:23     ` Tian, Kevin
2026-06-04  5:15 ` [PATCH 9/9] iommu/vt-d: Support the new DMA_REMAP_OPT_OUT flag bit Kevin Tian

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dcab2d86-30e5-4d29-9640-bd56c6fc9cea@linux.intel.com \
    --to=baolu.lu@linux.intel.com \
    --cc=ashok.raj@intel.com \
    --cc=asit.k.mallick@intel.com \
    --cc=chrisw@sous-sol.org \
    --cc=iommu@lists.linux.dev \
    --cc=jbarnes@virtuousgeek.org \
    --cc=joro@8bytes.org \
    --cc=jroedel@suse.de \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=robin.murphy@arm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox