mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Paolo Bonzini <pbonzini@redhat.com>
To: Sean Christopherson <sean.j.christopherson@intel.com>
Cc: Vitaly Kuznetsov <vkuznets@redhat.com>,
	Wanpeng Li <wanpengli@tencent.com>,
	Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
	kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
	Xiaoyao Li <xiaoyao.li@intel.com>
Subject: Re: [PATCH 0/2] KVM: VMX: Super early file refactor for TDX
Date: Fri, 25 Sep 2020 23:07:05 +0200	[thread overview]
Message-ID: <dcf93010-7c6b-a1a5-250c-f6017ea8f881@redhat.com> (raw)
In-Reply-To: <20200923183112.3030-1-sean.j.christopherson@intel.com>

On 23/09/20 20:31, Sean Christopherson wrote:
> Rename vmx/ops.h to vmx/vmx_ops.h, and move VMX's posted interrupt support
> to dedicated files in preparation for future Trust Domain Extensions (TDX)
> enabling.
> 
> These changes are somewhat premature, as full TDX enabling is months away,
> but the posted interrupts change is (IMO) valuable irrespective of TDX.
> 
> The value of the vmx_ops.h rename without TDX is debatable.  I have no
> problem deferring the change to the actual TDX series if there are
> objections.  I'm submitting the patch now as getting the rename upstream
> will save us minor merge conflict pain if there are changes to vmx/ops.h
> between now and whenever the TDX enabling series comes along.
> 
> https://software.intel.com/content/www/us/en/develop/articles/intel-trust-domain-extensions.html
> 
> Sean Christopherson (1):
>   KVM: VMX: Rename ops.h to vmx_ops.h
> 
> Xiaoyao Li (1):
>   KVM: VMX: Extract posted interrupt support to separate files
> 
>  arch/x86/kvm/Makefile                 |   3 +-
>  arch/x86/kvm/vmx/posted_intr.c        | 332 ++++++++++++++++++++++++++
>  arch/x86/kvm/vmx/posted_intr.h        |  99 ++++++++
>  arch/x86/kvm/vmx/vmx.c                | 321 +------------------------
>  arch/x86/kvm/vmx/vmx.h                |  92 +------
>  arch/x86/kvm/vmx/{ops.h => vmx_ops.h} |   0
>  6 files changed, 440 insertions(+), 407 deletions(-)
>  create mode 100644 arch/x86/kvm/vmx/posted_intr.c
>  create mode 100644 arch/x86/kvm/vmx/posted_intr.h
>  rename arch/x86/kvm/vmx/{ops.h => vmx_ops.h} (100%)
> 

Queued, thanks.

Paolo


      parent reply	other threads:[~2020-09-25 21:07 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-23 18:31 Sean Christopherson
2020-09-23 18:31 ` [PATCH 2/2] KVM: VMX: Rename ops.h to vmx_ops.h Sean Christopherson
2020-09-25 21:07 ` Paolo Bonzini [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dcf93010-7c6b-a1a5-250c-f6017ea8f881@redhat.com \
    --to=pbonzini@redhat.com \
    --cc=jmattson@google.com \
    --cc=joro@8bytes.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sean.j.christopherson@intel.com \
    --cc=vkuznets@redhat.com \
    --cc=wanpengli@tencent.com \
    --cc=xiaoyao.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®