From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from madrid.collaboradmins.com (madrid.collaboradmins.com [46.235.227.194]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 30A30363 for ; Fri, 15 Dec 2023 00:42:12 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=collabora.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=collabora.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=collabora.com header.i=@collabora.com header.b="tOpmRTOa" DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=collabora.com; s=mail; t=1702600930; bh=8uQA7X0TDsHumtavr3z9rkEcB9+/ly7xWDGiAAZ0ejg=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=tOpmRTOaVYB9FvaSZ5kmt1LchI1SnTSIUE1Tb/L5eDv0lITAVO018lWqGrbPgTfmk t9JRw/sT1Dnop+PueP2TfFAy9TiJlH0g2UQcc1+75KheSXGpVTugCc/w9H8s1NuSQj Mm+gatj4DTyxRvRCQlln51kiayj6ROOtd3nq7jX6T34p1+N1nArJosdZTCcZVtW7lc X55Y5cqpC739/9eprZksDxaOqfX18P71wjtAydMb1qIuDA9bN8Jh/do8yKi9N0UNmr ibp47oobtLqfT5CbLgo5zz9JVOXm+i2i+oNjp5nj66l8aIcAfZ3/4f8781scF/9sSw bG07Lu977k5pA== Received: from [100.109.49.129] (cola.collaboradmins.com [195.201.22.229]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (4096 bits) server-digest SHA256) (No client certificate requested) (Authenticated sender: dmitry.osipenko) by madrid.collaboradmins.com (Postfix) with ESMTPSA id 444683781485; Fri, 15 Dec 2023 00:42:09 +0000 (UTC) Message-ID: Date: Fri, 15 Dec 2023 03:42:06 +0300 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.15.1 Subject: Re: [PATCH v18 04/26] drm/shmem-helper: Refactor locked/unlocked functions Content-Language: en-US To: Maxime Ripard Cc: Boris Brezillon , David Airlie , Gerd Hoffmann , Gurchetan Singh , Chia-I Wu , Daniel Vetter , Maarten Lankhorst , Thomas Zimmermann , =?UTF-8?Q?Christian_K=c3=b6nig?= , Qiang Yu , Steven Price , Emma Anholt , Melissa Wen , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, kernel@collabora.com, virtualization@lists.linux-foundation.org References: <20231128133712.53a6f6cb@collabora.com> <37208c72-7908-0a78-fc89-2fa9b8d756a5@collabora.com> <20231129085330.7ccb35d3@collabora.com> <20231129144609.7544e773@collabora.com> <6da6mzwfzwbn5rhiebypo5e2v6rhtpn2fovwvfnoo333zjgobf@bgtuwhum3trp> <20231129164705.7461a294@collabora.com> <161189c2-db65-2542-5d19-77a56b56cfac@collabora.com> From: Dmitry Osipenko In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 12/14/23 21:16, Maxime Ripard wrote: > On Tue, Dec 05, 2023 at 02:43:16PM +0300, Dmitry Osipenko wrote: >> On 12/4/23 15:55, Maxime Ripard wrote: >>>> Okay, that means s/_locked/_nolock/ in drm_gem_shmem_helpers.{c,h}, I >>>> guess. >> >> DRM subsys and majority of kernel uses common _locked postfix. We should >> retain the old naming scheme by using _locked() in DRM. It's not >> worthwhile changing the name to a much less popular variant for a no >> good reason. >> >> Maxime, are you okay with keeping the _locked name? > > Yeah... I still don't really like it, but you're right that it's best to > remain consistent over my opinion :) Thanks for the review! Best regards, Dmitry