On 14.11.23 19:16, Oleksandr Tyshchenko wrote: > > > On 16.10.23 09:28, Juergen Gross wrote: > > Hello Juergen > > >> Instead of the IRQ number user the struct irq_info pointer as parameter >> in the internal pirq related functions. This allows to drop some calls >> of info_for_irq(). >> >> Signed-off-by: Juergen Gross > > > Looks good, so > > Reviewed-by: Oleksandr Tyshchenko > > > Just one NIT below ... > > > [snip] > >> >> -static void pirq_query_unmask(int irq) >> +static void pirq_query_unmask(struct irq_info *info) >> { >> struct physdev_irq_status_query irq_status; >> - struct irq_info *info = info_for_irq(irq); >> >> BUG_ON(info->type != IRQT_PIRQ); >> >> - irq_status.irq = pirq_from_irq(irq); >> + irq_status.irq = info->u.pirq.pirq; > > > ... what is the reason to open-code pirq_from_irq() here? > For example, __startup_pirq() continues to use helper in almost the same > situation ... Good catch. I'll change that, especially as it allows to remove the BUG_ON() which is in the helper already. Juergen