Next try. On Wed, 3 Nov 2010 09:56:21 -0400 (EDT), Jiri Kosina wrote: > On Wed, 3 Nov 2010, gimli wrote: > >> Does this look better ? > > What I would actually prefer would be something like > > > if ( ... ) > table = macbookair_fn_keys; > else if ( ... ) > table = powerbook_fn_keys; > else > table = apple_fn_keys; > > apple_find_translation(table, usage->code); > >> I also use the USB id's for the if. > > Thanks,