From: Wilfred Mallawa <wilfred.mallawa@wdc.com>
To: "cassel@kernel.org" <cassel@kernel.org>,
"manivannan.sadhasivam@linaro.org"
<manivannan.sadhasivam@linaro.org>
Cc: "lukas@wunner.de" <lukas@wunner.de>,
"kw@linux.com" <kw@linux.com>,
"bhelgaas@google.com" <bhelgaas@google.com>,
"linux-arm-msm@vger.kernel.org" <linux-arm-msm@vger.kernel.org>,
"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
"lpieralisi@kernel.org" <lpieralisi@kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 2/2] PCI: Rename host_bridge::reset_slot() to host_bridge::reset_root_port()
Date: Sun, 25 May 2025 02:38:35 +0000 [thread overview]
Message-ID: <e01aa311ea176d182610059f10d900bda7ff93ec.camel@wdc.com> (raw)
In-Reply-To: <aDIyyMvQkMC40jnQ@ryzen>
On Sat, 2025-05-24 at 22:57 +0200, Niklas Cassel wrote:
> On Sun, May 25, 2025 at 12:23:04AM +0530, Manivannan Sadhasivam
> wrote:
> > The callback is supposed to reset the root port, hence it should be
> > named
> > as 'reset_root_port'. This also warrants renaming the rest of the
> > instances
> > of 'reset slot' as 'reset root port' in the drivers.
> >
> > Suggested-by: Lukas Wunner <lukas@wunner.de>
> > Signed-off-by: Manivannan Sadhasivam
> > <manivannan.sadhasivam@linaro.org>
> > ---
> > drivers/pci/controller/dwc/pcie-dw-rockchip.c | 8 ++++----
> > drivers/pci/controller/dwc/pcie-qcom.c | 8 ++++----
> > drivers/pci/controller/pci-host-common.c | 20 +++++++++------
> > ----
> > drivers/pci/pci.c | 6 +++---
> > include/linux/pci.h | 2 +-
> > 5 files changed, 22 insertions(+), 22 deletions(-)
> >
> > diff --git a/drivers/pci/controller/dwc/pcie-dw-rockchip.c
> > b/drivers/pci/controller/dwc/pcie-dw-rockchip.c
> > index 193e97adf228..0cc7186758ce 100644
> > --- a/drivers/pci/controller/dwc/pcie-dw-rockchip.c
> > +++ b/drivers/pci/controller/dwc/pcie-dw-rockchip.c
> > @@ -85,7 +85,7 @@ struct rockchip_pcie_of_data {
> > const struct pci_epc_features *epc_features;
> > };
> >
> > -static int rockchip_pcie_rc_reset_slot(struct pci_host_bridge
> > *bridge,
> > +static int rockchip_pcie_rc_reset_root_port(struct pci_host_bridge
> > *bridge,
> > struct pci_dev *pdev);
> >
> > static int rockchip_pcie_readl_apb(struct rockchip_pcie *rockchip,
> > u32 reg)
> > @@ -261,7 +261,7 @@ static int rockchip_pcie_host_init(struct
> > dw_pcie_rp *pp)
> > rockchip);
> >
> > rockchip_pcie_enable_l0s(pci);
> > - pp->bridge->reset_slot = rockchip_pcie_rc_reset_slot;
> > + pp->bridge->reset_root_port = rockchip_pcie_rc_reset_slot;
>
> You just renamed the function to rockchip_pcie_rc_reset_root_port(),
> but you seem to use the old name here, so I would guess that this
> will
> not compile.
>
> With the function pointer renamed, this patch looks good to me:
> Reviewed-by: Niklas Cassel <cassel@kernel.org>
>
Reviewed-by: Wilfred Mallawa <wilfred.mallawa@wdc.com>
>
next prev parent reply other threads:[~2025-05-25 2:38 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-24 18:53 [PATCH 0/2] PCI: Slot reset fixes Manivannan Sadhasivam
2025-05-24 18:53 ` [PATCH 1/2] PCI: Save and restore root port config space in pcibios_reset_secondary_bus() Manivannan Sadhasivam
2025-05-24 20:54 ` Niklas Cassel
2025-05-25 2:36 ` Wilfred Mallawa
2025-05-25 7:22 ` Lukas Wunner
2025-05-25 7:58 ` Manivannan Sadhasivam
2025-05-26 6:54 ` Lukas Wunner
2025-05-26 11:16 ` Manivannan Sadhasivam
2025-05-24 18:53 ` [PATCH 2/2] PCI: Rename host_bridge::reset_slot() to host_bridge::reset_root_port() Manivannan Sadhasivam
2025-05-24 20:57 ` Niklas Cassel
2025-05-25 2:38 ` Wilfred Mallawa [this message]
2025-05-25 8:00 ` Manivannan Sadhasivam
2025-05-24 21:51 ` kernel test robot
2025-05-25 7:26 ` Lukas Wunner
2025-05-26 0:47 ` [PATCH 0/2] PCI: Slot reset fixes Wilfred Mallawa
2025-05-26 5:53 ` Manivannan Sadhasivam
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e01aa311ea176d182610059f10d900bda7ff93ec.camel@wdc.com \
--to=wilfred.mallawa@wdc.com \
--cc=bhelgaas@google.com \
--cc=cassel@kernel.org \
--cc=kw@linux.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=lukas@wunner.de \
--cc=manivannan.sadhasivam@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®