From: Tvrtko Ursulin <tursulin@ursulin.net>
To: Yicong Hui <yiconghui@gmail.com>,
christian.koenig@amd.com, michel.daenzer@mailbox.org
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
skhan@linuxfoundation.org, david.hunter.linux@gmail.com
Subject: Re: [RFC PATCH v3 1/3] drm/syncobj: Add flag DRM_SYNCOBJ_QUERY_FLAGS_ERROR to query errors
Date: Wed, 25 Feb 2026 16:21:34 +0000 [thread overview]
Message-ID: <e06314cd-7cc1-4d1b-8f2d-bbbcc372ab82@ursulin.net> (raw)
In-Reply-To: <20260225124609.968505-2-yiconghui@gmail.com>
On 25/02/2026 12:46, Yicong Hui wrote:
> Add flag DRM_SYNCOBJ_QUERY_FLAGS_ERROR to make the
> DRM_IOCTL_SYNCOBJ_QUERY ioctl fill out the handles array with the
> error code of the first fence found per syncobj and 0 if one is not
> found and maintain the normal return value in points.
>
> Suggested-by: Christian König <christian.koenig@amd.com>
> Suggested-by: Michel Dänzer <michel.daenzer@mailbox.org>
> Signed-off-by: Yicong Hui <yiconghui@gmail.com>
> ---
> Changes in v3:
> * Fixed inline comments by converting to multi-line comments in
> accordance to kernel style guidelines.
> * No longer using a separate superfluous function to walk the fence
> chain, and instead queries the last signaled fence in in the chain for
> its error code
> * Fixed types for error and handles array.
>
>
> drivers/gpu/drm/drm_syncobj.c | 22 ++++++++++++++++++++--
> include/uapi/drm/drm.h | 5 +++++
> 2 files changed, 25 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_syncobj.c b/drivers/gpu/drm/drm_syncobj.c
> index 2d4ab745fdad..b74e491f9d8b 100644
> --- a/drivers/gpu/drm/drm_syncobj.c
> +++ b/drivers/gpu/drm/drm_syncobj.c
> @@ -1654,14 +1654,17 @@ int drm_syncobj_query_ioctl(struct drm_device *dev, void *data,
> {
> struct drm_syncobj_timeline_array *args = data;
> struct drm_syncobj **syncobjs;
> + unsigned int valid_flags = DRM_SYNCOBJ_QUERY_FLAGS_LAST_SUBMITTED |
> + DRM_SYNCOBJ_QUERY_FLAGS_ERROR;
> uint64_t __user *points = u64_to_user_ptr(args->points);
> + uint32_t __user *handles = u64_to_user_ptr(args->handles);
> uint32_t i;
> - int ret;
> + int ret, error;
>
> if (!drm_core_check_feature(dev, DRIVER_SYNCOBJ_TIMELINE))
> return -EOPNOTSUPP;
>
> - if (args->flags & ~DRM_SYNCOBJ_QUERY_FLAGS_LAST_SUBMITTED)
> + if (args->flags & ~valid_flags)
> return -EINVAL;
>
> if (args->count_handles == 0)
> @@ -1681,6 +1684,7 @@ int drm_syncobj_query_ioctl(struct drm_device *dev, void *data,
>
> fence = drm_syncobj_fence_get(syncobjs[i]);
> chain = to_dma_fence_chain(fence);
> +
Random whitespace changes should be avoided.
> if (chain) {
> struct dma_fence *iter, *last_signaled =
> dma_fence_get(fence);
> @@ -1688,6 +1692,8 @@ int drm_syncobj_query_ioctl(struct drm_device *dev, void *data,
> if (args->flags &
> DRM_SYNCOBJ_QUERY_FLAGS_LAST_SUBMITTED) {
> point = fence->seqno;
> + error = dma_fence_get_status(fence);
> +
Ditto.
> } else {
> dma_fence_chain_for_each(iter, fence) {
> if (iter->context != fence->context) {
> @@ -1702,16 +1708,28 @@ int drm_syncobj_query_ioctl(struct drm_device *dev, void *data,
> point = dma_fence_is_signaled(last_signaled) ?
> last_signaled->seqno :
> to_dma_fence_chain(last_signaled)->prev_seqno;
> +
> + error = dma_fence_get_status(last_signaled);
> }
> dma_fence_put(last_signaled);
> } else {
> point = 0;
> + error = fence ? dma_fence_get_status(fence) : 0;
> }
> dma_fence_put(fence);
> +
More of the same. Although in this case I think it is an improvement so
you may keep it.
> ret = copy_to_user(&points[i], &point, sizeof(uint64_t));
> ret = ret ? -EFAULT : 0;
> if (ret)
> break;
> +
> + if (args->flags & DRM_SYNCOBJ_QUERY_FLAGS_ERROR) {
> + ret = copy_to_user(&handles[i], &error, sizeof(*handles));
> +
This blank line is not inserted between the existing code but still
please remove it - it is not separating any logical blocks so it is not
improving readability.
Apart from nitpicks, the implementation looks correct to me. But
userspace folks need to bless it and use it, as other people have
already commented.
And uapi is fine since fence status is already UABI courtesy of
sync_file. So it is not promoting anything kernel internal to UABI.
> + ret = ret ? -EFAULT : 0;
> + if (ret)
> + break;
> + }
> }
> drm_syncobj_array_free(syncobjs, args->count_handles);
>
> diff --git a/include/uapi/drm/drm.h b/include/uapi/drm/drm.h
> index 27cc159c1d27..213b4dc9b612 100644
> --- a/include/uapi/drm/drm.h
> +++ b/include/uapi/drm/drm.h
> @@ -1044,6 +1044,11 @@ struct drm_syncobj_array {
> };
>
> #define DRM_SYNCOBJ_QUERY_FLAGS_LAST_SUBMITTED (1 << 0) /* last available point on timeline syncobj */
> +/*
> + * Copy the status of the fence as output into the handles array.
> + * The handles array is overwritten by that.
The documentation could be improved though. Make it clear that one
status per handle is returned (use more plural) and we need an
explanation of what is the status, or a link to something existing.
For example sync_file uapi header documents it like this:
* @status: status of the fence 0:active 1:signaled <0:error
See if you can come up with something clear and to the point for this
comment block?
Regards,
Tvrtko
> + */
> +#define DRM_SYNCOBJ_QUERY_FLAGS_ERROR (1 << 1)
> struct drm_syncobj_timeline_array {
> __u64 handles;
> __u64 points;
next prev parent reply other threads:[~2026-02-25 16:21 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-25 12:46 [RFC PATCH v3 0/3] Querying errors from drm_syncobj Yicong Hui
2026-02-25 12:46 ` [RFC PATCH v3 1/3] drm/syncobj: Add flag DRM_SYNCOBJ_QUERY_FLAGS_ERROR to query errors Yicong Hui
2026-02-25 16:21 ` Tvrtko Ursulin [this message]
2026-02-27 0:23 ` Matthew Brost
2026-02-27 10:19 ` Christian König
2026-02-25 12:46 ` [RFC PATCH v3 2/3] drm/syncobj: Add DRM_SYNCOBJ_WAIT_FLAGS_ABORT_ON_ERROR ioctl flag Yicong Hui
2026-02-25 16:37 ` Tvrtko Ursulin
2026-02-25 12:46 ` [RFC PATCH v3 3/3] drm/syncobj/doc: Remove starter task from todo list Yicong Hui
2026-02-25 13:25 ` [RFC PATCH v3 0/3] Querying errors from drm_syncobj Christian König
2026-02-25 13:37 ` Michel Dänzer
2026-02-25 13:57 ` Christian König
2026-03-05 16:23 ` Yicong Hui
2026-03-06 8:42 ` Tvrtko Ursulin
2026-02-26 23:56 ` Matthew Brost
2026-02-27 10:14 ` Christian König
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e06314cd-7cc1-4d1b-8f2d-bbbcc372ab82@ursulin.net \
--to=tursulin@ursulin.net \
--cc=christian.koenig@amd.com \
--cc=david.hunter.linux@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=michel.daenzer@mailbox.org \
--cc=skhan@linuxfoundation.org \
--cc=yiconghui@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®