From: Paolo Bonzini <pbonzini@redhat.com>
To: Wanpeng Li <kernellwp@gmail.com>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
kvm <kvm@vger.kernel.org>, "Radim Krčmář" <rkrcmar@redhat.com>,
"Wanpeng Li" <wanpeng.li@hotmail.com>
Subject: Re: [PATCH v4 3/4] KVM: async_pf: Force a nested vmexit if the injected #PF is async_pf
Date: Wed, 28 Jun 2017 13:40:02 +0200 [thread overview]
Message-ID: <e08c257d-b92f-c829-7091-de9de28ae47d@redhat.com> (raw)
In-Reply-To: <CANRm+CzJHoLwgsECeTbXrEVEjU4xzh0DTqiV3yVoLY2twHq5DQ@mail.gmail.com>
On 28/06/2017 00:33, Wanpeng Li wrote:
> I have already added the same logic in kvm_inject_page_fault in patch
> 3/4, in addition, there is a guarantee it is in guest mode when we set
> svm->vmcb->control.xxxx in nested_svm_check_exception, how about just
> as what we do in nested_vmx_check_exception?
>
> + if (svm->vcpu.arch.exception.async_page_fault)
> + svm->vmcb->control.exit_info_2 = svm->vcpu.arch.apf.nested_apf_token;
> + else
> + svm->vmcb->control.exit_info_2 = svm->vcpu.arch.cr2;
Yes, see my reply to [PATCH v5 3/4].
What do you think of moving "is_guest_mode(vcpu) &&" from this "if":
>
> void kvm_inject_page_fault(struct kvm_vcpu *vcpu, struct x86_exception *fault)
> {
> ++vcpu->stat.pf_guest;
> - vcpu->arch.cr2 = fault->address;
> + vcpu->arch.exception.async_page_fault = fault->async_page_fault;
> + if (is_guest_mode(vcpu) && vcpu->arch.exception.async_page_fault)
> + vcpu->arch.apf.nested_apf_token = fault->address;
to the previous assignment of vcpu->arch.exception.async_page_fault (so
that it can be renamed to nested_apf)?
Thanks,
Paolo
next prev parent reply other threads:[~2017-06-28 11:40 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-22 2:06 [PATCH v4 0/4] KVM: async_pf: Fix async_pf exception injection Wanpeng Li
2017-06-22 2:06 ` [PATCH v4 1/4] KVM: x86: Simple kvm_x86_ops->queue_exception parameter Wanpeng Li
2017-06-22 2:06 ` [PATCH v4 2/4] KVM: async_pf: Add L1 guest async_pf #PF vmexit handler Wanpeng Li
2017-06-22 2:06 ` [PATCH v4 3/4] KVM: async_pf: Force a nested vmexit if the injected #PF is async_pf Wanpeng Li
2017-06-27 13:40 ` Paolo Bonzini
2017-06-27 22:33 ` Wanpeng Li
2017-06-28 11:40 ` Paolo Bonzini [this message]
2017-06-22 2:06 ` [PATCH v4 4/4] KVM: async_pf: Let host know whether the guest support delivery async_pf as #PF vmexit Wanpeng Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e08c257d-b92f-c829-7091-de9de28ae47d@redhat.com \
--to=pbonzini@redhat.com \
--cc=kernellwp@gmail.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rkrcmar@redhat.com \
--cc=wanpeng.li@hotmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®