mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Trond Myklebust <trondmy@hammerspace.com>
To: "chuck.lever@oracle.com" <chuck.lever@oracle.com>
Cc: "bfields@fieldses.org" <bfields@fieldses.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"nixiaoming@huawei.com" <nixiaoming@huawei.com>,
	"linux-nfs@vger.kernel.org" <linux-nfs@vger.kernel.org>,
	"jlayton@kernel.org" <jlayton@kernel.org>
Subject: Re: [PATCH] fs/nfsd: Delete invalid assignment statements in nfsd4_decode_exchange_id
Date: Sun, 22 Jul 2018 19:08:09 +0000	[thread overview]
Message-ID: <e0ee80246f7bb7587beac3f8d90f94cc6b7e6aff.camel@hammerspace.com> (raw)
In-Reply-To: <8B9E4DFD-F651-4478-A82E-CDB759BB1A69@oracle.com>

On Sun, 2018-07-22 at 15:01 -0400, Chuck Lever wrote:
> > On Jul 22, 2018, at 2:33 PM, Trond Myklebust <
> > trondmy@hammerspace.com> wrote:
> > 
> > On Sun, 2018-07-22 at 14:12 -0400, Chuck Lever wrote:
> > > > On Jul 22, 2018, at 4:50 AM, nixiaoming <nixiaoming@huawei.com>
> > > > wrote:
> > > > 
> > > > dummy = be32_to_cpup(p++);
> > > > dummy = be32_to_cpup(p++);
> > > > Assigning value to "dummy" here, but that stored value
> > > > is overwritten before it can be used.
> > > > 
> > > > delete invalid assignment statements in
> > > > nfsd4_decode_exchange_id
> > > > 
> > > > Signed-off-by: n00202754 <nixiaoming@huawei.com>
> > > > ---
> > > > fs/nfsd/nfs4xdr.c | 4 ++--
> > > > 1 file changed, 2 insertions(+), 2 deletions(-)
> > > > 
> > > > diff --git a/fs/nfsd/nfs4xdr.c b/fs/nfsd/nfs4xdr.c
> > > > index a96843c..8e78541 100644
> > > > --- a/fs/nfsd/nfs4xdr.c
> > > > +++ b/fs/nfsd/nfs4xdr.c
> > > > @@ -1392,8 +1392,8 @@ nfsd4_decode_exchange_id(struct
> > > > nfsd4_compoundargs *argp,
> > > > 
> > > > 		/* ssp_window and ssp_num_gss_handles */
> > > > 		READ_BUF(8);
> > > > -		dummy = be32_to_cpup(p++);
> > > > -		dummy = be32_to_cpup(p++);
> > > > +		be32_to_cpup(p++);
> > > > +		be32_to_cpup(p++);
> > > 
> > > If these values are not used, what's the point of byte swapping
> > > them?
> > > Surely "p += 2;" should be enough.
> > > 
> > > 
> > > > 		break;
> > > > 	default:
> > > > 		goto xdr_error;
> > 
> > Given that the value of 'p' isn't used either, why not just delete
> > those two lines altogether?
> 
> Sounds OK, READ_BUF is tracking progress through the buffer,
> and it already updates "p" as a side-effect.
> 
> Might there be some nearby instances of open-coded "p" updates
> that could also be removed, for similar reasons?
> 

Probably, yes. I believe that we've said before (and Bruce agreed at
the time) that we should get rid of READ_BUF() in knfsd as it tends to
obfuscate these assignments to 'p'. Does anyone have any free cycles to
work on that?

-- 
Trond Myklebust
Linux NFS client maintainer, Hammerspace
trond.myklebust@hammerspace.com



  reply	other threads:[~2018-07-22 19:08 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-22  8:50 nixiaoming
2018-07-22 18:12 ` Chuck Lever
2018-07-22 18:33   ` Trond Myklebust
2018-07-22 19:01     ` Chuck Lever
2018-07-22 19:08       ` Trond Myklebust [this message]
2018-07-23  2:16         ` Nixiaoming

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e0ee80246f7bb7587beac3f8d90f94cc6b7e6aff.camel@hammerspace.com \
    --to=trondmy@hammerspace.com \
    --cc=bfields@fieldses.org \
    --cc=chuck.lever@oracle.com \
    --cc=jlayton@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=nixiaoming@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®