From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933373AbdIYAac (ORCPT ); Sun, 24 Sep 2017 20:30:32 -0400 Received: from smtp.codeaurora.org ([198.145.29.96]:57334 "EHLO smtp.codeaurora.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932529AbdIYAa3 (ORCPT ); Sun, 24 Sep 2017 20:30:29 -0400 DMARC-Filter: OpenDMARC Filter v1.3.2 smtp.codeaurora.org E092760618 Authentication-Results: pdx-caf-mail.web.codeaurora.org; dmarc=none (p=none dis=none) header.from=codeaurora.org Authentication-Results: pdx-caf-mail.web.codeaurora.org; spf=none smtp.mailfrom=okaya@codeaurora.org Subject: Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() To: Christoph Hellwig Cc: linux-pci@vger.kernel.org, timur@codeaurora.org, alex.williamson@redhat.com, linux-arm-msm@vger.kernel.org, linux-arm-kernel@lists.infradead.org, Bjorn Helgaas , linux-kernel@vger.kernel.org References: <1506212218-29103-1-git-send-email-okaya@codeaurora.org> <1506212218-29103-3-git-send-email-okaya@codeaurora.org> <20170924130806.GA12285@infradead.org> From: Sinan Kaya Message-ID: Date: Sun, 24 Sep 2017 20:30:23 -0400 User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.3.0 MIME-Version: 1.0 In-Reply-To: <20170924130806.GA12285@infradead.org> Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 9/24/2017 9:08 AM, Christoph Hellwig wrote: > On Sat, Sep 23, 2017 at 08:16:56PM -0400, Sinan Kaya wrote: >> Rev 3.1 Sec 2.3.1 Request Handling Rules: >> Valid reset conditions after which a device is permitted to return CRS >> are: >> * Cold, Warm, and Hot Resets, >> * FLR >> * A reset initiated in response to a D3hot to D0 uninitialized >> >> Try to reuse FLR implementation towards other reset types. > > Maybe call it pci_reset_wait instead of pci_dev_wait? > I can go for pci_dev_reset_wait(). I was using the PCI directory function naming nomenclature where some functions using struct pci_dev start with pci_dev and others using struct pci_bus start with pci_bus. -- Sinan Kaya Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm Technologies, Inc. Qualcomm Technologies, Inc. is a member of the Code Aurora Forum, a Linux Foundation Collaborative Project.