From: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
To: srinivas.kandagatla@oss.qualcomm.com, vkoul@kernel.org,
broonie@kernel.org
Cc: yung-chuan.liao@linux.intel.com, pierre-louis.bossart@linux.dev,
lgirdwood@gmail.com, perex@perex.cz, tiwai@suse.com,
krzysztof.kozlowski@linaro.org, linux-kernel@vger.kernel.org,
linux-sound@vger.kernel.org, linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH 1/4] soundwire: bus: add of_sdw_find_device_by_node helper
Date: Fri, 27 Jun 2025 18:29:46 +0200 [thread overview]
Message-ID: <e1fe370c-6435-4a84-b7d7-1ce4db4dbfea@oss.qualcomm.com> (raw)
In-Reply-To: <20250627155103.441547-2-srinivas.kandagatla@oss.qualcomm.com>
On 6/27/25 5:51 PM, srinivas.kandagatla@oss.qualcomm.com wrote:
> From: Srinivas Kandagatla <srinivas.kandagatla@oss.qualcomm.com>
>
> There has been more than 3 instances of this helper in multiple codec
> drivers, it does not make sense to keep duplicating this part of code.
>
> Lets add a helper of_sdw_find_device_by_node for codec drivers to use it.
>
> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@oss.qualcomm.com>
> ---
I think we can do the same with e.g.
sound/soc/sdw_utils/soc_sdw_rt_amp.c
281: sdw_dev1 = bus_find_device_by_name(&sdw_bus_type, NULL, dai_links->codecs[0].name);
292: sdw_dev2 = bus_find_device_by_name(&sdw_bus_type, NULL, dai_links->codecs[1].name);
and make sdw_bus_type private again
Konrad
next prev parent reply other threads:[~2025-06-27 16:29 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-27 15:50 [PATCH 0/4] ASoC: codecs: wcd937x/8x/9x: cleanup srinivas.kandagatla
2025-06-27 15:51 ` [PATCH 1/4] soundwire: bus: add of_sdw_find_device_by_node helper srinivas.kandagatla
2025-06-27 16:29 ` Konrad Dybcio [this message]
2025-06-27 17:46 ` Vinod Koul
2025-06-28 20:29 ` Srinivas Kandagatla
2025-06-28 2:02 ` Dmitry Baryshkov
2025-06-27 15:51 ` [PATCH 2/4] soundwire: bus: add sdw_slave_get_current_bank helper srinivas.kandagatla
2025-06-27 15:54 ` Konrad Dybcio
2025-06-27 16:20 ` Srinivas Kandagatla
2025-06-27 15:51 ` [PATCH 3/4] ASoC: codecs: wcdxxxx: use of_sdw_find_device_by_node helper srinivas.kandagatla
2025-06-28 2:01 ` Dmitry Baryshkov
2025-06-27 15:51 ` [PATCH 4/4] ASoC: codecs: wcdxxxx: use sdw_slave_get_current_bank helper srinivas.kandagatla
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e1fe370c-6435-4a84-b7d7-1ce4db4dbfea@oss.qualcomm.com \
--to=konrad.dybcio@oss.qualcomm.com \
--cc=broonie@kernel.org \
--cc=krzysztof.kozlowski@linaro.org \
--cc=lgirdwood@gmail.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-sound@vger.kernel.org \
--cc=perex@perex.cz \
--cc=pierre-louis.bossart@linux.dev \
--cc=srinivas.kandagatla@oss.qualcomm.com \
--cc=tiwai@suse.com \
--cc=vkoul@kernel.org \
--cc=yung-chuan.liao@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®