mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Sven Peter" <sven@svenpeter.dev>
To: "Lu Baolu" <baolu.lu@linux.intel.com>,
	"Joerg Roedel" <joro@8bytes.org>,
	"Jason Gunthorpe" <jgg@nvidia.com>,
	"Christoph Hellwig" <hch@infradead.org>,
	"Kevin Tian" <kevin.tian@intel.com>,
	"Will Deacon" <will@kernel.org>,
	"Robin Murphy" <robin.murphy@arm.com>,
	"Jean-Philippe Brucker" <jean-philippe@linaro.org>
Cc: "Suravee Suthikulpanit" <suravee.suthikulpanit@amd.com>,
	"Hector Martin" <marcan@marcan.st>,
	"Rob Clark" <robdclark@gmail.com>,
	"Marek Szyprowski" <m.szyprowski@samsung.com>,
	"Krzysztof Kozlowski" <krzysztof.kozlowski@linaro.org>,
	"Andy Gross" <agross@kernel.org>,
	"Bjorn Andersson" <andersson@kernel.org>,
	"Yong Wu" <yong.wu@mediatek.com>,
	"Matthias Brugger" <matthias.bgg@gmail.com>,
	"Heiko Stuebner" <heiko@sntech.de>,
	"Matthew Rosato" <mjrosato@linux.ibm.com>,
	"Orson Zhai" <orsonzhai@gmail.com>,
	"Baolin Wang" <baolin.wang@linux.alibaba.com>,
	"Chunyan Zhang" <zhang.lyra@gmail.com>,
	"Chen-Yu Tsai" <wens@csie.org>,
	"Thierry Reding" <thierry.reding@gmail.com>,
	iommu@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 02/20] iommu/apple-dart: Remove detach_dev callback
Date: Wed, 30 Nov 2022 18:00:38 +0100	[thread overview]
Message-ID: <e255ed09-ed67-46b3-b055-287959d1b76f@app.fastmail.com> (raw)
In-Reply-To: <20221128064648.1934720-3-baolu.lu@linux.intel.com>

Hi,

On Mon, Nov 28, 2022, at 07:46, Lu Baolu wrote:
> The IOMMU driver supports default domain, so the detach_dev op will never
> be called. Remove it to avoid dead code.
>
> Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com>
> ---

Reviewed-by: Sven Peter <sven@svenpeter.dev>

>  drivers/iommu/apple-dart.c | 17 -----------------
>  1 file changed, 17 deletions(-)
>
> diff --git a/drivers/iommu/apple-dart.c b/drivers/iommu/apple-dart.c
> index 4f4a323be0d0..6fbe6b275c79 100644
> --- a/drivers/iommu/apple-dart.c
> +++ b/drivers/iommu/apple-dart.c
> @@ -535,22 +535,6 @@ static int apple_dart_attach_dev(struct 
> iommu_domain *domain,
>  	return ret;
>  }
> 
> -static void apple_dart_detach_dev(struct iommu_domain *domain,
> -				  struct device *dev)
> -{

Thanks for cleaning this entire API up!

It actually turns out that this is slightly broken because I assumed that
detach_dev would always be called for any attach_dev. I think the only
consequence for a device that used to be assigned to domain A and is now moved to
domain B is that any TLB flushes required for A will still flush the TLB for that
device.

That's not a big deal but I'll eventually send a fix.

> -	int i;
> -	struct apple_dart_stream_map *stream_map;
> -	struct apple_dart_master_cfg *cfg = dev_iommu_priv_get(dev);
> -	struct apple_dart_domain *dart_domain = to_dart_domain(domain);
> -
> -	for_each_stream_map(i, cfg, stream_map)
> -		apple_dart_hw_disable_dma(stream_map);
> -
> -	if (domain->type == IOMMU_DOMAIN_DMA ||
> -	    domain->type == IOMMU_DOMAIN_UNMANAGED)
> -		apple_dart_domain_remove_streams(dart_domain, cfg);

Something might complain about unused apple_dart_domain_remove_streams now.
Might make sense to drop that for now as well.



Best,

Sven

  parent reply	other threads:[~2022-11-30 17:07 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-28  6:46 [PATCH v3 00/20] iommu: Retire " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 01/20] iommu/amd: Remove " Lu Baolu
2022-11-28 13:42   ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 02/20] iommu/apple-dart: " Lu Baolu
2022-11-28 13:43   ` Jason Gunthorpe
2022-11-30 17:00   ` Sven Peter [this message]
2022-12-01  4:50     ` Baolu Lu
2022-11-28  6:46 ` [PATCH v3 03/20] iommu/qcom: " Lu Baolu
2022-11-28 13:43   ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 04/20] iommu/exynos: " Lu Baolu
2022-11-28 13:44   ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 05/20] iommu/ipmmu: " Lu Baolu
2022-11-28 13:44   ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 06/20] iommu/mtk: " Lu Baolu
2022-11-28 13:49   ` Jason Gunthorpe
2022-11-28 13:59     ` Robin Murphy
2022-11-29  2:07       ` Baolu Lu
2022-11-29 11:45         ` Robin Murphy
2022-11-29 11:58           ` Baolu Lu
2022-11-28  6:46 ` [PATCH v3 07/20] iommu/rockchip: " Lu Baolu
2022-11-28 13:53   ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 08/20] iommu/sprd: " Lu Baolu
2022-11-28 13:53   ` Jason Gunthorpe
2022-11-29  3:34   ` Tian, Kevin
2022-11-30  9:02     ` Chunyan Zhang
2022-11-30  9:03   ` Chunyan Zhang
2022-11-28  6:46 ` [PATCH v3 09/20] iommu/sun50i: " Lu Baolu
2022-11-28 14:09   ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 10/20] iommu: Add set_platform_dma iommu ops Lu Baolu
2022-11-28 14:11   ` Jason Gunthorpe
2022-11-29  2:15     ` Baolu Lu
2022-11-28  6:46 ` [PATCH v3 11/20] iommu/fsl_pamu: Add set_platform_dma callback Lu Baolu
2022-11-28 14:14   ` Jason Gunthorpe
2022-11-29  3:46     ` Baolu Lu
2022-11-28  6:46 ` [PATCH v3 12/20] iommu/msm: " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 13/20] iommu/mtk_v1: " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 14/20] iommu/omap: " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 15/20] iommu/s390: " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 16/20] iommu/gart: " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 17/20] iommu/tegra: " Lu Baolu
2022-11-28  6:46 ` [PATCH v3 18/20] iommu: Call set_platform_dma if default domain is unavailable Lu Baolu
2022-11-28 14:57   ` Jason Gunthorpe
2023-01-03  2:45     ` Baolu Lu
2023-01-03 14:25       ` Jason Gunthorpe
2022-11-28  6:46 ` [PATCH v3 19/20] iommu: Retire detach_dev callback Lu Baolu
2022-11-28  6:46 ` [PATCH v3 20/20] iommu: Rename attach_dev to set_dev Lu Baolu
2022-11-28 13:41   ` Robin Murphy
2022-11-28 15:00     ` Jason Gunthorpe
2022-11-28 15:53       ` Robin Murphy
2022-11-29  3:59         ` Tian, Kevin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e255ed09-ed67-46b3-b055-287959d1b76f@app.fastmail.com \
    --to=sven@svenpeter.dev \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=hch@infradead.org \
    --cc=heiko@sntech.de \
    --cc=iommu@lists.linux.dev \
    --cc=jean-philippe@linaro.org \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=krzysztof.kozlowski@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=m.szyprowski@samsung.com \
    --cc=marcan@marcan.st \
    --cc=matthias.bgg@gmail.com \
    --cc=mjrosato@linux.ibm.com \
    --cc=orsonzhai@gmail.com \
    --cc=robdclark@gmail.com \
    --cc=robin.murphy@arm.com \
    --cc=suravee.suthikulpanit@amd.com \
    --cc=thierry.reding@gmail.com \
    --cc=wens@csie.org \
    --cc=will@kernel.org \
    --cc=yong.wu@mediatek.com \
    --cc=zhang.lyra@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®