mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "H. Peter Anvin" <hpa@zytor.com>
To: Joe Damato <ice799@gmail.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Cc: mingo@redhat.com, akpm@linux-foundation.org
Subject: Re: [PATCH] x86: Reduce duplicated code in the x86_64 context switch path.
Date: Sun, 12 May 2013 23:03:31 -0700	[thread overview]
Message-ID: <e3016dd4-99f5-4d32-a802-d4d03bcf470f@email.android.com> (raw)
In-Reply-To: <1368422091-959-1-git-send-email-ice799@gmail.com>

This is a net addition in code, and send to only make it harder to understand what is happening.  As such I don't think this is a good idea.

Joe Damato <ice799@gmail.com> wrote:

>Signed-off-by: Joe Damato <ice799@gmail.com>
>---
> arch/x86/include/asm/switch_to.h |   30 ++++++++++++++++++++++++++++++
> arch/x86/kernel/process_64.c     |   29 ++---------------------------
> 2 files changed, 32 insertions(+), 27 deletions(-)
>
>diff --git a/arch/x86/include/asm/switch_to.h
>b/arch/x86/include/asm/switch_to.h
>index 4ec45b3..a322cc6 100644
>--- a/arch/x86/include/asm/switch_to.h
>+++ b/arch/x86/include/asm/switch_to.h
>@@ -124,6 +124,36 @@ do {									\
> 	       __switch_canary_iparam					  \
> 	     : "memory", "cc" __EXTRA_CLOBBER)
> 
>+#define loadsegment_fs(fs, index)					  \
>+	loadsegment(fs, index)
>+
>+#define loadsegment_gs(gs, index)					  \
>+	load_gs_index(index)
>+
>+#define switch_segment(prev, next, index, seg, msr)			       \
>+	do {								       \
>+		/*							       \
>+		 * Segment register != 0 always requires a reload.  Also       \
>+		 * reload when it has changed.  When prev process used 64bit   \
>+		 * base always reload to avoid an information leak.	       \
>+		 */							       \
>+		if (unlikely(index | next->index | prev->seg)) {	       \
>+			loadsegment_##seg(seg, next->index);		       \
>+			/*						       \
>+			 * Check if the user used a selector != 0; if yes      \
>+			 *  clear 64bit base, since overloaded base is always  \
>+			 *  mapped to the Null selector			       \
>+			 */						       \
>+			if (index)					       \
>+			  prev->seg = 0;				       \
>+		}							       \
>+									       \
>+		/* when next process has a 64bit base use it */		       \
>+		if (next->seg)						       \
>+		  wrmsrl(msr, next->seg);				       \
>+		prev->index = index;					       \
>+	} while (0)
>+
> #endif /* CONFIG_X86_32 */
> 
> #endif /* _ASM_X86_SWITCH_TO_H */
>diff --git a/arch/x86/kernel/process_64.c
>b/arch/x86/kernel/process_64.c
>index 355ae06..f41d026 100644
>--- a/arch/x86/kernel/process_64.c
>+++ b/arch/x86/kernel/process_64.c
>@@ -318,34 +318,9 @@ __switch_to(struct task_struct *prev_p, struct
>task_struct *next_p)
> 
> 	/*
> 	 * Switch FS and GS.
>-	 *
>-	 * Segment register != 0 always requires a reload.  Also
>-	 * reload when it has changed.  When prev process used 64bit
>-	 * base always reload to avoid an information leak.
> 	 */
>-	if (unlikely(fsindex | next->fsindex | prev->fs)) {
>-		loadsegment(fs, next->fsindex);
>-		/*
>-		 * Check if the user used a selector != 0; if yes
>-		 *  clear 64bit base, since overloaded base is always
>-		 *  mapped to the Null selector
>-		 */
>-		if (fsindex)
>-			prev->fs = 0;
>-	}
>-	/* when next process has a 64bit base use it */
>-	if (next->fs)
>-		wrmsrl(MSR_FS_BASE, next->fs);
>-	prev->fsindex = fsindex;
>-
>-	if (unlikely(gsindex | next->gsindex | prev->gs)) {
>-		load_gs_index(next->gsindex);
>-		if (gsindex)
>-			prev->gs = 0;
>-	}
>-	if (next->gs)
>-		wrmsrl(MSR_KERNEL_GS_BASE, next->gs);
>-	prev->gsindex = gsindex;
>+	switch_segment(prev, next, fsindex, fs, MSR_FS_BASE);
>+	switch_segment(prev, next, gsindex, gs, MSR_KERNEL_GS_BASE);
> 
> 	switch_fpu_finish(next_p, fpu);
> 

-- 
Sent from my mobile phone. Please excuse brevity and lack of formatting.

  reply	other threads:[~2013-05-13  6:03 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-05-13  5:14 Joe Damato
2013-05-13  6:03 ` H. Peter Anvin [this message]
2013-05-13  7:26   ` Joe Damato
2013-05-13  7:20 ` [PATCH v2] " Joe Damato
2013-05-13 16:31 ` [PATCH] " Guenter Roeck
2013-05-13 17:30   ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e3016dd4-99f5-4d32-a802-d4d03bcf470f@email.android.com \
    --to=hpa@zytor.com \
    --cc=akpm@linux-foundation.org \
    --cc=ice799@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome