From: David Laight <David.Laight@ACULAB.COM>
To: 'Yang Guang' <davidcomponentone@gmail.com>,
"anton.ivanov@cambridgegreys.com"
<anton.ivanov@cambridgegreys.com>
Cc: "jdike@addtoit.com" <jdike@addtoit.com>,
"johannes.berg@intel.com" <johannes.berg@intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-um@lists.infradead.org" <linux-um@lists.infradead.org>,
"richard@nod.at" <richard@nod.at>,
"yang.guang5@zte.com.cn" <yang.guang5@zte.com.cn>,
"zealci@zte.com.cn" <zealci@zte.com.cn>
Subject: RE: [PATCH v2] um: use swap() to make code cleaner
Date: Fri, 5 Nov 2021 11:30:40 +0000 [thread overview]
Message-ID: <e392bf23c3ae4b93b1ffb23e40728873@AcuMS.aculab.com> (raw)
In-Reply-To: <80d5d60030f9f4c0d299e139597f67c562f1d6b2.1636092427.git.yang.guang5@zte.com.cn>
From: Yang Guang
> Sent: 05 November 2021 06:19
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
Is there any real point to any of these patches??
If I'm reading a 'random' piece of code I now have to assume
that swap() is something that 'magically' exchanges two items.
This requires more brain-power than parsing the three lines
that do an actual swap.
David
-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
prev parent reply other threads:[~2021-11-05 11:30 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-11-04 6:16 [PATCH] " davidcomponentone
2021-11-04 11:10 ` kernel test robot
2021-11-04 14:11 ` Anton Ivanov
2021-11-05 6:12 ` [PATCH v2] " davidcomponentone
2021-11-05 6:18 ` Yang Guang
2021-11-05 11:30 ` David Laight [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e392bf23c3ae4b93b1ffb23e40728873@AcuMS.aculab.com \
--to=david.laight@aculab.com \
--cc=anton.ivanov@cambridgegreys.com \
--cc=davidcomponentone@gmail.com \
--cc=jdike@addtoit.com \
--cc=johannes.berg@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-um@lists.infradead.org \
--cc=richard@nod.at \
--cc=yang.guang5@zte.com.cn \
--cc=zealci@zte.com.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®