mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Maxime Chevallier <maxime.chevallier@bootlin.com>
To: Andrew Lunn <andrew@lunn.ch>
Cc: davem@davemloft.net, "Jakub Kicinski" <kuba@kernel.org>,
	"Eric Dumazet" <edumazet@google.com>,
	"Paolo Abeni" <pabeni@redhat.com>,
	"Russell King" <linux@armlinux.org.uk>,
	"Heiner Kallweit" <hkallweit1@gmail.com>,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
	thomas.petazzoni@bootlin.com,
	"Christophe Leroy" <christophe.leroy@csgroup.eu>,
	"Herve Codina" <herve.codina@bootlin.com>,
	"Florian Fainelli" <f.fainelli@gmail.com>,
	"Vladimir Oltean" <vladimir.oltean@nxp.com>,
	"Köry Maincent" <kory.maincent@bootlin.com>,
	"Marek Behún" <kabel@kernel.org>,
	"Oleksij Rempel" <o.rempel@pengutronix.de>,
	"Nicolò Veronese" <nicveronese@gmail.com>,
	"Simon Horman" <horms@kernel.org>,
	mwojtas@chromium.org,
	"Romain Gantois" <romain.gantois@bootlin.com>,
	"Daniel Golle" <daniel@makrotopia.org>,
	"Dimitri Fedrau" <dimitri.fedrau@liebherr.com>
Subject: Re: [PATCH net-next v9 04/10] net: phy: Create SFP phy_port before registering upstream
Date: Wed, 15 Apr 2026 09:19:45 +0200	[thread overview]
Message-ID: <e4f6503c-6514-46f1-bf4f-a38c12903c16@bootlin.com> (raw)
In-Reply-To: <2bdd6224-6acf-49db-955a-5552e64d4b73@lunn.ch>

Hi Andrew,

On 15/04/2026 01:46, Andrew Lunn wrote:
> On Fri, Apr 03, 2026 at 02:37:48PM +0200, Maxime Chevallier wrote:
>> When dealing with PHY-driven SFP, we create a phy_port representing the
>> SFP bus when we know we have such a bus.
> 
> I'm missing the big picture here.
> 
> Do we have three different things represented in the topology:
> 
> SFP bus-> SFP cage-> SFP module
> 
> 	Andrew

Ah by bad, this is a wording issue, this is the port for the cage indeed.

The model I ended-up with is to represent the SFP cage itself as a PHY
port, but I've been calling that the "sfp bus port" in the code so far :/

Let me try to summarize the phy_port usage, especially with SFP :


         phylink->sfp_bus_port (should be renamed sfp_cage_port)
          vacant = true
              |
              v
+-----+   +----------+
| MAC | - | SFP cage |
+-----+   +----------+


           phylink->sfp_bus_port, vacant = false
                |
                |             phylink->mod_port
                v                v
+-----+     +----------+     +------------+
| MAC | --- | SFP cage | --- | SFP Module |
+-----+     +----------+     +------------+


                    one of phydev->ports
                           v
+-----+     +-----+     +------+
| MAC | --- | PHY | --- | RJ45 |
+-----+     +-----+     +------+


                      one of phydev->ports
                             v
                          +------+
+-----+     +-----+   /-- | RJ45 |
| MAC | --- | PHY | -+    +------+
+-----+     |     | -+    +----------+
            +-----+   \-- | SFP Cage |
                          +----------+
                             ^
                      phydev->sfp_bus_port +
                   is also in phydev->ports
                     port->vacant = true


                      one of phydev->ports
                             v
                          +------+
+-----+     +-----+   /-- | RJ45 |         phydev->mod_port
| MAC | --- | PHY | -+    +------+              v
+-----+     |     | -+    +----------+     +------------+
            +-----+   \-- | SFP Cage | --- | SFP Module |
                          +----------+     +------------+
                             ^
                      phydev->sfp_bus_port +
                   is also in phydev->ports
                     port->vacant = false


I should probably add that at least in the cover. Does it clarify the
picture a little bit ?

Thanks a lot for the reviews :)

Maxime

  reply	other threads:[~2026-04-15  7:19 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-04-03 12:37 [PATCH net-next v9 00/10] net: phy_port: SFP modules representation and phy_port listing Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 01/10] net: phy: phy_link_topology: Add a helper for opportunistic alloc Maxime Chevallier
2026-04-14 23:23   ` Andrew Lunn
2026-04-14 23:28   ` Andrew Lunn
2026-04-03 12:37 ` [PATCH net-next v9 02/10] net: phy: phy_link_topology: Track ports in phy_link_topology Maxime Chevallier
2026-04-14 23:31   ` Andrew Lunn
2026-04-03 12:37 ` [PATCH net-next v9 03/10] net: phylink: Register a phy_port for MAC-driven SFP busses Maxime Chevallier
2026-04-14 23:38   ` Andrew Lunn
2026-05-13 12:49     ` Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 04/10] net: phy: Create SFP phy_port before registering upstream Maxime Chevallier
2026-04-14 23:46   ` Andrew Lunn
2026-04-15  7:19     ` Maxime Chevallier [this message]
2026-04-16  0:59       ` Andrew Lunn
2026-04-03 12:37 ` [PATCH net-next v9 05/10] net: phy: Represent PHY-less SFP modules with phy_port Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 06/10] net: phylink: " Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 07/10] net: phy: phy_port: Store information about a MII port's vacant state Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 08/10] net: phy: phy_link_topology: Add a helper to retrieve ports Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 09/10] netlink: specs: Add ethernet port listing with ethtool Maxime Chevallier
2026-04-03 12:37 ` [PATCH net-next v9 10/10] net: ethtool: Introduce ethtool command to list ports Maxime Chevallier
2026-04-09  7:35 ` [PATCH net-next v9 00/10] net: phy_port: SFP modules representation and phy_port listing Paolo Abeni
2026-04-09  8:40   ` Maxime Chevallier
2026-04-12 21:27     ` Jakub Kicinski
2026-04-13  0:29       ` Russell King (Oracle)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e4f6503c-6514-46f1-bf4f-a38c12903c16@bootlin.com \
    --to=maxime.chevallier@bootlin.com \
    --cc=andrew@lunn.ch \
    --cc=christophe.leroy@csgroup.eu \
    --cc=daniel@makrotopia.org \
    --cc=davem@davemloft.net \
    --cc=dimitri.fedrau@liebherr.com \
    --cc=edumazet@google.com \
    --cc=f.fainelli@gmail.com \
    --cc=herve.codina@bootlin.com \
    --cc=hkallweit1@gmail.com \
    --cc=horms@kernel.org \
    --cc=kabel@kernel.org \
    --cc=kory.maincent@bootlin.com \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=mwojtas@chromium.org \
    --cc=netdev@vger.kernel.org \
    --cc=nicveronese@gmail.com \
    --cc=o.rempel@pengutronix.de \
    --cc=pabeni@redhat.com \
    --cc=romain.gantois@bootlin.com \
    --cc=thomas.petazzoni@bootlin.com \
    --cc=vladimir.oltean@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®