From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_PASS,URIBL_BLOCKED autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 1B46FC64EB8 for ; Tue, 9 Oct 2018 16:34:31 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 98D07214C5 for ; Tue, 9 Oct 2018 16:34:30 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 98D07214C5 Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=arm.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-kernel-owner@vger.kernel.org Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726700AbeJIXwP (ORCPT ); Tue, 9 Oct 2018 19:52:15 -0400 Received: from usa-sjc-mx-foss1.foss.arm.com ([217.140.101.70]:41334 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726481AbeJIXwP (ORCPT ); Tue, 9 Oct 2018 19:52:15 -0400 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.72.51.249]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 493BA7A9; Tue, 9 Oct 2018 09:34:28 -0700 (PDT) Received: from [10.1.196.93] (en101.cambridge.arm.com [10.1.196.93]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 878613F5D3; Tue, 9 Oct 2018 09:34:26 -0700 (PDT) Subject: Re: [PATCH v2 1/2] arm/arm64: KVM: rename function kvm_arch_dev_ioctl_check_extension() To: Dongjiu Geng , christoffer.dall@arm.com, marc.zyngier@arm.com, peter.maydell@linaro.org, drjones@redhat.com, james.morse@arm.com, linux-arm-kernel@lists.infradead.org, kvmarm@lists.cs.columbia.edu, linux-kernel@vger.kernel.org, kvm@vger.kernel.org References: <1539002088-21215-1-git-send-email-gengdongjiu@huawei.com> <1539002088-21215-2-git-send-email-gengdongjiu@huawei.com> From: Suzuki K Poulose Message-ID: Date: Tue, 9 Oct 2018 17:34:24 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1 MIME-Version: 1.0 In-Reply-To: <1539002088-21215-2-git-send-email-gengdongjiu@huawei.com> Content-Type: text/plain; charset=utf-8; format=flowed Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, On 08/10/18 13:34, Dongjiu Geng wrote: > Rename kvm_arch_dev_ioctl_check_extension() to > kvm_arch_vm_ioctl_check_extension(), because it does > not have any relationship with device. > > Renaming this function can make code readable. +1. The current name is not really intuitive. > > Cc: James Morse > Signed-off-by: Dongjiu Geng Reviewed-by: Suzuki K Poulose