From: Baokun Li <libaokun1@huawei.com>
To: Jan Kara <jack@suse.cz>
Cc: <linux-ext4@vger.kernel.org>, <tytso@mit.edu>,
<adilger.kernel@dilger.ca>, <ritesh.list@gmail.com>,
<linux-kernel@vger.kernel.org>, <yi.zhang@huawei.com>,
<yangerkun@huawei.com>, <chengzhihao1@huawei.com>,
<yukuai3@huawei.com>, Baokun Li <libaokun1@huawei.com>
Subject: Re: [PATCH 7/7] ext4: set the type of max_zeroout to unsigned int to avoid overflow
Date: Sat, 17 Feb 2024 15:45:13 +0800 [thread overview]
Message-ID: <e867978a-f64f-fe32-2671-aeaa34e75b0e@huawei.com> (raw)
In-Reply-To: <20240213163807.lodqvvw24namiu7g@quack3>
On 2024/2/14 0:38, Jan Kara wrote:
> On Fri 26-01-24 16:57:16, Baokun Li wrote:
>> The max_zeroout is of type int and the s_extent_max_zeroout_kb is of
>> type uint, and the s_extent_max_zeroout_kb can be freely modified via
>> the sysfs interface. When the block size is 1024, max_zeroout may
>> overflow, so declare it as unsigned int to avoid overflow.
>>
>> Signed-off-by: Baokun Li <libaokun1@huawei.com>
>> ---
>> fs/ext4/extents.c | 6 ++----
>> 1 file changed, 2 insertions(+), 4 deletions(-)
>>
>> diff --git a/fs/ext4/extents.c b/fs/ext4/extents.c
>> index 01299b55a567..8653b13e8248 100644
>> --- a/fs/ext4/extents.c
>> +++ b/fs/ext4/extents.c
>> @@ -3425,10 +3425,8 @@ static int ext4_ext_convert_to_initialized(handle_t *handle,
>> struct ext4_extent zero_ex1, zero_ex2;
>> struct ext4_extent *ex, *abut_ex;
>> ext4_lblk_t ee_block, eof_block;
>> - unsigned int ee_len, depth, map_len = map->m_len;
>> - int allocated = 0, max_zeroout = 0;
>> - int err = 0;
>> - int split_flag = EXT4_EXT_DATA_VALID2;
>> + unsigned int ee_len, depth, map_len = map->m_len, max_zeroout = 0;
>> + int err = 0, allocated = 0, split_flag = EXT4_EXT_DATA_VALID2;
> Honestly, I prefer if we keep unrelated variables on different lines,
> especially when they have initializers. I find the code more readable that
> way. So in this case:
>
> int err = 0;
> int split_flag = EXT4_EXT_DATA_VALID2;
> int allocated = 0;
> unsigned int max_zeroout = 0;
>
> But otherwise the fix looks good!
>
> Honza
Totally agree! I will replace it in the next version.
Thanks!
--
With Best Regards,
Baokun Li
.
prev parent reply other threads:[~2024-02-17 7:45 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-01-26 8:57 [PATCH 0/7] ext4: avoid sysfs variables overflow causing BUG_ON/SOOB Baokun Li
2024-01-26 8:57 ` [PATCH 1/7] ext4: avoid overflow when setting values via sysfs Baokun Li
2024-01-26 9:28 ` Zhang Yi
2024-02-13 16:05 ` Jan Kara
2024-02-17 7:09 ` Baokun Li
2024-02-23 11:54 ` Jan Kara
2024-02-24 1:59 ` Baokun Li
2024-01-26 8:57 ` [PATCH 2/7] ext4: refactor out ext4_generic_attr_store() Baokun Li
2024-01-26 9:37 ` Zhang Yi
2024-02-13 16:47 ` Jan Kara
2024-01-26 8:57 ` [PATCH 3/7] ext4: refactor out ext4_generic_attr_show() Baokun Li
2024-01-26 10:08 ` Zhang Yi
2024-02-13 16:44 ` Jan Kara
2024-01-26 8:57 ` [PATCH 4/7] ext4: add positive int attr pointer to avoid sysfs variables overflow Baokun Li
2024-01-27 2:07 ` Zhang Yi
2024-02-13 16:58 ` Jan Kara
2024-02-17 7:41 ` Baokun Li
2024-02-23 12:05 ` Jan Kara
2024-02-24 2:46 ` Baokun Li
2024-01-26 8:57 ` [PATCH 5/7] ext4: fix slab-out-of-bounds in ext4_mb_find_good_group_avg_frag_lists() Baokun Li
2024-01-27 2:09 ` Zhang Yi
2024-02-13 16:14 ` Jan Kara
2024-02-20 5:39 ` Ojaswin Mujoo
2024-02-20 6:31 ` Baokun Li
2024-01-26 8:57 ` [PATCH 6/7] ext4: set type of ac_groups_linear_remaining to __u32 to avoid overflow Baokun Li
2024-01-27 2:10 ` Zhang Yi
2024-02-13 16:15 ` Jan Kara
2024-01-26 8:57 ` [PATCH 7/7] ext4: set the type of max_zeroout to unsigned int " Baokun Li
2024-01-27 2:12 ` Zhang Yi
2024-02-13 16:38 ` Jan Kara
2024-02-17 7:45 ` Baokun Li [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e867978a-f64f-fe32-2671-aeaa34e75b0e@huawei.com \
--to=libaokun1@huawei.com \
--cc=adilger.kernel@dilger.ca \
--cc=chengzhihao1@huawei.com \
--cc=jack@suse.cz \
--cc=linux-ext4@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ritesh.list@gmail.com \
--cc=tytso@mit.edu \
--cc=yangerkun@huawei.com \
--cc=yi.zhang@huawei.com \
--cc=yukuai3@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®