From: Atish Patra <atishp@rivosinc.com>
To: Andrew Jones <ajones@ventanamicro.com>
Cc: linux-kernel@vger.kernel.org,
Palmer Dabbelt <palmer@rivosinc.com>,
Conor Dooley <conor.dooley@microchip.com>,
Anup Patel <anup@brainfault.org>, Ajay Kaher <akaher@vmware.com>,
Alexandre Ghiti <alexghiti@rivosinc.com>,
Alexey Makhalov <amakhalov@vmware.com>,
Juergen Gross <jgross@suse.com>,
kvm-riscv@lists.infradead.org, kvm@vger.kernel.org,
linux-kselftest@vger.kernel.org, linux-riscv@lists.infradead.org,
Mark Rutland <mark.rutland@arm.com>,
Palmer Dabbelt <palmer@dabbelt.com>,
Paolo Bonzini <pbonzini@redhat.com>,
Paul Walmsley <paul.walmsley@sifive.com>,
Shuah Khan <shuah@kernel.org>,
virtualization@lists.linux.dev,
VMware PV-Drivers Reviewers <pv-drivers@vmware.com>,
Will Deacon <will@kernel.org>,
x86@kernel.org
Subject: Re: [PATCH v5 03/22] drivers/perf: riscv: Read upper bits of a firmware counter
Date: Mon, 8 Apr 2024 17:04:41 -0700 [thread overview]
Message-ID: <e95f9821-e83c-4abb-941d-60ce24b9c0a3@rivosinc.com> (raw)
In-Reply-To: <20240404-89ee7d7f90a5fcc91809065e@orel>
On 4/4/24 04:02, Andrew Jones wrote:
> On Wed, Apr 03, 2024 at 01:04:32AM -0700, Atish Patra wrote:
>> SBI v2.0 introduced a explicit function to read the upper 32 bits
>> for any firmware counter width that is longer than 32bits.
>> This is only applicable for RV32 where firmware counter can be
>> 64 bit.
>>
>> Reviewed-by: Andrew Jones <ajones@ventanamicro.com>
>> Acked-by: Palmer Dabbelt <palmer@rivosinc.com>
>> Reviewed-by: Conor Dooley <conor.dooley@microchip.com>
>> Reviewed-by: Anup Patel <anup@brainfault.org>
>> Signed-off-by: Atish Patra <atishp@rivosinc.com>
>> ---
>> drivers/perf/riscv_pmu_sbi.c | 25 ++++++++++++++++++++-----
>> 1 file changed, 20 insertions(+), 5 deletions(-)
>>
>> diff --git a/drivers/perf/riscv_pmu_sbi.c b/drivers/perf/riscv_pmu_sbi.c
>> index 3e44d2fb8bf8..babf1b9a4dbe 100644
>> --- a/drivers/perf/riscv_pmu_sbi.c
>> +++ b/drivers/perf/riscv_pmu_sbi.c
>> @@ -57,6 +57,8 @@ asm volatile(ALTERNATIVE( \
>> PMU_FORMAT_ATTR(event, "config:0-47");
>> PMU_FORMAT_ATTR(firmware, "config:63");
>>
>> +static bool sbi_v2_available;
>> +
>> static struct attribute *riscv_arch_formats_attr[] = {
>> &format_attr_event.attr,
>> &format_attr_firmware.attr,
>> @@ -511,19 +513,29 @@ static u64 pmu_sbi_ctr_read(struct perf_event *event)
>> struct hw_perf_event *hwc = &event->hw;
>> int idx = hwc->idx;
>> struct sbiret ret;
>> - union sbi_pmu_ctr_info info;
>> u64 val = 0;
>> + union sbi_pmu_ctr_info info = pmu_ctr_list[idx];
>>
>> if (pmu_sbi_is_fw_event(event)) {
>> ret = sbi_ecall(SBI_EXT_PMU, SBI_EXT_PMU_COUNTER_FW_READ,
>> hwc->idx, 0, 0, 0, 0, 0);
>> - if (!ret.error)
>> - val = ret.value;
>> + if (ret.error)
>> + return 0;
>> +
>> + val = ret.value;
>> + if (IS_ENABLED(CONFIG_32BIT) && sbi_v2_available && info.width >= 32) {
>> + ret = sbi_ecall(SBI_EXT_PMU, SBI_EXT_PMU_COUNTER_FW_READ_HI,
>> + hwc->idx, 0, 0, 0, 0, 0);
>> + if (!ret.error)
>> + val |= ((u64)ret.value << 32);
>> + else
>> + WARN_ONCE(1, "Unable to read upper 32 bits of firmware counter error: %d\n",
>> + sbi_err_map_linux_errno(ret.error));
>
> I don't think we should use sbi_err_map_linux_errno() in this case since
> we don't have a 1:1 mapping of SBI errors to Linux errors and we don't
> propagate the error as a Linux error. For warnings, it's better to output
> the exact SBI error.
>
Sure. Fixed it.
>> + }
>> } else {
>> - info = pmu_ctr_list[idx];
>> val = riscv_pmu_ctr_read_csr(info.csr);
>> if (IS_ENABLED(CONFIG_32BIT))
>> - val = ((u64)riscv_pmu_ctr_read_csr(info.csr + 0x80)) << 31 | val;
>> + val |= ((u64)riscv_pmu_ctr_read_csr(info.csr + 0x80)) << 32;
>> }
>>
>> return val;
>> @@ -1135,6 +1147,9 @@ static int __init pmu_sbi_devinit(void)
>> return 0;
>> }
>>
>> + if (sbi_spec_version >= sbi_mk_version(2, 0))
>> + sbi_v2_available = true;
>> +
>> ret = cpuhp_setup_state_multi(CPUHP_AP_PERF_RISCV_STARTING,
>> "perf/riscv/pmu:starting",
>> pmu_sbi_starting_cpu, pmu_sbi_dying_cpu);
>> --
>> 2.34.1
>>
>
> Thanks,
> drew
next prev parent reply other threads:[~2024-04-09 0:04 UTC|newest]
Thread overview: 59+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-03 8:04 [PATCH v5 00/22] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest Atish Patra
2024-04-03 8:04 ` [PATCH v5 01/22] RISC-V: Fix the typo in Scountovf CSR name Atish Patra
2024-04-04 10:56 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 02/22] RISC-V: Add FIRMWARE_READ_HI definition Atish Patra
2024-04-04 10:57 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 03/22] drivers/perf: riscv: Read upper bits of a firmware counter Atish Patra
2024-04-04 11:02 ` Andrew Jones
2024-04-09 0:04 ` Atish Patra [this message]
2024-04-03 8:04 ` [PATCH v5 04/22] drivers/perf: riscv: Use BIT macro for shifting operations Atish Patra
2024-04-03 15:57 ` unsubscribe jonathan.oleson
2024-04-04 11:08 ` [PATCH v5 04/22] drivers/perf: riscv: Use BIT macro for shifting operations Andrew Jones
2024-04-09 0:20 ` Atish Patra
2024-04-03 8:04 ` [PATCH v5 05/22] RISC-V: Add SBI PMU snapshot definitions Atish Patra
2024-04-04 11:14 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 06/22] drivers/perf: riscv: Implement SBI PMU snapshot function Atish Patra
2024-04-04 11:52 ` Andrew Jones
2024-04-10 22:29 ` Atish Patra
2024-04-11 7:45 ` Andrew Jones
2024-04-04 12:01 ` Andrew Jones
2024-04-09 0:21 ` Atish Patra
2024-04-03 8:04 ` [PATCH v5 07/22] drivers/perf: riscv: Fix counter mask iteration for RV32 Atish Patra
2024-04-04 11:55 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 08/22] RISC-V: KVM: Fix the initial sample period value Atish Patra
2024-04-04 11:57 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 09/22] RISC-V: KVM: Rename the SBI_STA_SHMEM_DISABLE to a generic name Atish Patra
2024-04-04 11:59 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 10/22] RISC-V: KVM: No need to update the counter value during reset Atish Patra
2024-04-03 8:04 ` [PATCH v5 11/22] RISC-V: KVM: No need to exit to the user space if perf event failed Atish Patra
2024-04-04 12:19 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 12/22] RISC-V: KVM: Implement SBI PMU Snapshot feature Atish Patra
2024-04-05 11:23 ` Andrew Jones
2024-04-09 0:33 ` Atish Patra
2024-04-03 8:04 ` [PATCH v5 13/22] RISC-V: KVM: Add perf sampling support for guests Atish Patra
2024-04-05 11:36 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 14/22] RISC-V: KVM: Support 64 bit firmware counters on RV32 Atish Patra
2024-04-05 12:10 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 15/22] RISC-V: KVM: Improve firmware counter read function Atish Patra
2024-04-05 12:12 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 16/22] KVM: riscv: selftests: Move sbi definitions to its own header file Atish Patra
2024-04-05 12:16 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 17/22] KVM: riscv: selftests: Add helper functions for extension checks Atish Patra
2024-04-05 12:17 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 18/22] KVM: riscv: selftests: Add Sscofpmf to get-reg-list test Atish Patra
2024-04-03 8:04 ` [PATCH v5 19/22] KVM: riscv: selftests: Add SBI PMU extension definitions Atish Patra
2024-04-05 12:20 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 20/22] KVM: riscv: selftests: Add SBI PMU selftest Atish Patra
2024-04-05 12:50 ` Andrew Jones
2024-04-09 0:37 ` Atish Patra
2024-04-09 8:01 ` Andrew Jones
2024-04-09 22:11 ` Atish Kumar Patra
2024-04-03 8:04 ` [PATCH v5 21/22] KVM: riscv: selftests: Add a test for PMU snapshot functionality Atish Patra
2024-04-05 13:11 ` Andrew Jones
2024-04-09 22:52 ` Atish Patra
2024-04-10 7:10 ` Andrew Jones
2024-04-10 7:28 ` Atish Patra
2024-04-10 7:54 ` Andrew Jones
2024-04-03 8:04 ` [PATCH v5 22/22] KVM: riscv: selftests: Add a test for counter overflow Atish Patra
2024-04-05 13:23 ` Andrew Jones
2024-04-09 23:47 ` Atish Patra
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e95f9821-e83c-4abb-941d-60ce24b9c0a3@rivosinc.com \
--to=atishp@rivosinc.com \
--cc=ajones@ventanamicro.com \
--cc=akaher@vmware.com \
--cc=alexghiti@rivosinc.com \
--cc=amakhalov@vmware.com \
--cc=anup@brainfault.org \
--cc=conor.dooley@microchip.com \
--cc=jgross@suse.com \
--cc=kvm-riscv@lists.infradead.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=linux-riscv@lists.infradead.org \
--cc=mark.rutland@arm.com \
--cc=palmer@dabbelt.com \
--cc=palmer@rivosinc.com \
--cc=paul.walmsley@sifive.com \
--cc=pbonzini@redhat.com \
--cc=pv-drivers@vmware.com \
--cc=shuah@kernel.org \
--cc=virtualization@lists.linux.dev \
--cc=will@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®