From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from bali.collaboradmins.com (bali.collaboradmins.com [148.251.105.195]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 2E93E39A06A for ; Wed, 22 Jul 2026 12:04:03 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=148.251.105.195 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784721845; cv=none; b=uW6S1Uu+DZc9xoJkNo7UHKEDiRx8LReWDsCwfsRWpzDKR38vBdGixxDrGPwqt2W381ndc6VcVettkt0EZ9EDXIFMytdvdjxlH3zQ3XpgNa4kcO8Ul6ZOGxz5X8rDhNGvttuhezI6iN1Sg3C77nfvb6buseemeOTGYVtTT3QhI3s= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784721845; c=relaxed/simple; bh=nT5fhfe0RjpKLPARR0Tl+dL4OT3X73lgOHZYHu6f+mw=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=VeqB3MTJWoGfn1UopaxzB59ZzWehWiwgrYdV7+bz9zh7oUj2Auy2m7qitLxip8oE+zw/kiQl9yW4PFi3R5NDonyi8liO2is8ZFDEfNezJrAlui4/kKBxMpvMulvp+L35agWuQFN25AL43+mwLe6gqAQj1BxRomXmuFmu2EYAQQg= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=collabora.com; spf=pass smtp.mailfrom=collabora.com; dkim=pass (2048-bit key) header.d=collabora.com header.i=@collabora.com header.b=PprzGMQa; arc=none smtp.client-ip=148.251.105.195 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=collabora.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=collabora.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=collabora.com header.i=@collabora.com header.b="PprzGMQa" DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=collabora.com; s=mail; t=1784721841; bh=nT5fhfe0RjpKLPARR0Tl+dL4OT3X73lgOHZYHu6f+mw=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=PprzGMQaFXJUVMwPQkPXQHAiPVbKz3LOn4qKLnJmY8OrCbRFd42vtdjk/B9vyLvWA myCJDoKBYamluY6wyoPRQ/tl3ZP2nhdNbe5sevWvL/1FNj4LNsjsAFeehejfZ017EW gi10rCB68SWwhRspltcFpYZKKekEJidrd8fha57hN7gAiEU3yAG+J1zcfAf7Tsrnh1 5MspXjEIQnEtbFQvIG+99ypL5mNRHEXLKWh2cVYW7Jcgkgq3suTrtLA5dZKmDtIHG6 rubOsesOTnpSC/0E5YUHRMkOVCQ5ILp8G+oUPcZxZHbI6V8dG/mDpcCn7b5qtSJ5yR Uq/jSCW4cuTQQ== Received: from [100.64.0.241] (unknown [100.64.0.241]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange x25519) (No client certificate requested) (Authenticated sender: cristicc) by bali.collaboradmins.com (Postfix) with ESMTPSA id D238717E062C; Wed, 22 Jul 2026 14:04:00 +0200 (CEST) Message-ID: Date: Wed, 22 Jul 2026 15:04:00 +0300 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v8 03/39] drm/display: bridge_connector: Pass HDMI capabilities through caps struct To: Dmitry Baryshkov Cc: Maxime Ripard , Maarten Lankhorst , Thomas Zimmermann , David Airlie , Simona Vetter , Andrzej Hajda , Neil Armstrong , Robert Foss , Laurent Pinchart , Jonas Karlman , Jernej Skrabec , Luca Ceresoli , Sandy Huang , =?UTF-8?Q?Heiko_St=C3=BCbner?= , Andy Yan , Daniel Stone , Dave Stevenson , =?UTF-8?Q?Ma=C3=ADra_Canal?= , Raspberry Pi Kernel Maintenance , kernel@collabora.com, dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-rockchip@lists.infradead.org References: <20260702-dw-hdmi-qp-scramb-v8-0-d79890d00b6a@collabora.com> <20260702-dw-hdmi-qp-scramb-v8-3-d79890d00b6a@collabora.com> <20260708-bold-ruby-potoo-c6c949@houat> Content-Language: en-US From: Cristian Ciocaltea In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 7/22/26 9:47 AM, Dmitry Baryshkov wrote: > On Wed, Jul 08, 2026 at 01:19:23PM +0300, Cristian Ciocaltea wrote: >> On 7/8/26 9:46 AM, Maxime Ripard wrote: >>> On Fri, Jul 03, 2026 at 10:55:09PM +0300, Cristian Ciocaltea wrote: >>>> On 7/3/26 5:19 PM, Dmitry Baryshkov wrote: >>>>> On Thu, Jul 02, 2026 at 05:46:16PM +0300, Cristian Ciocaltea wrote: >>>>>> Switch drm_bridge_connector_init() to >>>>>> drmm_connector_hdmi_init_with_caps(), collecting the bridge's HDMI >>>>>> properties into a stack drm_connector_hdmi_caps so future HDMI 2.x >>>>>> capabilities can be plumbed without growing the argument list. >>>>>> >>>>>> Introduce struct drm_bridge::supported_hdmi_ver to let bridges declare >>>>>> the HDMI specification version they are conformant with, and forward it >>>>>> to the connector layer through the new caps struct so HDMI 2.x features >>>>>> can be gated on real source capability rather than guesswork. >>>>> >>>>> And it's left uninitialized by the bridges, which doesn't mean anything. >>>>> If you don't want to touch all bridge drivers in one commit, please >>>>> provide some migration path and hopefully get rid of it by the end of >>>>> the series. >>>> >>>> Sure, one question though: at the end of the migration, would it be fine to >>>> stick with drmm_connector_hdmi_init_with_caps() and just drop >>>> drmm_connector_hdmi_init()? Otherwise I'll rename it back. >>> >>> Absolutely, it doesn't make any sense to keep both variants. >> >> I was referring to whether option 3 might be the preferred choice in the context >> of the earlier patch discussion. > > Plesae exuse my ignorance, what is option 3? The options discussed were: 1. Continue with drmm_connector_hdmi_init_with_caps() after removing the caps parameter, and then drop drmm_connector_hdmi_init() after the migration. ... 3. A variation of option 1: additionally rename drmm_connector_hdmi_init_with_caps() to drmm_connector_hdmi_init() after the migration. In the end I went with a slightly different approach: temporarily renamed the original helper to drmm_connector_hdmi_ini2(), to let the new signature be introduced under the original name while callers were converted incrementally. Finally added a patch to remove *_ini2(). Note the transitional name had the same length, to avoid re-alignment churn and keep the diffs to a minimum. Cristian