From: Baolin Wang <baolin.wang@linux.alibaba.com>
To: Barry Song <baohua@kernel.org>
Cc: akpm@linux-foundation.org, linux-mm@kvack.org,
axelrasmussen@google.com, david@kernel.org, hannes@cmpxchg.org,
kasong@tencent.com, linux-kernel@vger.kernel.org, ljs@kernel.org,
lyugaofei@xiaomi.com, mhocko@kernel.org, qi.zheng@linux.dev,
shakeel.butt@linux.dev, stevensd@chromium.org,
weixugc@google.com, yuanchu@google.com, chenridong@xiaomi.com,
zhangbo56@xiaomi.com, wangzicheng@honor.com, lianux.mm@gmail.com
Subject: Re: [RFC PATCH v3 3/6] mm/mglru: improve readability of isolate_folios()
Date: Mon, 3 Aug 2026 13:33:44 +0800 [thread overview]
Message-ID: <e9ad4f78-b4c6-42a7-a746-069739db00b8@linux.alibaba.com> (raw)
In-Reply-To: <CAGsJ_4yxJyOaNTfVWxeTH0PVED0fgExOod4ay3pRVYjFcf+BZg@mail.gmail.com>
On 8/3/26 12:46 PM, Barry Song wrote:
> On Mon, Aug 3, 2026 at 11:22 AM Baolin Wang
> <baolin.wang@linux.alibaba.com> wrote:
>>
>>
>>
>> On 7/31/26 4:38 PM, Barry Song (Xiaomi) wrote:
>>> From: Ridong Chen <chenridong@xiaomi.com>
>>>
>>> The for_each_evictable_type() loop in isolate_folios()
>>> is misleading: it does not actually iterate over each
>>> evictable type. Instead, get_type_to_scan() selects the
>>> type to scan, while the iterator `i` merely bounds the
>>> number of attempts.
>>>
>>> Signed-off-by: Ridong Chen <chenridong@xiaomi.com>
>>> Co-developed-by: Barry Song (Xiaomi) <baohua@kernel.org>
>>> Signed-off-by: Barry Song (Xiaomi) <baohua@kernel.org>
>>> ---
>>
>> Good cleanup. Some comments below.
>>
>>> mm/vmscan.c | 47 +++++++++++++++++++++++++++--------------------
>>> 1 file changed, 27 insertions(+), 20 deletions(-)
>>>
>>> diff --git a/mm/vmscan.c b/mm/vmscan.c
>>> index 31947fa60f18..0038f33aa318 100644
>>> --- a/mm/vmscan.c
>>> +++ b/mm/vmscan.c
>>> @@ -4828,35 +4828,42 @@ static int get_type_to_scan(struct lruvec *lruvec, int swappiness)
>>> return positive_ctrl_err(&sp, &pv);
>>> }
>>>
>>> +static inline bool is_single_type_reclaim(int swappiness)
>>> +{
>>> + return swappiness == MIN_SWAPPINESS ||
>>> + swappiness == SWAPPINESS_ANON_ONLY;
>>> +}
>>> +
>>> static int isolate_folios(unsigned long nr_to_scan, struct lruvec *lruvec,
>>> struct scan_control *sc, int swappiness,
>>> struct list_head *list, int *isolated,
>>> int *isolate_type, int *isolate_scanned)
>>> {
>>> - int i;
>>> - int total_scanned = 0;
>>> + bool single_type = is_single_type_reclaim(swappiness);
>>> int type = get_type_to_scan(lruvec, swappiness);
>>> + int total_scanned = 0, scanned, tier;
>>> + bool tried = false;
>>
>> The tried' is a bit confusing. How about 'type_fallback_allowed'? Or
>> other more readable variable name?
>>
>> In addition, the 'single_type' variable can be removed, and just
>> initialize 'type_fallback_allowed' directly:
>>
>> bool type_fallback_allowed = !is_single_type_reclaim(swappiness);
>
>
> Yep. It seems we can simply use type_fallback_allowed and drop
> tried entirely:
Thanks. That's what I meant:)
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index 1ffd96c87bc2..358388b49a70 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -4840,10 +4840,9 @@ static int isolate_folios(unsigned long
> nr_to_scan, struct lruvec *lruvec,
> struct list_head *list, int *isolated,
> int *isolate_type, int *isolate_scanned)
> {
> - bool single_type = is_single_type_reclaim(swappiness);
> + bool type_fallback_allowed = !is_single_type_reclaim(swappiness);
> int type = get_type_to_scan(lruvec, swappiness);
> int total_scanned = 0, scanned, tier;
> - bool tried = false;
>
> retry:
> tier = get_tier_idx(lruvec, type);
> @@ -4861,9 +4860,9 @@ static int isolate_folios(unsigned long
> nr_to_scan, struct lruvec *lruvec,
> * We are running out of the current reclaim type. Fall back to
> * the other type if allowed.
> */
> - if (!tried && !scanned && !single_type) {
> + if (type_fallback_allowed && !scanned) {
> type = !type;
> - tried = true;
> + type_fallback_allowed = false;
> goto retry;
> }
next prev parent reply other threads:[~2026-08-03 5:33 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-31 8:38 [RFC PATCH v3 0/6] mm: mglru: fix swappiness behavior Barry Song (Xiaomi)
2026-07-31 8:38 ` [RFC PATCH v3 1/6] mm: mglru: prevent min_seq[type] from pointing to an empty generation Barry Song (Xiaomi)
2026-07-31 8:38 ` [RFC PATCH v3 2/6] mm: mglru: let scan_folios() scan both reclaimable generations Barry Song (Xiaomi)
2026-08-01 6:18 ` Barry Song
2026-07-31 8:38 ` [RFC PATCH v3 3/6] mm/mglru: improve readability of isolate_folios() Barry Song (Xiaomi)
2026-08-03 3:22 ` Baolin Wang
2026-08-03 4:46 ` Barry Song
2026-08-03 5:33 ` Baolin Wang [this message]
2026-07-31 8:38 ` [RFC PATCH v3 4/6] mm: mglru: improve scan_folios() exhaustion detection Barry Song (Xiaomi)
2026-07-31 23:33 ` Barry Song
2026-07-31 8:38 ` [RFC PATCH v3 5/6] mm: mglru: run aging when pages are severely imbalanced across gens Barry Song (Xiaomi)
2026-07-31 8:38 ` [RFC PATCH v3 6/6] mm: mglru: run aging if the preferred type has no folios in reclaimable gens Barry Song (Xiaomi)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e9ad4f78-b4c6-42a7-a746-069739db00b8@linux.alibaba.com \
--to=baolin.wang@linux.alibaba.com \
--cc=akpm@linux-foundation.org \
--cc=axelrasmussen@google.com \
--cc=baohua@kernel.org \
--cc=chenridong@xiaomi.com \
--cc=david@kernel.org \
--cc=hannes@cmpxchg.org \
--cc=kasong@tencent.com \
--cc=lianux.mm@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=lyugaofei@xiaomi.com \
--cc=mhocko@kernel.org \
--cc=qi.zheng@linux.dev \
--cc=shakeel.butt@linux.dev \
--cc=stevensd@chromium.org \
--cc=wangzicheng@honor.com \
--cc=weixugc@google.com \
--cc=yuanchu@google.com \
--cc=zhangbo56@xiaomi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®