From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 88429C433EF for ; Tue, 22 Mar 2022 17:41:35 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S239906AbiCVRm4 (ORCPT ); Tue, 22 Mar 2022 13:42:56 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:54304 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S239852AbiCVRmr (ORCPT ); Tue, 22 Mar 2022 13:42:47 -0400 Received: from foss.arm.com (foss.arm.com [217.140.110.172]) by lindbergh.monkeyblade.net (Postfix) with ESMTP id 5A2758D696; Tue, 22 Mar 2022 10:41:18 -0700 (PDT) Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 12D631042; Tue, 22 Mar 2022 10:41:18 -0700 (PDT) Received: from [10.57.43.230] (unknown [10.57.43.230]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id CE0043F66F; Tue, 22 Mar 2022 10:41:15 -0700 (PDT) Message-ID: Date: Tue, 22 Mar 2022 17:41:11 +0000 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (Windows NT 10.0; rv:91.0) Gecko/20100101 Thunderbird/91.7.0 Subject: Re: [PATCH 5/9] soc: apple: Add RTKit IPC library Content-Language: en-GB To: Arnd Bergmann , Sven Peter Cc: Hector Martin , Alyssa Rosenzweig , Rob Herring , Keith Busch , Jens Axboe , Christoph Hellwig , Sagi Grimberg , Marc Zyngier , DTML , Linux ARM , Linux Kernel Mailing List , linux-nvme@lists.infradead.org References: <20220321165049.35985-1-sven@svenpeter.dev> <20220321165049.35985-6-sven@svenpeter.dev> From: Robin Murphy In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2022-03-22 13:13, Arnd Bergmann wrote: >> +#define rtk_err(format, arg...) dev_err(rtk->dev, "RTKit: " format, ##arg) >> +#define rtk_warn(format, arg...) dev_warn(rtk->dev, "RTKit: " format, ##arg) >> +#define rtk_info(format, arg...) dev_info(rtk->dev, "RTKit: " format, ##arg) >> +#define rtk_dbg(format, arg...) dev_dbg(rtk->dev, "RTKit: " format, ##arg) > > I generally don't like the custom printing macros, please just open-code > the prints where they are used, that makes it easier for other kernel > developers to see exactly what is being printed More to the point, implicitly depending on having something named "rtk" in scope is pretty much inexcusable, and the only thing left after fixing that is what we have pr_fmt for ;) Robin.