From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1763692AbdAEWbR (ORCPT ); Thu, 5 Jan 2017 17:31:17 -0500 Received: from mail-pg0-f68.google.com ([74.125.83.68]:33217 "EHLO mail-pg0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1763521AbdAEWav (ORCPT ); Thu, 5 Jan 2017 17:30:51 -0500 Subject: Re: [PATCH v2 05/19] ARM: dts: imx6-sabresd: add OV5642 and OV5640 camera sensors To: Vladimir Zapolskiy , shawnguo@kernel.org, kernel@pengutronix.de, fabio.estevam@nxp.com, robh+dt@kernel.org, mark.rutland@arm.com, linux@armlinux.org.uk, mchehab@kernel.org, gregkh@linuxfoundation.org, p.zabel@pengutronix.de References: <1483477049-19056-1-git-send-email-steve_longerbeam@mentor.com> <1483477049-19056-6-git-send-email-steve_longerbeam@mentor.com> Cc: linux-arm-kernel@lists.infradead.org, devicetree@vger.kernel.org, linux-kernel@vger.kernel.org, linux-media@vger.kernel.org, devel@driverdev.osuosl.org, Steve Longerbeam From: Steve Longerbeam Message-ID: Date: Thu, 5 Jan 2017 14:30:49 -0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 01/04/2017 04:33 AM, Vladimir Zapolskiy wrote: > >> + >> + camera: ov5642@3c { > ov5642: camera@3c done. >> + pwdn-gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>; /* SD1_DAT0 */ >> + reset-gpios = <&gpio1 17 GPIO_ACTIVE_LOW>; /* SD1_DAT1 */ > Comments about SD1_* pad names are redundant. sure, removed. >> + status = "disabled"; > Why is it disabled here? It's explained in the header. I don't yet have the OV5642 module for the sabresd for testing, so it is disabled for now. >> + >> + mipi_camera: ov5640@3c { > ov5640: camera@3c done. > >> + pwdn-gpios = <&gpio1 19 GPIO_ACTIVE_HIGH>; /* SD1_DAT2 */ >> + reset-gpios = <&gpio1 20 GPIO_ACTIVE_LOW>; /* SD1_CLK */ > Comments about SD1_* pad names are redundant. removed. >> + >> + pinctrl_ipu1_csi0: ipu1grp-csi0 { > Please rename the node name to ipu1csi0grp. > > Please add new pin control groups preserving the alphanimerical order. done and done. Steve