From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Suren Baghdasaryan <surenb@google.com>,
"Lorenzo Stoakes (ARM)" <ljs@kernel.org>
Cc: akpm@linux-foundation.org, liam@infradead.org, vbabka@kernel.org,
willy@infradead.org, jannh@google.com, paulmck@kernel.org,
pfalcato@suse.de, xueyuan.chen21@gmail.com, linux-mm@kvack.org,
linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH v3 3/7] proc/task_mmu: clarify shmem mapping walk conditions in smap_gather_stats()
Date: Fri, 11 Sep 2026 19:52:38 +0200 [thread overview]
Message-ID: <eb040cfc-4038-4cc1-9220-c387c4c8a02e@kernel.org> (raw)
In-Reply-To: <CAJuCfpEMd=hVtwe_9Rp1kqigYJwqEUGCD+ViQmoacAZONCR6DA@mail.gmail.com>
On 9/11/26 19:39, Suren Baghdasaryan wrote:
> On Fri, Sep 11, 2026 at 10:10 AM Lorenzo Stoakes (ARM) <ljs@kernel.org> wrote:
>>
>> On Fri, Sep 11, 2026 at 04:58:40PM +0000, Suren Baghdasaryan wrote:
>>>
>>> Well, the "other" Lorenzo does not agree with you and suggested this
>>> approach in [1]. Specifically, see the comment:
>>> ```
>>> I also don't love that 0 is taken to be 'start from vma->vm_start' and I
>>> also don't love that the code in smap_gather_stats() actually special cases
>>> this...
>>
>> I'm not sure what part of this is disagreement?
>>
>> It's saying passing 0 is a hack, which is one that is still in place and which
>> this patch makes worse, because instead of explicitly calling out the invalid
>> value, you're treating it as if it were valid.
>>
>>>
>>> How about passing last_vma_end and making smap_gather_stats() more sane? In
>>> the other invocation of smap_gather_stats() we could pass vma->vm_start
>>> here.
>>
>> Yup, well me of 3 months ago should have suggested what I suggested re: wrapper
>> (I think you cut that suggestion out of my reply).
>>
>>> ```
>>>
>>> [1] https://lore.kernel.org/all/aifO_rCurVhFRTcl@lucifer/
>>
>>>
>>>
>>> See [1]. This is exactly how you wrote it at the end of that reply.
>>
>> Assuming you passed vma->vm_start, not 0? Passing 0 makes it really strange.
>
> Ah! Now I see the problem you are pointing out. Ok, in v2 [2] this was
> done correctly and that's the way you want it!
> Okay, I agree this split was incorrect. I think I'll move is_partial
> conversion completely into the next patch and this one will only
> update the comment and use vma_is_cow_mapping() instead of open-coding
> it.
Ah, that makes sense, I missed that as I was mostly focusing on the cow stuff only.
--
Cheers,
David
next prev parent reply other threads:[~2026-09-11 17:52 UTC|newest]
Thread overview: 40+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-10 23:47 [PATCH v3 0/7] read proc/pid/smaps_rollup under per-vma lock Suren Baghdasaryan
2026-09-10 23:47 ` [PATCH v3 1/7] proc/task_mmu: remove unnecessary helpers Suren Baghdasaryan
2026-09-11 10:52 ` David Hildenbrand (Arm)
2026-09-11 14:28 ` Suren Baghdasaryan
2026-09-11 14:57 ` David Hildenbrand (Arm)
2026-09-11 15:20 ` Suren Baghdasaryan
2026-09-10 23:47 ` [PATCH v3 2/7] proc/task_mmu: remove unnecessary inlines in function definitions Suren Baghdasaryan
2026-09-11 15:33 ` David Hildenbrand (Arm)
2026-09-10 23:47 ` [PATCH v3 3/7] proc/task_mmu: clarify shmem mapping walk conditions in smap_gather_stats() Suren Baghdasaryan
2026-09-11 15:33 ` David Hildenbrand (Arm)
2026-09-11 16:28 ` Lorenzo Stoakes (ARM)
2026-09-11 16:58 ` Suren Baghdasaryan
2026-09-11 17:10 ` Lorenzo Stoakes (ARM)
2026-09-11 17:39 ` Suren Baghdasaryan
2026-09-11 17:52 ` David Hildenbrand (Arm) [this message]
2026-09-11 17:56 ` Lorenzo Stoakes (ARM)
2026-09-11 18:08 ` Suren Baghdasaryan
2026-09-10 23:47 ` [PATCH v3 4/7] proc/task_mmu: remove special-casing of smap_gather_stats() start parameter Suren Baghdasaryan
2026-09-11 15:34 ` David Hildenbrand (Arm)
2026-09-11 16:39 ` Lorenzo Stoakes (ARM)
2026-09-11 17:07 ` Suren Baghdasaryan
2026-09-11 17:49 ` Lorenzo Stoakes (ARM)
2026-09-11 18:06 ` Suren Baghdasaryan
2026-09-11 18:11 ` Lorenzo Stoakes (ARM)
2026-09-11 18:15 ` Suren Baghdasaryan
2026-09-10 23:47 ` [PATCH v3 5/7] proc/task_mmu: change proc_get_vma() to stop returning gate VMA at the end Suren Baghdasaryan
2026-09-11 15:35 ` David Hildenbrand (Arm)
2026-09-11 18:26 ` Lorenzo Stoakes (ARM)
2026-09-11 18:39 ` Suren Baghdasaryan
2026-09-11 19:03 ` Lorenzo Stoakes (ARM)
2026-09-11 19:11 ` Suren Baghdasaryan
2026-09-11 19:13 ` Lorenzo Stoakes (ARM)
2026-09-11 19:18 ` Suren Baghdasaryan
2026-09-11 19:26 ` Lorenzo Stoakes (ARM)
2026-09-11 19:44 ` Suren Baghdasaryan
2026-09-11 19:45 ` Suren Baghdasaryan
2026-09-10 23:47 ` [PATCH v3 6/7] proc/task_mmu: read proc/pid/smaps_rollup under per-vma lock Suren Baghdasaryan
2026-09-11 19:07 ` Lorenzo Stoakes (ARM)
2026-09-10 23:47 ` [PATCH v3 7/7] selftests/proc: add /proc/pid/smaps_rollup tearing tests Suren Baghdasaryan
2026-09-11 19:12 ` Lorenzo Stoakes (ARM)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=eb040cfc-4038-4cc1-9220-c387c4c8a02e@kernel.org \
--to=david@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=jannh@google.com \
--cc=liam@infradead.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=paulmck@kernel.org \
--cc=pfalcato@suse.de \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=willy@infradead.org \
--cc=xueyuan.chen21@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®