From: Rodolfo Giometti <giometti@enneenne.com>
To: Bastien Curutchet <bastien.curutchet@bootlin.com>
Cc: linux-kernel@vger.kernel.org,
Thomas Petazzoni <thomas.petazzoni@bootlin.com>,
herve.codina@bootlin.com, christophercordahi@nanometrics.ca
Subject: Re: [PATCH 1/1] pps: clients: gpio: Bypass edge's direction check when not needed
Date: Wed, 10 Apr 2024 17:24:36 +0200 [thread overview]
Message-ID: <eb64ec08-2ae3-48bb-9f84-3cec362280b2@enneenne.com> (raw)
In-Reply-To: <5bda0980-2373-4284-bda4-89f0c6944e76@bootlin.com>
On 10/04/24 16:46, Bastien Curutchet wrote:
> Hi Rodolfo,
>
> On 4/10/24 16:23, Rodolfo Giometti wrote:
>> On 10/04/24 13:35, Bastien Curutchet wrote:
>>> In the IRQ handler, the GPIO's state is read to verify the direction of
>>> the edge that triggered the interruption before generating the PPS event.
>>> If a pulse is too short, the GPIO line can reach back its original state
>>> before this verification and the PPS event is lost.
>>>
>>> This check is needed when info->capture_clear is set because it needs
>>> interruptions on both rising and falling edges. When info->capture_clear
>>> is not set, interruption is triggered by one edge only so this check can
>>> be omitted.
>>>
>>> Bypass the edge's direction verification when info->capture_clear is not
>>> set.
>>>
>>> Signed-off-by: Bastien Curutchet <bastien.curutchet@bootlin.com>
>>> ---
>>> drivers/pps/clients/pps-gpio.c | 9 +++++++++
>>> 1 file changed, 9 insertions(+)
>>>
>>> diff --git a/drivers/pps/clients/pps-gpio.c b/drivers/pps/clients/pps-gpio.c
>>> index 2f4b11b4dfcd..c2a96e3e3836 100644
>>> --- a/drivers/pps/clients/pps-gpio.c
>>> +++ b/drivers/pps/clients/pps-gpio.c
>>> @@ -52,6 +52,15 @@ static irqreturn_t pps_gpio_irq_handler(int irq, void *data)
>>> info = data;
>>> + if (!info->capture_clear) {
>>> + /*
>>> + * If capture_clear is unset, IRQ is triggered by one edge only.
>>> + * So the check on edge direction is not needed here
>>> + */
>>> + pps_event(info->pps, &ts, PPS_CAPTUREASSERT, data);
>>> + return IRQ_HANDLED;
>>> + }
>>> +
>>> rising_edge = gpiod_get_value(info->gpio_pin);
>>> if ((rising_edge && !info->assert_falling_edge) ||
>>> (!rising_edge && info->assert_falling_edge))
>>
>> Apart the code duplication, which are the real benefits of doing so?
>>
>
> It prevents from losing a PPS event when the pulse is so short (or the
> kernel so busy) that the trailing edge of the pulse occurs before the
> interrupt handler can read the state of the GPIO pin.
Have you a real case when this happens?
In any cases we should avoid code duplication... so I think we should do
something as below:
diff --git a/drivers/pps/clients/pps-gpio.c b/drivers/pps/clients/pps-gpio.c
index 2f4b11b4dfcd..f05fb15ed7f4 100644
--- a/drivers/pps/clients/pps-gpio.c
+++ b/drivers/pps/clients/pps-gpio.c
@@ -52,7 +52,9 @@ static irqreturn_t pps_gpio_irq_handler(int irq, void *data)
info = data;
- rising_edge = gpiod_get_value(info->gpio_pin);
+ rising_edge = info->capture_clear ? \
+ gpiod_get_value(info->gpio_pin) : \
+ !info->assert_falling_edge;
if ((rising_edge && !info->assert_falling_edge) ||
(!rising_edge && info->assert_falling_edge))
pps_event(info->pps, &ts, PPS_CAPTUREASSERT, data);
Please, review and test it before resubmitting. :)
Ciao,
Rodolfo
--
GNU/Linux Solutions e-mail: giometti@enneenne.com
Linux Device Driver giometti@linux.it
Embedded Systems phone: +39 349 2432127
UNIX programming
next prev parent reply other threads:[~2024-04-10 15:24 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-10 11:35 Bastien Curutchet
2024-04-10 14:23 ` Rodolfo Giometti
2024-04-10 14:46 ` Bastien Curutchet
2024-04-10 15:24 ` Rodolfo Giometti [this message]
2024-04-10 16:05 ` Bastien Curutchet
2024-04-11 7:20 ` Rodolfo Giometti
2024-04-11 12:44 ` Bastien Curutchet
2024-04-12 6:44 ` Rodolfo Giometti
2024-04-12 12:20 ` Bastien Curutchet
2024-04-25 6:11 ` Bastien Curutchet
2024-04-25 11:46 ` Rodolfo Giometti
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=eb64ec08-2ae3-48bb-9f84-3cec362280b2@enneenne.com \
--to=giometti@enneenne.com \
--cc=bastien.curutchet@bootlin.com \
--cc=christophercordahi@nanometrics.ca \
--cc=herve.codina@bootlin.com \
--cc=linux-kernel@vger.kernel.org \
--cc=thomas.petazzoni@bootlin.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®