From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-wm1-f43.google.com (mail-wm1-f43.google.com [209.85.128.43]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 7235D275861 for ; Mon, 24 Nov 2025 11:16:34 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.128.43 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1763982996; cv=none; b=UFHFpf40gbzaKsenfXsLC+R7wcST08EKMM1mRzXs4Pr8sCaIMfVdPZjvw/vUA6O/FFW0/rUuDiULy0ae3Dm7fbo2BqZEx9ux3gMqIDpG9MEGm6+G7qUwK2hZW71ZnUzqNNUE6fAIqvsno476U06YeS247qTgBaIgnfJSB11wqmk= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1763982996; c=relaxed/simple; bh=PkrzqQiN/qcj/0t3ahO3DxqiRf/xvfoXnTu2D4FlPMg=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=nzIJLfLeb8vHlE0j5CITO3gwBfKq+GHbXvlryMrwq8JdgFr2dLeAZ13zHQ9K8+sJIHM3lCmOOMIw9g8KFkTKeiQOFY7Wzvl2lDKoV5HlPY3WAOWqGW3/gVS3cyTavxS1zITzMdHbTnKXOOFqgHWrTHTozPfoOlAFZgAeInGjYig= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=linaro.org; spf=pass smtp.mailfrom=linaro.org; dkim=pass (2048-bit key) header.d=linaro.org header.i=@linaro.org header.b=oG5NnK/O; arc=none smtp.client-ip=209.85.128.43 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=linaro.org Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=linaro.org Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=linaro.org header.i=@linaro.org header.b="oG5NnK/O" Received: by mail-wm1-f43.google.com with SMTP id 5b1f17b1804b1-4775ae77516so42057105e9.1 for ; Mon, 24 Nov 2025 03:16:34 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=linaro.org; s=google; t=1763982993; x=1764587793; darn=vger.kernel.org; h=content-transfer-encoding:in-reply-to:from:content-language :references:cc:to:subject:user-agent:mime-version:date:message-id :from:to:cc:subject:date:message-id:reply-to; bh=UuRrMhunT9TDWnZHLII8BIXNolS7BUSymKB5ka4d4O0=; b=oG5NnK/O0Dwjxg6PFUKLHtTVLys9LDlAWbhAZjHzdzxU+KnlIY+tvhiEbgQo8z6IhM +qNJLswUiuAafz0F5c6h43ky2YawIcfM+wk6mzjVnpTkvCEcxGCF4RR/5qvb1zwzdx7O N+Wbdc1U91nrrIfIuZVcdmVQRFBTqCiuiJ9E91TxDm3J0XNuVAKy/YVmQEhvmcmTbd+n gUvWqUlmRqrm765g2hxlHk8EYg6MQ2uQX1UB4gHsjk47vMrpHwDDNjVRVTdl57WONLdP cNh0GLoWclbhLpvY7TORQ7cHw+iUeVEHk7AP/7J/Axkwkka4Z4oCiArkn2KJ8RI4QExW ivCg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1763982993; x=1764587793; h=content-transfer-encoding:in-reply-to:from:content-language :references:cc:to:subject:user-agent:mime-version:date:message-id :x-gm-gg:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=UuRrMhunT9TDWnZHLII8BIXNolS7BUSymKB5ka4d4O0=; b=ksm4n4gFOxx1v/KS47hRPitkL9OkegQRyqymBpRUhN1i2OnMn0+kloh3D6Sdv4O1tx 4ZmfdJXbRQwEjXnjvPC1izCXb6oz6x28lzGhl+70JYV83HybexPdClCdc1mNCa1d003m GkmZYLgxNMd8/Y6g6a0jlFSU+YIwRqvWRcienTO3a1CVXW6X159XnqPcdmFfuxiVdp08 Vufpra37LbG96Ls7MpB4IgtYR+VuZ1hsDjqgONDgKZRMwAvXIQS2Av4f7yaUS+d8Qfil i2XQ1n0aa4JHfFU7wpgkB+GCnVHzuQdXXuliyNwV5d2oQS9jG84e+OLYCsgRmbnCvlSD MXgw== X-Forwarded-Encrypted: i=1; AJvYcCWN4XteAZHSVXtHFz43DfNzxVhrHqLWe2jotzmsPnY6EyEBdtX1rlcCuMzuLT+mjdvLOiJivuReUbnWiA0=@vger.kernel.org X-Gm-Message-State: AOJu0YyB4fgBsOgJK/cLLlTHJHbwTbXRbpWbXSm4cAj9fq0Tn2kFr+dG 7h59pZIazAnFWWl1I1MgJTbTMDXthR1zI0ZG1w1d5zdB8kawbGtN4I0dS3LFrXYMOCIUJfqY2h7 bJ5SGB5Y= X-Gm-Gg: ASbGncuGPMDvZEjktxNnFdwWEricWsg9/Jug79wVtlk4oqr1B7rkhScA5dK5leUfUTg dFXbMSRrT6MFHC6P+xzbXwssYhNlSqgTO6i8tN2lXfaYIYUOdWpkdKyI66NQ0tRQd1KH9+johkv RpL22Wot9bPWjFlCUEvWrRJZnHjpfSW2mxKIpDuvb9JkS5xxv/f31MbZ/Vf+FgwYhr+PfJoZw8R /eXBnY5UzlT322twcyr6RkmEPm5sGkE/0sbKzeD8H9klbSwlbrhlhsYNKOH1rkuQ45oSp4jZYRA hPSxCbx03SRGceHFtjf9ssUxIvXMNR1PG8fYWjBkZSJLJxMBU/jlTV4gbKpE1p52dFXUvSs+vxG tPAvOXejrpD5a+oAt/qVW9aEvpUAoRj2j6Nnh/FRh6acC6K/EDgRnIqGs5OebcpxKaXVE/ITkjS 9itWdy52nq3GLyaX88OpcUu+oyikxKMq8R5XYUS3kc4oqQoS9UPLX1Uawawv/zMBwy6Q== X-Google-Smtp-Source: AGHT+IGoaXb9zqkluRUTXSsxY7Elb/IIHiZ+I4IVLxjc5bpkpHjrfyygfT2RwN8BHb50RMQMY1Fuxg== X-Received: by 2002:a05:600c:1ca5:b0:475:dde5:d91b with SMTP id 5b1f17b1804b1-477c1115ff6mr126002295e9.17.1763982992722; Mon, 24 Nov 2025 03:16:32 -0800 (PST) Received: from ?IPV6:2a05:6e02:1041:c10:a756:bb6c:7b35:af9b? ([2a05:6e02:1041:c10:a756:bb6c:7b35:af9b]) by smtp.googlemail.com with ESMTPSA id ffacd0b85a97d-42cb7f2e5b6sm27447425f8f.1.2025.11.24.03.16.31 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Mon, 24 Nov 2025 03:16:32 -0800 (PST) Message-ID: Date: Mon, 24 Nov 2025 12:16:31 +0100 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v7 RESEND 2/3] thermal: exynos_tmu: Support new hardware and update TMU interface To: Tudor Ambarus , =?UTF-8?B?7IaQ7Iug?= , 'Bartlomiej Zolnierkiewicz' , 'Krzysztof Kozlowski' , "'Rafael J . Wysocki'" , 'Zhang Rui' , 'Lukasz Luba' , 'Rob Herring' , 'Conor Dooley' , 'Alim Akhtar' Cc: 'Henrik Grimler' , linux-pm@vger.kernel.org, linux-samsung-soc@vger.kernel.org, devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, Peter Griffin , =?UTF-8?Q?Andr=C3=A9_Draszik?= , William McVicker , jyescas@google.com References: <20251113064022.2701578-1-shin.son@samsung.com> <20251113064022.2701578-3-shin.son@samsung.com> <2180a854-8ba6-4424-add2-eb34637530c1@linaro.org> <000001dc5d2a$0697bf10$13c73d30$@samsung.com> <12346382-7718-4942-a497-4de278b1d5a0@linaro.org> Content-Language: en-US From: Daniel Lezcano In-Reply-To: <12346382-7718-4942-a497-4de278b1d5a0@linaro.org> Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit Hi Tudor, On 11/24/25 11:43, Tudor Ambarus wrote: > Hi, Shin, > > On 11/24/25 12:06 PM, ์†์‹  wrote: >>>> +static void update_con_reg(struct exynos_tmu_data *data) { >>>> + u32 val, t_buf_vref_sel, t_buf_slope_sel; >>>> + >>>> + val = readl(data->base + EXYNOS_TMU_REG_TRIMINFO); >>>> + t_buf_vref_sel = (val >> EXYNOSAUTOV920_TMU_T_BUF_VREF_SEL_SHIFT) >>>> + & EXYNOSAUTOV920_TMU_T_BUF_VREF_SEL_MASK; >>>> + t_buf_slope_sel = (val >> EXYNOSAUTOV920_TMU_T_BUF_SLOPE_SEL_SHIFT) >>>> + & EXYNOSAUTOV920_TMU_T_BUF_SLOPE_SEL_MASK; >>>> + >>>> + val = readl(data->base + EXYNOSAUTOV920_TMU_REG_CONTROL); >>>> + val &= ~(EXYNOS_TMU_REF_VOLTAGE_MASK << >>> EXYNOS_TMU_REF_VOLTAGE_SHIFT); >>>> + val |= (t_buf_vref_sel << EXYNOS_TMU_REF_VOLTAGE_SHIFT); >>>> + val &= ~(EXYNOS_TMU_BUF_SLOPE_SEL_MASK << >>> EXYNOS_TMU_BUF_SLOPE_SEL_SHIFT); >>>> + val |= (t_buf_slope_sel << EXYNOS_TMU_BUF_SLOPE_SEL_SHIFT); >>>> + writel(val, data->base + EXYNOSAUTOV920_TMU_REG_CONTROL); >>>> + >>>> + val = readl(data->base + EXYNOSAUTOV920_TMU_REG_CONTROL1); >>>> + val &= ~(EXYNOSAUTOV920_TMU_NUM_PROBE_MASK << >>> EXYNOSAUTOV920_TMU_NUM_PROBE_SHIFT); >>>> + val &= ~(EXYNOSAUTOV920_TMU_LPI_MODE_MASK << >>> EXYNOSAUTOV920_TMU_LPI_MODE_SHIFT); >>>> + val |= (data->sensor_count << EXYNOSAUTOV920_TMU_NUM_PROBE_SHIFT); >>>> + writel(val, data->base + EXYNOSAUTOV920_TMU_REG_CONTROL1); >>>> + >>>> + writel(1, data->base + EXYNOSAUTOV920_TMU_SAMPLING_INTERVAL); >>>> + writel(EXYNOSAUTOV920_TMU_AVG_CON_UPDATE, data->base + >>> EXYNOSAUTOV920_TMU_REG_AVG_CONTROL); >>>> + writel(EXYNOSAUTOV920_TMU_COUNTER_VALUE0_UPDATE, >>>> + data->base + EXYNOSAUTOV920_TMU_REG_COUNTER_VALUE0); >>>> + writel(EXYNOSAUTOV920_TMU_COUNTER_VALUE1_UPDATE, >>>> + data->base + EXYNOSAUTOV920_TMU_REG_COUNTER_VALUE1); >>>> +} >>>> + >>> This is unreadable; please make it understandable for those who donโ€™t have >>> the documentation (explicit static inline functions, comments, etc ...). >> I'll restructure this code by introducing explicit static inline helper functions and proper comments to improve readability. > > We likely shouldn't use inlines here, see Linus's reply from 2006: > https://lore.kernel.org/all/Pine.LNX.4.64.0601021105000.3668@g5.osdl.org/T/#u We should not use inline functions when they can be called from different places and if they contain a significant amount of code inside. But for one line functions, inside a driver it may help for the readability when the function name is self-explanatory. > I guess you can make this easier to read if you use FIELD_GET/SET from > bitfield.h. Other improvement would be using the regmap api. regmap would be too overkill to write unshared registers. -- Linaro.org โ”‚ Open source software for ARM SoCs Follow Linaro: Facebook | Twitter | Blog