From: "Moger, Babu" <babu.moger@amd.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
corbet@lwn.net, tglx@linutronix.de, mingo@redhat.com,
bp@alien8.de
Cc: fenghua.yu@intel.com, dave.hansen@linux.intel.com,
x86@kernel.org, hpa@zytor.com, paulmck@kernel.org,
akpm@linux-foundation.org, quic_neeraju@quicinc.com,
rdunlap@infradead.org, damien.lemoal@opensource.wdc.com,
songmuchun@bytedance.com, peterz@infradead.org,
jpoimboe@kernel.org, pbonzini@redhat.com,
chang.seok.bae@intel.com, pawan.kumar.gupta@linux.intel.com,
jmattson@google.com, daniel.sneddon@linux.intel.com,
sandipan.das@amd.com, tony.luck@intel.com, james.morse@arm.com,
linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org,
bagasdotme@gmail.com, eranian@google.com,
christophe.leroy@csgroup.eu, jarkko@kernel.org,
adrian.hunter@intel.com, quic_jiles@quicinc.com,
peternewman@google.com
Subject: Re: [PATCH v3 2/7] x86/resctrl: Remove few unnecessary rftype flags
Date: Thu, 16 Mar 2023 15:31:24 -0500 [thread overview]
Message-ID: <edcb0810-df39-669b-ebf2-5988a71525e9@amd.com> (raw)
In-Reply-To: <1a45fc82-9339-d086-2e70-27fd91906b8a@intel.com>
Hi Reinette,
On 3/15/23 13:33, Reinette Chatre wrote:
> Hi Babu,
>
> On 3/2/2023 12:24 PM, Babu Moger wrote:
>> Remove few unnecessary rftype flags and simplify the code. This is done
>
> Please drop "few" (here and in subject).
Sure.
>
>> to further cleanup the code eventually.
>
> Could you please be specific? "further cleanup the code
> eventually" is too vague. I do not understand what is meant
> with the second sentence.
I can just say "Remove unnecessary rftype flags and improve code readability."
>
>>
>> Signed-off-by: Babu Moger <babu.moger@amd.com>
>> ---
>> arch/x86/kernel/cpu/resctrl/internal.h | 9 +++------
>> arch/x86/kernel/cpu/resctrl/rdtgroup.c | 10 +++++++---
>> 2 files changed, 10 insertions(+), 9 deletions(-)
>>
>> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
>> index 8edecc5763d8..571145d75d29 100644
>> --- a/arch/x86/kernel/cpu/resctrl/internal.h
>> +++ b/arch/x86/kernel/cpu/resctrl/internal.h
>> @@ -243,12 +243,9 @@ struct rdtgroup {
>> */
>> #define RFTYPE_INFO BIT(0)
>> #define RFTYPE_BASE BIT(1)
>> -#define RF_CTRLSHIFT 4
>> -#define RF_MONSHIFT 5
>> -#define RF_TOPSHIFT 6
>> -#define RFTYPE_CTRL BIT(RF_CTRLSHIFT)
>> -#define RFTYPE_MON BIT(RF_MONSHIFT)
>> -#define RFTYPE_TOP BIT(RF_TOPSHIFT)
>> +#define RFTYPE_CTRL BIT(4)
>> +#define RFTYPE_MON BIT(5)
>> +#define RFTYPE_TOP BIT(6)
>> #define RFTYPE_RES_CACHE BIT(8)
>> #define RFTYPE_RES_MB BIT(9)
>> #define RF_CTRL_INFO (RFTYPE_INFO | RFTYPE_CTRL)
>> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> index 15ea5b550fe9..3c86506e54c1 100644
>> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> @@ -3163,7 +3163,7 @@ static int mkdir_rdt_prepare(struct kernfs_node *parent_kn,
>> {
>> struct rdtgroup *prdtgrp, *rdtgrp;
>> struct kernfs_node *kn;
>> - uint files = 0;
>> + uint fflags = 0;
>
> Hoe does changing the variable name from "files" to "fflags" simplify
> the code?
I should have said readability of the code. Its actually fflags we are
passing to rdtgroup_add_files. While changing flags below, I changed the
variable name to fflags.
>
>> int ret;
>>
>> prdtgrp = rdtgroup_kn_lock_live(parent_kn);
>> @@ -3215,8 +3215,12 @@ static int mkdir_rdt_prepare(struct kernfs_node *parent_kn,
>> goto out_destroy;
>> }
>>
>> - files = RFTYPE_BASE | BIT(RF_CTRLSHIFT + rtype);
>> - ret = rdtgroup_add_files(kn, files);
>> + if (rtype == RDTCTRL_GROUP)
>> + fflags = RFTYPE_BASE | RFTYPE_CTRL;
>> + else
>> + fflags = RFTYPE_BASE | RFTYPE_MON;
>> +
>> + ret = rdtgroup_add_files(kn, fflags);
>> if (ret) {
>> rdt_last_cmd_puts("kernfs fill error\n");
>> goto out_destroy;
>>
>>
>
> Reinette
--
Thanks
Babu Moger
next prev parent reply other threads:[~2023-03-16 20:31 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-03-02 20:24 [PATCH v3 0/7] x86/resctrl: Miscellaneous resctrl features Babu Moger
2023-03-02 20:24 ` [PATCH v3 1/7] x86/resctrl: Add multiple tasks to the resctrl group at once Babu Moger
2023-03-15 18:32 ` Reinette Chatre
2023-03-16 16:27 ` Moger, Babu
2023-03-16 17:12 ` Reinette Chatre
2023-03-16 19:51 ` Moger, Babu
2023-03-16 20:33 ` Reinette Chatre
2023-03-20 15:07 ` Moger, Babu
2023-03-20 15:15 ` Moger, Babu
2023-03-20 16:52 ` Reinette Chatre
2023-03-20 18:29 ` Moger, Babu
2023-03-02 20:24 ` [PATCH v3 2/7] x86/resctrl: Remove few unnecessary rftype flags Babu Moger
2023-03-15 18:33 ` Reinette Chatre
2023-03-16 20:31 ` Moger, Babu [this message]
2023-03-16 20:41 ` Reinette Chatre
2023-03-16 21:11 ` Moger, Babu
2023-03-16 21:17 ` Reinette Chatre
2023-03-20 13:35 ` Moger, Babu
2023-03-02 20:24 ` [PATCH v3 3/7] x86/resctrl: Rename rftype flags for consistency Babu Moger
2023-03-02 20:24 ` [PATCH v3 4/7] x86/resctrl: Re-arrange RFTYPE flags based on hierarchy Babu Moger
2023-03-15 18:37 ` Reinette Chatre
2023-03-21 15:54 ` Moger, Babu
2023-03-22 18:46 ` Reinette Chatre
2023-03-02 20:24 ` [PATCH v3 5/7] x86/resctrl: Display the RMID and COSID for resctrl groups Babu Moger
2023-03-15 18:42 ` Reinette Chatre
2023-03-20 16:52 ` Moger, Babu
2023-03-20 17:00 ` Reinette Chatre
2023-03-20 17:10 ` James Morse
2023-03-20 19:53 ` Moger, Babu
2023-03-20 20:59 ` Stephane Eranian
2023-03-22 13:49 ` Moger, Babu
2023-03-02 20:25 ` [PATCH v3 6/7] x86/resctrl: Introduce -o debug mount option Babu Moger
2023-03-15 18:43 ` Reinette Chatre
2023-03-22 14:01 ` Moger, Babu
2023-03-02 20:25 ` [PATCH v3 7/7] x86/resctrl: Add debug files when mounted with debug option Babu Moger
2023-03-15 18:45 ` Reinette Chatre
2023-03-22 15:09 ` Moger, Babu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=edcb0810-df39-669b-ebf2-5988a71525e9@amd.com \
--to=babu.moger@amd.com \
--cc=adrian.hunter@intel.com \
--cc=akpm@linux-foundation.org \
--cc=bagasdotme@gmail.com \
--cc=bp@alien8.de \
--cc=chang.seok.bae@intel.com \
--cc=christophe.leroy@csgroup.eu \
--cc=corbet@lwn.net \
--cc=damien.lemoal@opensource.wdc.com \
--cc=daniel.sneddon@linux.intel.com \
--cc=dave.hansen@linux.intel.com \
--cc=eranian@google.com \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=jarkko@kernel.org \
--cc=jmattson@google.com \
--cc=jpoimboe@kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=paulmck@kernel.org \
--cc=pawan.kumar.gupta@linux.intel.com \
--cc=pbonzini@redhat.com \
--cc=peternewman@google.com \
--cc=peterz@infradead.org \
--cc=quic_jiles@quicinc.com \
--cc=quic_neeraju@quicinc.com \
--cc=rdunlap@infradead.org \
--cc=reinette.chatre@intel.com \
--cc=sandipan.das@amd.com \
--cc=songmuchun@bytedance.com \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®