From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Jiri Slaby <jirislaby@kernel.org>,
"open list:SERIAL DRIVERS" <linux-serial@vger.kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/1] 8250_dwlib: Convert bitops to newer form
Date: Thu, 30 Jun 2022 13:20:49 +0300 (EEST) [thread overview]
Message-ID: <eeba3ce9-c0a1-2363-154a-82b0b4468e3@linux.intel.com> (raw)
In-Reply-To: <CAHp75VcH9O6=Lk06w3Set==zBEFyseCSDN6OUE3n7g4ZnBM4Bg@mail.gmail.com>
[-- Attachment #1: Type: text/plain, Size: 2566 bytes --]
On Thu, 30 Jun 2022, Andy Shevchenko wrote:
> On Thu, Jun 30, 2022 at 12:08 PM Ilpo Järvinen
> <ilpo.jarvinen@linux.intel.com> wrote:
> >
> > Instead of open-coding, use BIT(), GENMASK(), and FIELD_GET() helpers.
>
> FIELD_GET() requires bitfield.h to be included. Is this the case already?
It's there already.
--
i.
> If so,
> Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
>
> > Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@linux.intel.com>
> > ---
> > drivers/tty/serial/8250/8250_dwlib.c | 26 +++++++++++++-------------
> > 1 file changed, 13 insertions(+), 13 deletions(-)
> >
> > diff --git a/drivers/tty/serial/8250/8250_dwlib.c b/drivers/tty/serial/8250/8250_dwlib.c
> > index da330ef46446..a8bbed74ea70 100644
> > --- a/drivers/tty/serial/8250/8250_dwlib.c
> > +++ b/drivers/tty/serial/8250/8250_dwlib.c
> > @@ -46,21 +46,21 @@
> > #define DW_UART_LCR_EXT_TRANSMIT_MODE BIT(3)
> >
> > /* Component Parameter Register bits */
> > -#define DW_UART_CPR_ABP_DATA_WIDTH (3 << 0)
> > -#define DW_UART_CPR_AFCE_MODE (1 << 4)
> > -#define DW_UART_CPR_THRE_MODE (1 << 5)
> > -#define DW_UART_CPR_SIR_MODE (1 << 6)
> > -#define DW_UART_CPR_SIR_LP_MODE (1 << 7)
> > -#define DW_UART_CPR_ADDITIONAL_FEATURES (1 << 8)
> > -#define DW_UART_CPR_FIFO_ACCESS (1 << 9)
> > -#define DW_UART_CPR_FIFO_STAT (1 << 10)
> > -#define DW_UART_CPR_SHADOW (1 << 11)
> > -#define DW_UART_CPR_ENCODED_PARMS (1 << 12)
> > -#define DW_UART_CPR_DMA_EXTRA (1 << 13)
> > -#define DW_UART_CPR_FIFO_MODE (0xff << 16)
> > +#define DW_UART_CPR_ABP_DATA_WIDTH GENMASK(1, 0)
> > +#define DW_UART_CPR_AFCE_MODE BIT(4)
> > +#define DW_UART_CPR_THRE_MODE BIT(5)
> > +#define DW_UART_CPR_SIR_MODE BIT(6)
> > +#define DW_UART_CPR_SIR_LP_MODE BIT(7)
> > +#define DW_UART_CPR_ADDITIONAL_FEATURES BIT(8)
> > +#define DW_UART_CPR_FIFO_ACCESS BIT(9)
> > +#define DW_UART_CPR_FIFO_STAT BIT(10)
> > +#define DW_UART_CPR_SHADOW BIT(11)
> > +#define DW_UART_CPR_ENCODED_PARMS BIT(12)
> > +#define DW_UART_CPR_DMA_EXTRA BIT(13)
> > +#define DW_UART_CPR_FIFO_MODE GENMASK(23, 16)
> >
> > /* Helper for FIFO size calculation */
> > -#define DW_UART_CPR_FIFO_SIZE(a) (((a >> 16) & 0xff) * 16)
> > +#define DW_UART_CPR_FIFO_SIZE(a) (FIELD_GET(DW_UART_CPR_FIFO_MODE, (a)) * 16)
> >
> > /*
> > * divisor = div(I) + div(F)
> > --
> > 2.30.2
> >
>
>
>
prev parent reply other threads:[~2022-06-30 10:20 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-30 10:05 Ilpo Järvinen
2022-06-30 10:17 ` Andy Shevchenko
2022-06-30 10:20 ` Ilpo Järvinen [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=eeba3ce9-c0a1-2363-154a-82b0b4468e3@linux.intel.com \
--to=ilpo.jarvinen@linux.intel.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=jirislaby@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-serial@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®