From: Bart Van Assche <bvanassche@acm.org>
To: Damien Le Moal <dlemoal@kernel.org>,
Yihang Li <liyihang9@huawei.com>,
James.Bottomley@HansenPartnership.com,
martin.petersen@oracle.com
Cc: linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org,
linuxarm@huawei.com, prime.zeng@huawei.com,
stable@vger.kernel.org
Subject: Re: [PATCH v5] scsi: sd: Ignore command SYNC CACHE error if format in progress
Date: Tue, 20 Aug 2024 14:53:05 -0700 [thread overview]
Message-ID: <ef580b2b-af06-4b5c-a0e2-09d6374434fb@acm.org> (raw)
In-Reply-To: <c8a990c3-4b47-4e22-a378-8714c697748a@kernel.org>
On 8/19/24 4:19 PM, Damien Le Moal wrote:
> On 8/20/24 01:59, Bart Van Assche wrote:
>> On 8/19/24 2:09 AM, Yihang Li wrote:
>>> + if ((sshdr.asc == 0x04 && sshdr.ascq == 0x04) ||
>>
>> Shouldn't symbolic names be introduced for these numeric constants?
>> Although there is more code in the SCSI core that compares ASC / ASCQ
>> values with numeric constants, I think we need symbolic names for these
>> constants to make code like the above easier to read. There is already
>> a header file for definitions that come directly from the SCSI standard
>> and that is used by both SCSI initiator and SCSI target code:
>> <scsi/scsi_proto.h>.
>
> That would be *a lot* to define...
I meant introducing symbolic names only for the numerical constants that
occur in this patch. Anyway, I'm fine with a descriptive comment too.
Bart.
next prev parent reply other threads:[~2024-08-20 21:53 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-19 9:09 Yihang Li
2024-08-19 10:57 ` Damien Le Moal
2024-08-19 16:54 ` Bart Van Assche
2024-08-20 1:25 ` Yihang Li
2024-08-19 16:59 ` Bart Van Assche
2024-08-19 23:19 ` Damien Le Moal
2024-08-20 21:53 ` Bart Van Assche [this message]
2024-08-20 1:24 ` Yihang Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ef580b2b-af06-4b5c-a0e2-09d6374434fb@acm.org \
--to=bvanassche@acm.org \
--cc=James.Bottomley@HansenPartnership.com \
--cc=dlemoal@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=linuxarm@huawei.com \
--cc=liyihang9@huawei.com \
--cc=martin.petersen@oracle.com \
--cc=prime.zeng@huawei.com \
--cc=stable@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®