mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Paolo Bonzini <pbonzini@redhat.com>
To: Jim Mattson <jmattson@google.com>, Mohammed Gamal <mgamal@redhat.com>
Cc: kvm list <kvm@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>,
	Vitaly Kuznetsov <vkuznets@redhat.com>,
	Sean Christopherson <sean.j.christopherson@intel.com>,
	Wanpeng Li <wanpengli@tencent.com>,
	Joerg Roedel <joro@8bytes.org>,
	Tom Lendacky <thomas.lendacky@amd.com>,
	"Moger, Babu" <babu.moger@amd.com>
Subject: Re: [PATCH v2 06/11] KVM: VMX: introduce vmx_need_pf_intercept
Date: Mon, 22 Jun 2020 15:57:14 +0200	[thread overview]
Message-ID: <f0078376-dbd6-dc0a-6a7f-a05ebaadba11@redhat.com> (raw)
In-Reply-To: <CALMp9eQYRoB5vmxL0U7Mn0rWqotxLpUAJD15YX0DDYop1ZmuEg@mail.gmail.com>

On 20/06/20 00:45, Jim Mattson wrote:
>> +               /*
>> +                * TODO: if both L0 and L1 need the same MASK and MATCH,
>> +                * go ahead and use it?
>> +                */
> I'm not sure there's much "TODO", since L0's MASK and MATCH are both
> 0. So, if L1's MASK and MATCH are also both 0, we would go ahead and
> use 0's, which it seems we already do here:

True, the comment should be moved to patch 8.

Paolo

>> +               vmcs_write32(PAGE_FAULT_ERROR_CODE_MASK, 0);
>> +               vmcs_write32(PAGE_FAULT_ERROR_CODE_MATCH, 0);


  reply	other threads:[~2020-06-22 13:57 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-19 15:39 [PATCH v2 00/11] KVM: Support guest MAXPHYADDR < host MAXPHYADDR Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 01/11] KVM: x86: Add helper functions for illegal GPA checking and page fault injection Mohammed Gamal
2020-06-22  4:44   ` Yuan Yao
2020-06-22 12:21     ` Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 02/11] KVM: x86: mmu: Move translate_gpa() to mmu.c Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 03/11] KVM: x86: mmu: Add guest physical address check in translate_gpa() Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 04/11] KVM: x86: rename update_bp_intercept to update_exception_bitmap Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 05/11] KVM: x86: update exception bitmap on CPUID changes Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 06/11] KVM: VMX: introduce vmx_need_pf_intercept Mohammed Gamal
2020-06-19 22:45   ` Jim Mattson
2020-06-22 13:57     ` Paolo Bonzini [this message]
2020-06-19 15:39 ` [PATCH v2 07/11] KVM: VMX: Add guest physical address check in EPT violation and misconfig Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 08/11] KVM: VMX: optimize #PF injection when MAXPHYADDR does not match Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 09/11] KVM: SVM: introduce svm_need_pf_intercept Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 10/11] KVM: SVM: Add guest physical address check in NPF/PF interception Mohammed Gamal
2020-06-19 15:39 ` [PATCH v2 11/11] KVM: x86: SVM: VMX: Make GUEST_MAXPHYADDR < HOST_MAXPHYADDR support configurable Mohammed Gamal
2020-06-19 15:43 ` [PATCH v2 00/11] KVM: Support guest MAXPHYADDR < host MAXPHYADDR Paolo Bonzini
2020-06-19 21:52 ` Tom Lendacky
2020-06-19 23:07   ` Paolo Bonzini
2020-06-22 16:33     ` Tom Lendacky
2020-06-22 17:03       ` Paolo Bonzini
2020-06-22 17:57         ` Tom Lendacky
2020-06-22 18:01           ` Paolo Bonzini
2020-06-22 19:14             ` Tom Lendacky
2020-06-22 22:20               ` Paolo Bonzini
2020-06-22 23:47     ` Andy Lutomirski
2020-06-23  0:52       ` Paolo Bonzini
2020-06-22 15:08   ` Mohammed Gamal
2020-06-22 15:23     ` Paolo Bonzini
2020-06-22 16:35       ` Tom Lendacky
2020-06-22  4:32 ` Yuan Yao

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f0078376-dbd6-dc0a-6a7f-a05ebaadba11@redhat.com \
    --to=pbonzini@redhat.com \
    --cc=babu.moger@amd.com \
    --cc=jmattson@google.com \
    --cc=joro@8bytes.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mgamal@redhat.com \
    --cc=sean.j.christopherson@intel.com \
    --cc=thomas.lendacky@amd.com \
    --cc=vkuznets@redhat.com \
    --cc=wanpengli@tencent.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®