From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 3AF03C6FD1D for ; Fri, 7 Apr 2023 15:03:03 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S239501AbjDGPC7 (ORCPT ); Fri, 7 Apr 2023 11:02:59 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:34064 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S231732AbjDGPC2 (ORCPT ); Fri, 7 Apr 2023 11:02:28 -0400 Received: from vps0.lunn.ch (vps0.lunn.ch [156.67.10.101]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 1E774BB9D; Fri, 7 Apr 2023 08:01:43 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lunn.ch; s=20171124; h=In-Reply-To:Content-Disposition:Content-Type:MIME-Version: References:Message-ID:Subject:Cc:To:From:Date:From:Sender:Reply-To:Subject: Date:Message-ID:To:Cc:MIME-Version:Content-Type:Content-Transfer-Encoding: Content-ID:Content-Description:Content-Disposition:In-Reply-To:References; bh=WRzNxQq7iHXhn9Ubgg3RUKDCXQ7dwh7bEyStAdZAbEE=; b=ho9wvwF9mTKdejPMkw+bekkpr1 CLy+tTvTpwZUd6Sef6jFWbERD4OWBGoGJ8YiUnu/nqmRsWVBXukIzBGg0BH7Ys9KVnoFdp/zXa6Vv yj4o3fSgv1GCasJTw70ZyJrQmtxe4etiUxNEoVEthOG5Sd014e4YIXqDnU+r6NJiuzyo=; Received: from andrew by vps0.lunn.ch with local (Exim 4.94.2) (envelope-from ) id 1pkna2-009jTP-V9; Fri, 07 Apr 2023 17:00:46 +0200 Date: Fri, 7 Apr 2023 17:00:46 +0200 From: Andrew Lunn To: Marco Felsch Cc: Heiner Kallweit , Russell King , "David S. Miller" , Eric Dumazet , Jakub Kicinski , Paolo Abeni , Florian Fainelli , Broadcom internal kernel review list , Richard Cochran , Radu Pirea , Shyam Sundar S K , Yisen Zhuang , Salil Mehta , Jassi Brar , Ilias Apalodimas , Iyappan Subramanian , Keyur Chudgar , Quan Nguyen , "Rafael J. Wysocki" , Len Brown , Rob Herring , Frank Rowand , netdev@vger.kernel.org, linux-kernel@vger.kernel.org, linux-acpi@vger.kernel.org, devicetree@vger.kernel.org, kernel@pengutronix.de Subject: Re: [PATCH 06/12] net: phy: add phy_device_atomic_register helper Message-ID: References: <20230405-net-next-topic-net-phy-reset-v1-0-7e5329f08002@pengutronix.de> <20230405-net-next-topic-net-phy-reset-v1-6-7e5329f08002@pengutronix.de> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20230405-net-next-topic-net-phy-reset-v1-6-7e5329f08002@pengutronix.de> Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Lets try again.... There are a number of things i don't like about this patchset. It does too many different things. It pulls workarounds into the core. I don't like the phy_device_config. It would make sense if there were more than 6 arguments to pass to a function, but not for less. I don't like the name phy_device_atomic_register(), but that is bike shedding. There is no really strong argument to change the API. There is no really strong argument to move to fwnode. The problem you are trying to solve is to call phy_device_reset() earlier, before reading the ID registers. Please produce a patchset which is only focused on that. Nothing else. Andrew