mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
To: Abhinav Kumar <quic_abhinavk@quicinc.com>,
	freedreno@lists.freedesktop.org, Rob Clark <robdclark@gmail.com>,
	Sean Paul <sean@poorly.run>,
	Marijn Suijten <marijn.suijten@somainline.org>,
	David Airlie <airlied@gmail.com>, Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel@lists.freedesktop.org, quic_jesszhan@quicinc.com,
	andersson@kernel.org, linux-arm-msm@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 4/5] drm/msm/dpu: rename enable_compression() to program_intf_cmd_cfg()
Date: Thu, 13 Jul 2023 01:12:31 +0300	[thread overview]
Message-ID: <f0778167-17c7-b072-1e44-e8b6cdeb29d6@linaro.org> (raw)
In-Reply-To: <20230712012003.2212-5-quic_abhinavk@quicinc.com>

On 12/07/2023 04:20, Abhinav Kumar wrote:
> Rename the intf's enable_compression() op to program_intf_cmd_cfg()
> and allow it to accept a struct intf_cmd_mode_cfg to program
> all the bits at once. This can be re-used by widebus later on as
> well as it touches the same register.
> 
> changes in v5:
> 	- rename struct intf_cmd_mode_cfg to dpu_hw_intf_cmd_mode_cfg
> 	- remove couple of comments
> 
> Signed-off-by: Abhinav Kumar <quic_abhinavk@quicinc.com>
> ---
>   drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c | 8 ++++++--
>   drivers/gpu/drm/msm/disp/dpu1/dpu_hw_intf.c          | 8 +++++---
>   drivers/gpu/drm/msm/disp/dpu1/dpu_hw_intf.h          | 9 +++++++--
>   3 files changed, 18 insertions(+), 7 deletions(-)

Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>

-- 
With best wishes
Dmitry


  reply	other threads:[~2023-07-12 22:12 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20230712012003.2212-1-quic_abhinavk@quicinc.com>
2023-07-12  1:19 ` [PATCH v5 1/5] drm/msm/dpu: re-introduce dpu core revision to the catalog Abhinav Kumar
2023-07-12  1:20 ` [PATCH v5 2/5] drm/msm/dpu: use dpu core's major version to enable data compress Abhinav Kumar
2023-07-12  1:20 ` [PATCH v5 3/5] drm/msm/dpu: rename all hw_intf structs to have dpu_hw prefix Abhinav Kumar
2023-07-12 22:12   ` Dmitry Baryshkov
2023-07-12  1:20 ` [PATCH v5 4/5] drm/msm/dpu: rename enable_compression() to program_intf_cmd_cfg() Abhinav Kumar
2023-07-12 22:12   ` Dmitry Baryshkov [this message]
2023-07-12  1:20 ` [PATCH v5 5/5] drm/msm/dpu: drop DPU_INTF_DATA_COMPRESS from dpu catalog Abhinav Kumar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f0778167-17c7-b072-1e44-e8b6cdeb29d6@linaro.org \
    --to=dmitry.baryshkov@linaro.org \
    --cc=airlied@gmail.com \
    --cc=andersson@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=freedreno@lists.freedesktop.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marijn.suijten@somainline.org \
    --cc=quic_abhinavk@quicinc.com \
    --cc=quic_jesszhan@quicinc.com \
    --cc=robdclark@gmail.com \
    --cc=sean@poorly.run \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®