From: Nikolay Borisov <nik.borisov@suse.com>
To: Xiaoyao Li <xiaoyao.li@intel.com>,
Dave Hansen <dave.hansen@linux.intel.com>,
Kiryl Shutsemau <kas@kernel.org>,
Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
"H. Peter Anvin" <hpa@zytor.com>,
linux-coco@lists.linux.dev, kvm@vger.kernel.org,
linux-kernel@vger.kernel.org, x86@kernel.org,
Rick Edgecombe <rick.p.edgecombe@intel.com>,
Kai Huang <kai.huang@intel.com>,
binbin.wu@linux.intel.com,
Tony Lindgren <tony.lindgren@linux.intel.com>
Subject: Re: [PATCH v4 0/4] x86/tdx: Clean up the definitions of TDX TD ATTRIBUTES
Date: Wed, 4 Mar 2026 17:02:32 +0200 [thread overview]
Message-ID: <f0941a37-1055-4473-a8d2-fbe3e912c7b8@suse.com> (raw)
In-Reply-To: <20260303030335.766779-1-xiaoyao.li@intel.com>
On 3.03.26 г. 5:03 ч., Xiaoyao Li wrote:
> The main purpose of this series was to remove redundant macros between
> core TDX and KVM, along with a typo fix. They were implemented as patch 1
> and patch 2.
>
> During the review of v1 and v2, there was encouragement to refine the
> names of the macros related to TD attributes to clarify their scope.
> Thus patch 3 and patch 4 are added.
>
> Note, Binbin suggested to rename tdx_attributes[] to tdx_td_attributes[]
> during v3 review. However, this v4 doesn't do it but leaves it for future
> cleanup to avoid making it more complicated because it also looks like
> it needs to rename "Attributes" to "TD Attributes" in tdx_dump_attributes(),
> which has user visibility change.
>
Reviewed-by: Nikolay Borisov <nik.borisov@suse.com>
prev parent reply other threads:[~2026-03-04 15:02 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-03 3:03 Xiaoyao Li
2026-03-03 3:03 ` [PATCH v4 1/4] x86/tdx: Fix the typo in TDX_ATTR_MIGRTABLE Xiaoyao Li
2026-03-04 0:10 ` [tip: x86/tdx] " tip-bot2 for Xiaoyao Li
2026-03-03 3:03 ` [PATCH v4 2/4] KVM: TDX: Remove redundant definitions of TDX_TD_ATTR_* Xiaoyao Li
2026-03-04 0:10 ` [tip: x86/tdx] KVM/TDX: " tip-bot2 for Xiaoyao Li
2026-03-03 3:03 ` [PATCH v4 3/4] x86/tdx: Rename TDX_ATTR_* to TDX_TD_ATTR_* Xiaoyao Li
2026-03-04 0:10 ` [tip: x86/tdx] " tip-bot2 for Xiaoyao Li
2026-03-03 3:03 ` [PATCH v4 4/4] KVM: TDX: Rename KVM_SUPPORTED_TD_ATTRS to KVM_SUPPORTED_TDX_TD_ATTRS Xiaoyao Li
2026-03-04 0:10 ` [tip: x86/tdx] KVM/TDX: " tip-bot2 for Xiaoyao Li
2026-03-04 15:02 ` Nikolay Borisov [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f0941a37-1055-4473-a8d2-fbe3e912c7b8@suse.com \
--to=nik.borisov@suse.com \
--cc=binbin.wu@linux.intel.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=kai.huang@intel.com \
--cc=kas@kernel.org \
--cc=kvm@vger.kernel.org \
--cc=linux-coco@lists.linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pbonzini@redhat.com \
--cc=rick.p.edgecombe@intel.com \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=tony.lindgren@linux.intel.com \
--cc=x86@kernel.org \
--cc=xiaoyao.li@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®