From: Julien Thierry <jthierry@redhat.com>
To: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: linux-kernel@vger.kernel.org, peterz@infradead.org,
mhelsley@vmware.com, mbenes@suse.cz
Subject: Re: [PATCH v3 1/4] objtool: Move object file loading out of check
Date: Thu, 30 Jul 2020 15:42:55 +0100 [thread overview]
Message-ID: <f0b948c8-c824-4d8e-6a0b-20cde05444d7@redhat.com> (raw)
In-Reply-To: <20200730140936.uvw73r655356lhtm@treble>
On 7/30/20 3:09 PM, Josh Poimboeuf wrote:
> On Thu, Jul 30, 2020 at 10:41:40AM +0100, Julien Thierry wrote:
>> +struct objtool_file *objtool_setup_file(const char *_objname)
>> +{
>> + if (objname) {
>> + if (strcmp(objname, _objname)) {
>> + WARN("won't handle more than one file at a time");
>> + return NULL;
>> + }
>> + return &file;
>> + }
>> + objname = _objname;
>> +
>> + file.elf = elf_open_read(objname, O_RDWR);
>> + if (!file.elf)
>> + return NULL;
>> +
>> + INIT_LIST_HEAD(&file.insn_list);
>> + hash_init(file.insn_hash);
>> + file.c_file = find_section_by_name(file.elf, ".comment");
>> + file.ignore_unreachables = no_unreachable;
>> + file.hints = false;
>> +
>> + return &file;
>> +}
>
> How about calling it objtool_open_read()? It's (sort of) a wrapper
> around elf_open_read().
>
Sure, I'll update that.
Thanks,
--
Julien Thierry
next prev parent reply other threads:[~2020-07-30 14:43 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-07-30 9:41 [PATCH v3 0/4] Remove dependency of check subcmd upon orc Julien Thierry
2020-07-30 9:41 ` [PATCH v3 1/4] objtool: Move object file loading out of check Julien Thierry
2020-07-30 14:09 ` Josh Poimboeuf
2020-07-30 14:42 ` Julien Thierry [this message]
2020-07-30 9:41 ` [PATCH v3 2/4] objtool: Move orc outside " Julien Thierry
2020-07-30 9:57 ` peterz
2020-07-30 12:40 ` Julien Thierry
2020-07-30 13:22 ` peterz
2020-07-30 13:29 ` Julien Thierry
2020-07-30 14:15 ` Josh Poimboeuf
2020-07-30 14:44 ` Julien Thierry
2020-07-31 7:56 ` Miroslav Benes
2020-07-31 8:19 ` Julien Thierry
2020-07-30 9:41 ` [PATCH v3 3/4] objtool: orc: Skip setting orc_entry for non-text sections Julien Thierry
2020-07-30 9:41 ` [PATCH v3 4/4] objtool: orc_gen: Move orc_entry out of instruction structure Julien Thierry
2020-07-30 10:03 ` peterz
2020-07-30 12:40 ` Julien Thierry
2020-07-30 13:33 ` peterz
2020-07-30 13:45 ` Julien Thierry
2020-07-30 14:28 ` Josh Poimboeuf
2020-07-30 14:06 ` [PATCH v3 0/4] Remove dependency of check subcmd upon orc Josh Poimboeuf
2020-07-30 14:42 ` Julien Thierry
2020-07-30 15:05 ` Josh Poimboeuf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f0b948c8-c824-4d8e-6a0b-20cde05444d7@redhat.com \
--to=jthierry@redhat.com \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mbenes@suse.cz \
--cc=mhelsley@vmware.com \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®