mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Moger, Babu" <babu.moger@amd.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
	corbet@lwn.net, tony.luck@intel.com, Dave.Martin@arm.com,
	james.morse@arm.com, tglx@linutronix.de, mingo@redhat.com,
	bp@alien8.de, dave.hansen@linux.intel.com
Cc: x86@kernel.org, hpa@zytor.com, akpm@linux-foundation.org,
	paulmck@kernel.org, rostedt@goodmis.org, Neeraj.Upadhyay@amd.com,
	david@redhat.com, arnd@arndb.de, fvdl@google.com,
	seanjc@google.com, thomas.lendacky@amd.com,
	pawan.kumar.gupta@linux.intel.com, yosry.ahmed@linux.dev,
	sohil.mehta@intel.com, xin@zytor.com, kai.huang@intel.com,
	xiaoyao.li@intel.com, peterz@infradead.org, me@mixaill.net,
	mario.limonciello@amd.com, xin3.li@intel.com,
	ebiggers@google.com, ak@linux.intel.com,
	chang.seok.bae@intel.com, andrew.cooper3@citrix.com,
	perry.yuan@amd.com, linux-doc@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v7 05/10] fs/resctrl: Update bit_usage to reflect io_alloc
Date: Mon, 4 Aug 2025 16:20:43 -0500	[thread overview]
Message-ID: <f1721eba-2963-46c2-a68d-dd53f274df01@amd.com> (raw)
In-Reply-To: <94d075e0-6703-449f-9c0c-8e5973349dff@intel.com>

Hi Reinette,

On 7/21/25 18:35, Reinette Chatre wrote:
> Hi Babu,
> 
> On 7/10/25 10:16 AM, Babu Moger wrote:
>> When the io_alloc feature is enabled, a portion of the cache can be
>> configured for shared use between hardware and software.
>>
>> Update the bit_usage representation to reflect the io_alloc configuration.
> 
> This patch is early in the series but also relies on capabilities added
> later in the series. This cryptic changelog leaves a lot for the user
> to decipher. For example:
> - How is the "io_alloc CLOSID" chosen? This is mentioned in cover letter but
>   not here. Doing so here may help explain the hardcoding of CDP_CODE done
>   in this patch (which seem unnecessary, more later, but a lot depends on
>   changes that follow this patch).
> - No mention that when io_alloc is enabled then an associated CLOSID will
>   be allocated. This is done later in series but assumed to be known here
>   where rdt_bit_usage_show() implicitly assumes that when io_alloc is enabled
>   then the "io_alloc CLOSID" is supported AND allocated (otherwise array overrun?)

Make sense. Moved this patch to the last.

> 
>>
>> Signed-off-by: Babu Moger <babu.moger@amd.com>
>> ---
>> v7: New patch split from earlier patch #5.
>>     Added resctrl_io_alloc_closid() to return max COSID.
>> ---
>>  Documentation/filesystems/resctrl.rst | 20 ++++++++++-----
>>  fs/resctrl/rdtgroup.c                 | 37 +++++++++++++++++++++++++--
>>  2 files changed, 49 insertions(+), 8 deletions(-)
>>
>> diff --git a/Documentation/filesystems/resctrl.rst b/Documentation/filesystems/resctrl.rst
>> index c7949dd44f2f..c3c412733632 100644
>> --- a/Documentation/filesystems/resctrl.rst
>> +++ b/Documentation/filesystems/resctrl.rst
>> @@ -89,12 +89,20 @@ related to allocation:
>>  		must be set when writing a mask.
>>  
>>  "shareable_bits":
>> -		Bitmask of shareable resource with other executing
>> -		entities (e.g. I/O). User can use this when
>> -		setting up exclusive cache partitions. Note that
>> -		some platforms support devices that have their
>> -		own settings for cache use which can over-ride
>> -		these bits.
>> +		Bitmask of shareable resource with other executing entities
>> +		(e.g. I/O). Applies to all instances of this resource. User
>> +		can use this when setting up exclusive cache partitions.
>> +		Note that some platforms support devices that have their
>> +		own settings for cache use which can over-ride these bits.
>> +
>> +		When "io_alloc" feature is enabled, a portion of the cache
>> +		can be configured for shared use between hardware and software.
> 
> To help distinguish how "io_alloc" is different from "shareable_bits" this can be:
> 		When "io_alloc" is enabled, a portion of each cache instance can
> 		be configured for shared use between hardware and software.

Sure.

> 
> Please merge these two paragraphs.

Sure.

> 
>> +		"bit_usage" should be used to see which portions of each cache
>> +		instance is configured for hardware use via "io_alloc" feature
>> +		because every cache instance can have its "io_alloc" bitmask
>> +		configured independently.
> 
> append " via "io_alloc_cbm"."?

sure.

> (but io_alloc_cbm does not exist at this point ... another motivation for this
> patch to move later)
> 

Sure.

>> +
>>  "bit_usage":
>>  		Annotated capacity bitmasks showing how all
>>  		instances of the resource are used. The legend is:
> 
> Please note that this "bit_usage" section contain several references to "shareable_bits"
> that should be updated to refer to "io_alloc_cbm" also.
> 
> With all these new terms introduced as common knowledge it is starting to look
> like this patch would be easier to consume later in the series.

Sure.

> 
>> diff --git a/fs/resctrl/rdtgroup.c b/fs/resctrl/rdtgroup.c
>> index 77d08229d855..a2eea85aecc8 100644
>> --- a/fs/resctrl/rdtgroup.c
>> +++ b/fs/resctrl/rdtgroup.c
>> @@ -1030,6 +1030,20 @@ static int rdt_shareable_bits_show(struct kernfs_open_file *of,
>>  	return 0;
>>  }
>>  
>> +/*
>> + * resctrl_io_alloc_closid() - io_alloc feature routes I/O traffic using
>> + * the highest available CLOSID. Retrieve the maximum CLOSID supported by the
>> + * resource. Note that if Code Data Prioritization (CDP) is enabled, the number
>> + * of available CLOSIDs is reduced by half.
>> + */
>> +static u32 resctrl_io_alloc_closid(struct rdt_resource *r)
> 
> Please move to ctrlmondata.c.

Yes.

> 
>> +{
>> +	if (resctrl_arch_get_cdp_enabled(r->rid))
>> +		return resctrl_arch_get_num_closid(r) / 2  - 1;
>> +	else
>> +		return resctrl_arch_get_num_closid(r) - 1;
>> +}
>> +
>>  /*
>>   * rdt_bit_usage_show - Display current usage of resources
>>   *
>> @@ -1063,15 +1077,17 @@ static int rdt_bit_usage_show(struct kernfs_open_file *of,
>>  
>>  	cpus_read_lock();
>>  	mutex_lock(&rdtgroup_mutex);
>> -	hw_shareable = r->cache.shareable_bits;
>>  	list_for_each_entry(dom, &r->ctrl_domains, hdr.list) {
>>  		if (sep)
>>  			seq_putc(seq, ';');
>> +		hw_shareable = r->cache.shareable_bits;
>>  		sw_shareable = 0;
>>  		exclusive = 0;
>>  		seq_printf(seq, "%d=", dom->hdr.id);
>>  		for (i = 0; i < closids_supported(); i++) {
>> -			if (!closid_allocated(i))
>> +			if (!closid_allocated(i) ||
>> +			    (resctrl_arch_get_io_alloc_enabled(r) &&
>> +			     i == resctrl_io_alloc_closid(r)))
>>  				continue;
>>  			ctrl_val = resctrl_arch_get_config(r, dom, i,
>>  							   s->conf_type);
>> @@ -1099,6 +1115,23 @@ static int rdt_bit_usage_show(struct kernfs_open_file *of,
>>  				break;
>>  			}
>>  		}
>> +
>> +		/*
>> +		 * When the "io_alloc" feature is enabled, a portion of the
>> +		 * cache is configured for shared use between hardware and software.
>> +		 */
>> +		if (resctrl_arch_get_io_alloc_enabled(r)) {
> 
> Here is undocumented implicit assumption that when io_alloc is enabled then
> the "io_alloc CLOSID" is allocated. This is also outside the closids_supported()
> loop which adds the other implicit assumption that if io_alloc is enabled then
> its CLOSID is supported by resctrl fs. None of these concepts have been introduced
> so far and is not mentioned in changelog.
> It is not obvious here that an io_alloc CLOSID must be supported (this is just
> something enforced by later patches) and also not obvious that an io_alloc CLOSID
> must be allocated from same "pool" as other CLOSIDs. Without a good changelog and
> context of later patches this is hard to understand.
> These are motivations for this patch to move later in the series and then the
> changelog can just refer to these assumptions as fact, making it all easier to follow.

Sure.

> 
>> +			if (resctrl_arch_get_cdp_enabled(r->rid))
>> +				ctrl_val = resctrl_arch_get_config(r, dom,
>> +								   resctrl_io_alloc_closid(r),
>> +								   CDP_CODE);
>> +			else
>> +				ctrl_val = resctrl_arch_get_config(r, dom,
>> +								   resctrl_io_alloc_closid(r),
>> +								   CDP_NONE);
> 
> This does not look necessary to me. Why not just:
> 		if (resctrl_arch_get_io_alloc_enabled(r)) {
> 			ctrl_val = resctrl_arch_get_config(r, dom,
> 							   resctrl_io_alloc_closid(r),
> 							   s->conf_type);
> 			hw_shareable |= ctrl_val;
> 		}
> 
> Since the later patches keep the CDP_CODE and CDP_DATA CBMs in sync it does not matter
> if the io_alloc CBM is obtained from CDP_CODE or CDP_DATA and just providing the
> schema's type to resctrl_arch_get_config() will have it retrieve the right CBM, no?

Yes. That is correct.

> 
> This may also be easier to understand/claim if this patch is later in the series.

Sure.

> 
> 
>> +			hw_shareable |= ctrl_val;
>> +		}
>> +
>>  		for (i = r->cache.cbm_len - 1; i >= 0; i--) {
>>  			pseudo_locked = dom->plr ? dom->plr->cbm : 0;
>>  			hwb = test_bit(i, &hw_shareable);
> 
> Reinette
> 

-- 
Thanks
Babu Moger


  reply	other threads:[~2025-08-04 21:20 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-10 17:16 [PATCH v7 00/10] x86,fs/resctrl: Support L3 Smart Data Cache Injection Allocation Enforcement (SDCIAE) Babu Moger
2025-07-10 17:16 ` [PATCH v7 01/10] x86/cpufeatures: Add support for L3 Smart Data Cache Injection Allocation Enforcement Babu Moger
2025-07-10 23:26   ` Borislav Petkov
2025-07-21 23:28   ` Reinette Chatre
2025-07-10 17:16 ` [PATCH v7 02/10] x86/resctrl: Add SDCIAE feature in the command line options Babu Moger
2025-07-21 23:29   ` Reinette Chatre
2025-07-31 16:28     ` Moger, Babu
2025-07-10 17:16 ` [PATCH v7 03/10] x86,fs/resctrl: Detect io_alloc feature Babu Moger
2025-07-21 23:29   ` Reinette Chatre
2025-07-10 17:16 ` [PATCH v7 04/10] x86,fs/resctrl: Implement "io_alloc" enable/disable handlers Babu Moger
2025-07-21 23:32   ` Reinette Chatre
2025-07-31 17:40     ` Moger, Babu
2025-07-10 17:16 ` [PATCH v7 05/10] fs/resctrl: Update bit_usage to reflect io_alloc Babu Moger
2025-07-21 23:35   ` Reinette Chatre
2025-08-04 21:20     ` Moger, Babu [this message]
2025-07-10 17:16 ` [PATCH v7 06/10] fs/resctrl: Introduce interface to display "io_alloc" support Babu Moger
2025-07-21 23:36   ` Reinette Chatre
2025-07-31 18:51     ` Moger, Babu
2025-07-10 17:16 ` [PATCH v7 07/10] fs/resctrl: Add user interface to enable/disable io_alloc feature Babu Moger
2025-07-21 23:40   ` Reinette Chatre
2025-07-31 22:52     ` Moger, Babu
2025-08-04 16:07       ` Reinette Chatre
2025-08-04 17:14         ` Moger, Babu
2025-07-10 17:16 ` [PATCH v7 08/10] fs/resctrl: Introduce interface to display io_alloc CBMs Babu Moger
2025-07-21 23:42   ` Reinette Chatre
2025-08-04 18:14     ` Moger, Babu
2025-07-10 17:16 ` [PATCH v7 09/10] fs/resctrl: Modify rdt_parse_data to pass mode and CLOSID Babu Moger
2025-07-22  3:30   ` Reinette Chatre
2025-08-04 19:32     ` Moger, Babu
2025-07-10 17:16 ` [PATCH v7 10/10] fs/resctrl: Introduce interface to modify io_alloc Capacity Bit Masks Babu Moger
2025-07-22  3:32   ` Reinette Chatre
2025-08-04 21:01     ` Moger, Babu
2025-07-21 23:28 ` [PATCH v7 00/10] x86,fs/resctrl: Support L3 Smart Data Cache Injection Allocation Enforcement (SDCIAE) Reinette Chatre
2025-08-04 21:34   ` Moger, Babu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f1721eba-2963-46c2-a68d-dd53f274df01@amd.com \
    --to=babu.moger@amd.com \
    --cc=Dave.Martin@arm.com \
    --cc=Neeraj.Upadhyay@amd.com \
    --cc=ak@linux.intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=andrew.cooper3@citrix.com \
    --cc=arnd@arndb.de \
    --cc=bp@alien8.de \
    --cc=chang.seok.bae@intel.com \
    --cc=corbet@lwn.net \
    --cc=dave.hansen@linux.intel.com \
    --cc=david@redhat.com \
    --cc=ebiggers@google.com \
    --cc=fvdl@google.com \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=kai.huang@intel.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mario.limonciello@amd.com \
    --cc=me@mixaill.net \
    --cc=mingo@redhat.com \
    --cc=paulmck@kernel.org \
    --cc=pawan.kumar.gupta@linux.intel.com \
    --cc=perry.yuan@amd.com \
    --cc=peterz@infradead.org \
    --cc=reinette.chatre@intel.com \
    --cc=rostedt@goodmis.org \
    --cc=seanjc@google.com \
    --cc=sohil.mehta@intel.com \
    --cc=tglx@linutronix.de \
    --cc=thomas.lendacky@amd.com \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    --cc=xiaoyao.li@intel.com \
    --cc=xin3.li@intel.com \
    --cc=xin@zytor.com \
    --cc=yosry.ahmed@linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome