From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1761887AbdAKWBb (ORCPT ); Wed, 11 Jan 2017 17:01:31 -0500 Received: from mail-wm0-f67.google.com ([74.125.82.67]:33777 "EHLO mail-wm0-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756217AbdAKWB0 (ORCPT ); Wed, 11 Jan 2017 17:01:26 -0500 Subject: Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations To: SF Markus Elfring , linux-mtd@lists.infradead.org, Boris Brezillon , Brian Norris , Cyrille Pitchen , David Woodhouse , Denys Vlasenko , Richard Weinberger References: <71189baa-8780-b80a-0b4d-9dae74763ba3@users.sourceforge.net> Cc: kernel-janitors@vger.kernel.org, LKML From: Marek Vasut Message-ID: Date: Wed, 11 Jan 2017 22:58:27 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.4.0 MIME-Version: 1.0 In-Reply-To: <71189baa-8780-b80a-0b4d-9dae74763ba3@users.sourceforge.net> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 01/11/2017 09:34 PM, SF Markus Elfring wrote: > From: Markus Elfring > Date: Wed, 11 Jan 2017 21:21:12 +0100 > > Several update suggestions were taken into account > from static source code analysis. The patch listing doesn't seem to match the content of the patchset ? The $subject are different ... > Markus Elfring (18): > Use kmalloc_array() in cfi_intelext_partition_fixup() > Improve another size determination in cfi_intelext_partition_fixup() > cfi_cmdset_0001: Add some spaces for better code readability > cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword() > cfi_cmdset_0001: Use common error handling code in do_write_oneword() > Use kcalloc() in cfi_intelext_setup() > One function call and an unnecessary check less in cfi_intelext_setup() > Rename a jump label in cfi_intelext_setup() > Use kmalloc_array() in cfi_amdstd_setup() > One function call less in cfi_amdstd_setup() after error detection > Rename a jump label in cfi_amdstd_setup() > cfi_cmdset_0002: Add some spaces for better code readability > cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword() > cfi_cmdset_0002: Use common error handling code in do_write_oneword() > Use kcalloc() in cfi_ppb_unlock() > Use kmalloc_array() in cfi_staa_setup() > Use common error handling code in cfi_staa_setup() > cfi_cmdset_0020: Add some spaces for better code readability > > drivers/mtd/chips/cfi_cmdset_0001.c | 165 +++++++++++++++++++----------------- > drivers/mtd/chips/cfi_cmdset_0002.c | 110 +++++++++++++----------- > drivers/mtd/chips/cfi_cmdset_0020.c | 127 ++++++++++++++------------- > 3 files changed, 214 insertions(+), 188 deletions(-) > -- Best regards, Marek Vasut