From: "Thomas Weißschuh" <linux@weissschuh.net>
To: Melissa Wen <mwen@igalia.com>
Cc: "Harry Wentland" <harry.wentland@amd.com>,
"Leo Li" <sunpeng.li@amd.com>,
"Rodrigo Siqueira" <Rodrigo.Siqueira@amd.com>,
"Alex Deucher" <alexander.deucher@amd.com>,
"Christian König" <christian.koenig@amd.com>,
"Xinhui Pan" <Xinhui.Pan@amd.com>,
"David Airlie" <airlied@gmail.com>,
"Daniel Vetter" <daniel@ffwll.ch>, jinzh <jinzh@github.amd.com>,
"Aric Cyr" <Aric.Cyr@amd.com>, "Alan Liu" <HaoPing.Liu@amd.com>,
"Tony Cheng" <Tony.Cheng@amd.com>,
"Andrey Grodzovsky" <Andrey.Grodzovsky@amd.com>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 00/12] drm/amd: Switch over to struct drm_edid
Date: Mon, 19 Aug 2024 20:39:34 +0200 [thread overview]
Message-ID: <f2664caa-8bf5-4f6d-903c-3de01977e89e@t-8ch.de> (raw)
In-Reply-To: <3v3yvr6adlnqgbwbnvhfwj3ylpptunqyvosazyebvov3osdprb@znkx32uxku5q>
Hi Melissa,
On 2024-08-19 11:31:44+0000, Melissa Wen wrote:
> On 08/18, Thomas Weißschuh wrote:
> > The AMD DRM drivers use 'struct edid', raw pointers and even custom
> > structs to represent EDID data.
> > Uniformly switch to the safe and recommended "struct drm_edid".
> >
> > Some uses of "struct edid" are left because some ad-hoc parsing is still
> > being done inside the drivers.
>
> Hi Thomas,
>
> It's great to see more people working on removing raw edid from amd
> display driver in favor of drm_edid.
>
> I glanced over your series and I found it similar to my recent proposal
> to migrate amdgpu_dm_connector from edid to drm_edid. You can find the
> v5 of this work here:
> https://lore.kernel.org/amd-gfx/20240807203207.2830-1-mwen@igalia.com/
thanks for the pointer.
> I believe it's more productive if we can join efforts and improve that
> proposal instead of duplicating work. I'll look at your patches more
> carefully this week. If you can review my work, I'd be happy to hear
> your feedback too.
Indeed. I'll take a look at your patches.
Let's see how they can be combined.
> Thanks,
>
> Melissa
>
> >
> > The patch "drm/amd/display: Switch amdgpu_dm_connector to struct drm_edid"
> > will conflict with my backlight quirk series [0].
> > The conflict will result in an obvious and easy to fix build failure.
> >
> > Patches 1 and 2 delete some dead code.
> > Patches 3 to 6 constify some arguments and shuffle around some code.
> > The remaining patches perform the actual conversion in steps.
> >
> > [0] https://lore.kernel.org/lkml/20240818-amdgpu-min-backlight-quirk-v5-0-b6c0ead0c73d@weissschuh.net/
> >
> > Signed-off-by: Thomas Weißschuh <linux@weissschuh.net>
> > ---
> > Thomas Weißschuh (12):
> > drm/amd/display: remove spurious definition for dm_helpers_get_sbios_edid()
> > drm/amd/display: Remove EDID members of ddc_service
> > drm/edid: constify argument of drm_edid_is_valid()
> > drm/amd/display: Simplify raw_edid handling in dm_helpers_parse_edid_caps()
> > drm/amd/display: Constify raw_edid handling in dm_helpers_parse_edid_caps()
> > drm/amd/display: Constify 'struct edid' in parsing functions
> > drm/amd/display: Use struct edid in dc_link_add_remote_sink()
> > drm/amdgpu: Switch amdgpu_connector to struct drm_edid
> > drm/amd/display: Switch amdgpu_dm_connector to struct drm_edid
> > drm/edid: add a helper to compare two EDIDs
> > drm/amd/display: Switch dc_sink to struct drm_edid
> > drm/amd/display: Switch dc_link_add_remote_sink() to struct drm_edid
> >
> > drivers/gpu/drm/amd/amdgpu/amdgpu_connectors.c | 56 ++++++++-------
> > drivers/gpu/drm/amd/amdgpu/amdgpu_mode.h | 3 +-
> > drivers/gpu/drm/amd/amdgpu/dce_v10_0.c | 4 +-
> > drivers/gpu/drm/amd/amdgpu/dce_v11_0.c | 4 +-
> > drivers/gpu/drm/amd/amdgpu/dce_v6_0.c | 4 +-
> > drivers/gpu/drm/amd/amdgpu/dce_v8_0.c | 4 +-
> > drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 84 +++++++++++-----------
> > drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.h | 5 +-
> > .../drm/amd/display/amdgpu_dm/amdgpu_dm_helpers.c | 34 +++++----
> > .../amd/display/amdgpu_dm/amdgpu_dm_mst_types.c | 28 ++++----
> > .../gpu/drm/amd/display/dc/core/dc_link_exports.c | 5 +-
> > drivers/gpu/drm/amd/display/dc/dc.h | 8 +--
> > drivers/gpu/drm/amd/display/dc/dc_ddc_types.h | 7 --
> > drivers/gpu/drm/amd/display/dc/dc_types.h | 5 --
> > drivers/gpu/drm/amd/display/dc/dm_helpers.h | 4 +-
> > drivers/gpu/drm/amd/display/dc/inc/link.h | 3 +-
> > .../gpu/drm/amd/display/dc/link/link_detection.c | 42 ++++-------
> > .../gpu/drm/amd/display/dc/link/link_detection.h | 3 +-
> > drivers/gpu/drm/drm_edid.c | 20 +++++-
> > include/drm/drm_edid.h | 3 +-
> > 20 files changed, 155 insertions(+), 171 deletions(-)
> > ---
> > base-commit: 207565ee2594ac47261cdfc8a5048f4dc322c878
> > change-id: 20240615-amdgpu-drm_edid-32d969dfb899
> >
> > Best regards,
> > --
> > Thomas Weißschuh <linux@weissschuh.net>
> >
prev parent reply other threads:[~2024-08-19 18:39 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-18 10:43 Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 01/12] drm/amd/display: remove spurious definition for dm_helpers_get_sbios_edid() Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 02/12] drm/amd/display: Remove EDID members of ddc_service Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 03/12] drm/edid: constify argument of drm_edid_is_valid() Thomas Weißschuh
2024-08-19 8:21 ` Jani Nikula
2024-08-19 18:31 ` Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 04/12] drm/amd/display: Simplify raw_edid handling in dm_helpers_parse_edid_caps() Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 05/12] drm/amd/display: Constify " Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 06/12] drm/amd/display: Constify 'struct edid' in parsing functions Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 07/12] drm/amd/display: Use struct edid in dc_link_add_remote_sink() Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 08/12] drm/amdgpu: Switch amdgpu_connector to struct drm_edid Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 09/12] drm/amd/display: Switch amdgpu_dm_connector " Thomas Weißschuh
2024-08-19 8:26 ` Jani Nikula
2024-08-18 10:43 ` [PATCH 10/12] drm/edid: add a helper to compare two EDIDs Thomas Weißschuh
2024-08-19 8:45 ` Jani Nikula
2024-08-18 10:43 ` [PATCH 11/12] drm/amd/display: Switch dc_sink to struct drm_edid Thomas Weißschuh
2024-08-18 10:43 ` [PATCH 12/12] drm/amd/display: Switch dc_link_add_remote_sink() " Thomas Weißschuh
2024-08-19 14:31 ` [PATCH 00/12] drm/amd: Switch over " Melissa Wen
2024-08-19 18:39 ` Thomas Weißschuh [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f2664caa-8bf5-4f6d-903c-3de01977e89e@t-8ch.de \
--to=linux@weissschuh.net \
--cc=Andrey.Grodzovsky@amd.com \
--cc=Aric.Cyr@amd.com \
--cc=HaoPing.Liu@amd.com \
--cc=Rodrigo.Siqueira@amd.com \
--cc=Tony.Cheng@amd.com \
--cc=Xinhui.Pan@amd.com \
--cc=airlied@gmail.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=christian.koenig@amd.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=harry.wentland@amd.com \
--cc=jinzh@github.amd.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=mwen@igalia.com \
--cc=sunpeng.li@amd.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®