mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pavel Skripkin <paskripkin@gmail.com>
To: Saurav Girepunje <saurav.girepunje@gmail.com>,
	Larry.Finger@lwfinger.net, phil@philpotter.co.uk,
	gregkh@linuxfoundation.org, straube.linux@gmail.com,
	martin@kaiser.cx, linux-staging@lists.linux.dev,
	linux-kernel@vger.kernel.org
Cc: saurav.girepunje@hotmail.com
Subject: Re: [PATCH] staging: r8188eu: os_dep: remove the goto statement
Date: Sun, 31 Oct 2021 21:43:57 +0300	[thread overview]
Message-ID: <f26b4aec-c0a1-8c93-b34e-8b1a36ac81b3@gmail.com> (raw)
In-Reply-To: <YX7cCtVss2RWOJ/a@Sauravs-MacBook-Air.local>

On 10/31/21 21:10, Saurav Girepunje wrote:
> Remove the goto statement from rtw_init_drv_sw(). In this function goto
> can be replace by return statement. As on goto label exit, function
> only return it is not performing any cleanup. Avoiding goto will
> improve the function readability.
> 
> Signed-off-by: Saurav Girepunje <saurav.girepunje@gmail.com>
> ---
>   drivers/staging/r8188eu/os_dep/os_intfs.c | 39 +++++++----------------
>   1 file changed, 12 insertions(+), 27 deletions(-)
> 
> diff --git a/drivers/staging/r8188eu/os_dep/os_intfs.c b/drivers/staging/r8188eu/os_dep/os_intfs.c
> index 1418c9c4916c..4b409479108e 100644
> --- a/drivers/staging/r8188eu/os_dep/os_intfs.c
> +++ b/drivers/staging/r8188eu/os_dep/os_intfs.c
> @@ -480,48 +480,34 @@ u8 rtw_init_drv_sw(struct adapter *padapter)
>   {
>   	u8	ret8 = _SUCCESS;
> 


Btw, this variable can be removed completely then. It's used only for:

ret8 = rtw_init_default_value(padapter);

with your patch applied, but rtw_init_default_value() always returns 
_SUCCESS.


> -exit:
>  	return ret8;
>  }


And just `return _SUCCESS;` here.



With regards,
Pavel Skripkin

  reply	other threads:[~2021-10-31 18:44 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-31 18:10 Saurav Girepunje
2021-10-31 18:43 ` Pavel Skripkin [this message]
2021-10-31 19:17   ` Joe Perches
2021-11-01  4:28     ` Saurav Girepunje
2021-11-01  4:31       ` Joe Perches
2021-10-31 19:17   ` Saurav Girepunje
2021-10-31 19:24     ` Pavel Skripkin
2021-10-31 19:27       ` Pavel Skripkin
2021-11-02 16:40         ` Saurav Girepunje
2021-11-02 20:20           ` Pavel Skripkin
2021-11-01 13:01 ` Greg KH
2021-11-02 16:30   ` Saurav Girepunje

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f26b4aec-c0a1-8c93-b34e-8b1a36ac81b3@gmail.com \
    --to=paskripkin@gmail.com \
    --cc=Larry.Finger@lwfinger.net \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=martin@kaiser.cx \
    --cc=phil@philpotter.co.uk \
    --cc=saurav.girepunje@gmail.com \
    --cc=saurav.girepunje@hotmail.com \
    --cc=straube.linux@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®