From: Paolo Bonzini <pbonzini@redhat.com>
To: Xiaoyao Li <xiaoyao.li@intel.com>,
Sean Christopherson <sean.j.christopherson@intel.com>
Cc: Vitaly Kuznetsov <vkuznets@redhat.com>,
Wanpeng Li <wanpengli@tencent.com>,
Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 0/5] Refactor handling flow of KVM_SET_CPUID*
Date: Thu, 9 Jul 2020 13:08:33 +0200 [thread overview]
Message-ID: <f2814b87-5b15-e165-9042-a650e0acf9e1@redhat.com> (raw)
In-Reply-To: <20200709043426.92712-1-xiaoyao.li@intel.com>
On 09/07/20 06:34, Xiaoyao Li wrote:
> 4 Patches of v3 has been queued into kvm/queue branch. This v4 contains
> the rest to refactor the flow of KVM_SET_CPUID* as:
>
> 1. cpuid check: check if userspace provides legal CPUID settings;
>
> 2. cpuid update: Update userspace provided CPUID settings. It currently
> only contains kvm_update_cpuid_runtime, which updates special CPUID
> bits based on the vcpu state, e.g., OSXSAVE, OSPKE. In the future, we
> can re-introduce kvm_update_cpuid() if KVM needs to force on/off some
> bits.
>
> 3. update vcpu states: Update vcpu states/settings based on the final updated
> CPUID settings.
>
> v4:
> - remove 4 queued patches
> - rebased to kvm/queue: c16ced9cc67a "x86/kvm/vmx: Use native read/write_cr2()"
> - fix one bug in v3 to call kvfree(cpuid_entries) in kvm_vcpu_ioctl_set_cpuid()
> - rename "update_vcpu_model" to "vcpu_after_set_cpuid" [Paolo]
> - Add a new patch to extrace kvm_update_cpuid_runtime()
>
> v3:
> https://lkml.kernel.org/r/20200708065054.19713-1-xiaoyao.li@intel.com
> - Add a note in KVM api doc to state the previous CPUID configuration
> is not reliable if current KVM_SET_CPUID* fails [Jim]
> - Adjust Patch 2 to reduce code churn [Sean]
> - Commit message refine to add more justification [Sean]
> - Add a new patch 7
>
> v2:
> https://lkml.kernel.org/r/20200623115816.24132-1-xiaoyao.li@intel.com
> - rebase to kvm/queue: a037ff353ba6 ("Merge branch 'kvm-master' into HEAD")
> - change the name of kvm_update_state_based_on_cpuid() to
> kvm_update_vcpu_model() [Sean]
> - Add patch 5 to rename kvm_x86_ops.cpuid_date() to
> kvm_x86_ops.update_vcpu_model()
>
> v1:
> https://lkml.kernel.org/r/20200529085545.29242-1-xiaoyao.li@intel.com
>
> Xiaoyao Li (5):
> KVM: x86: Introduce kvm_check_cpuid()
> KVM: x86: Extract kvm_update_cpuid_runtime() from kvm_update_cpuid()
> KVM: x86: Rename kvm_update_cpuid() to kvm_vcpu_after_set_cpuid()
> KVM: x86: Rename cpuid_update() callback to vcpu_after_set_cpuid()
> KVM: x86: Move kvm_x86_ops.vcpu_after_set_cpuid() into
> kvm_vcpu_after_set_cpuid()
>
> arch/x86/include/asm/kvm_host.h | 2 +-
> arch/x86/kvm/cpuid.c | 99 +++++++++++++++++++++------------
> arch/x86/kvm/cpuid.h | 2 +-
> arch/x86/kvm/lapic.c | 2 +-
> arch/x86/kvm/svm/svm.c | 4 +-
> arch/x86/kvm/vmx/nested.c | 3 +-
> arch/x86/kvm/vmx/vmx.c | 4 +-
> arch/x86/kvm/x86.c | 10 ++--
> 8 files changed, 76 insertions(+), 50 deletions(-)
>
Queued, thanks.
Paolo
prev parent reply other threads:[~2020-07-09 11:08 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-07-09 4:34 Xiaoyao Li
2020-07-09 4:34 ` [PATCH v4 1/5] KVM: x86: Introduce kvm_check_cpuid() Xiaoyao Li
2020-07-09 4:34 ` [PATCH v4 2/5] KVM: x86: Extract kvm_update_cpuid_runtime() from kvm_update_cpuid() Xiaoyao Li
2020-07-09 10:55 ` Paolo Bonzini
2020-07-09 4:34 ` [PATCH v4 3/5] KVM: x86: Rename kvm_update_cpuid() to kvm_vcpu_after_set_cpuid() Xiaoyao Li
2020-07-09 4:34 ` [PATCH v4 4/5] KVM: x86: Rename cpuid_update() callback to vcpu_after_set_cpuid() Xiaoyao Li
2020-07-09 4:34 ` [PATCH v4 5/5] KVM: x86: Move kvm_x86_ops.vcpu_after_set_cpuid() into kvm_vcpu_after_set_cpuid() Xiaoyao Li
2020-07-09 11:08 ` Paolo Bonzini [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f2814b87-5b15-e165-9042-a650e0acf9e1@redhat.com \
--to=pbonzini@redhat.com \
--cc=jmattson@google.com \
--cc=joro@8bytes.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=sean.j.christopherson@intel.com \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
--cc=xiaoyao.li@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®