From: Dev Jain <dev.jain@arm.com>
To: Barry Song <baohua@kernel.org>
Cc: akpm@linux-foundation.org, david@kernel.org, ljs@kernel.org,
hughd@google.com, chrisl@kernel.org, kasong@tencent.com,
riel@surriel.com, liam@infradead.org, vbabka@kernel.org,
harry@kernel.org, jannh@google.com, lance.yang@linux.dev,
baolin.wang@linux.alibaba.com, shikemeng@huaweicloud.com,
nphamcs@gmail.com, baoquan.he@linux.dev, youngjun.park@lge.com,
linux-mm@kvack.org, linux-kernel@vger.kernel.org,
rppt@kernel.org, surenb@google.com, mhocko@suse.com,
pfalcato@suse.de, ryan.roberts@arm.com,
anshuman.khandual@arm.com
Subject: Re: [PATCH v2 4/8] mm/rmap: Add batched version of folio_try_share_anon_rmap_pte
Date: Wed, 9 Sep 2026 13:14:39 +0530 [thread overview]
Message-ID: <f4edb66c-1891-4d7b-83c2-d8251715fadd@arm.com> (raw)
In-Reply-To: <CAGsJ_4zWPXoJ5kiLoVcq1YHv6WcmjPEssTUs4OT15iNRob3_rQ@mail.gmail.com>
On 09/09/26 2:49 am, Barry Song wrote:
> On Tue, Sep 1, 2026 at 1:44 PM Dev Jain <dev.jain@arm.com> wrote:
>>
>> To enable batched unmapping of anonymous folios, we need to handle the
>> sharing of exclusive pages. Hence, a batched version of
>> folio_try_share_anon_rmap_pte is required.
>>
>> Currently, the sole purpose of nr_pages in __folio_try_share_anon_rmap is
>> to do some rmap sanity checks. Now, clear the PageAnonExclusive bit on a
>> batch of nr_pages. Refactor the function such that the clearing of the bit
>> can be done at one place without duplication.
>>
>> Note that __folio_try_share_anon_rmap can receive nr_pages == HPAGE_PMD_NR
>> from the PMD path, but currently we only clear the bit on the head page.
>> Retain this behaviour by setting nr_pages = 1 in case the caller is
>> folio_try_share_anon_rmap_pmd.
>>
>> While at it, convert nr_pages to unsigned long to future-proof from
>> overflow in case P4D-huge mappings etc get supported down the road.
>> I haven't made such a change in each function receiving nr_pages in
>> try_to_unmap_one - perhaps this can be done incrementally.
>>
>> Add two WARN's: check that the batch is entirely exclusive (for PMD
>> callers, need to check only head page), and that there are only
>> PTE/PMD paths converging into __folio_try_share_anon_rmap.
>>
>> Signed-off-by: Dev Jain <dev.jain@arm.com>
>> ---
>> include/linux/rmap.h | 56 ++++++++++++++++++++++++++++++--------------
>> 1 file changed, 39 insertions(+), 17 deletions(-)
>>
>> diff --git a/include/linux/rmap.h b/include/linux/rmap.h
>> index 0b332770abeed..320f9f14f6020 100644
>> --- a/include/linux/rmap.h
>> +++ b/include/linux/rmap.h
>> @@ -706,17 +706,23 @@ static inline int folio_try_dup_anon_rmap_pmd(struct folio *folio,
>> }
>>
>> static __always_inline int __folio_try_share_anon_rmap(struct folio *folio,
>> - struct page *page, int nr_pages, enum pgtable_level level)
>> + struct page *page, unsigned long nr_pages, enum pgtable_level level)
>> {
>> + /* device private folios cannot get pinned via GUP. */
>> + const bool pinnable = !folio_is_device_private(folio);
>> +
>> VM_WARN_ON_FOLIO(!folio_test_anon(folio), folio);
>> VM_WARN_ON_FOLIO(!PageAnonExclusive(page), folio);
>> +
>> __folio_rmap_sanity_checks(folio, page, nr_pages, level);
>>
>> - /* device private folios cannot get pinned via GUP. */
>> - if (unlikely(folio_is_device_private(folio))) {
>> - ClearPageAnonExclusive(page);
>> - return 0;
>> - }
>
> Somehow, I feel the early return for
> `folio_is_device_private(folio)` is more readable. Can we keep it?
> Then we can avoid many `if (pinnable)` checks later.
>
>> + VM_WARN_ON_ONCE(level > PGTABLE_LEVEL_PMD);
>
> Maybe the below would be better, as it avoids depending on the
> exact value of `PGTABLE_LEVEL_PMD` and above.
>
> VM_WARN_ON_ONCE(level != PGTABLE_LEVEL_PTE && level != PGTABLE_LEVEL_PMD);
Can do this.
>
>> +
>> + /* We only clear anon-exclusive from head page of PMD folio. */
>> + if (level == PGTABLE_LEVEL_PMD)
>> + nr_pages = 1;
>> +
>> + VM_WARN_ON_FOLIO(page_anon_exclusive_batch(0, nr_pages, page, true) != nr_pages, folio);
>>
>> /*
>> * We have to make sure that when we clear PageAnonExclusive, that
>> @@ -760,29 +766,38 @@ static __always_inline int __folio_try_share_anon_rmap(struct folio *folio,
>> * so we use explicit ones here.
>> */
>>
>> - /* Paired with the memory barrier in try_grab_folio(). */
>> - if (IS_ENABLED(CONFIG_HAVE_GUP_FAST))
>> - smp_mb();
>> + if (likely(pinnable)) {
>> + /* Paired with the memory barrier in try_grab_folio(). */
>> + if (IS_ENABLED(CONFIG_HAVE_GUP_FAST))
>> + smp_mb();
>
> If we return early for `!pinnable`, shouldn't we be able to avoid
> this? Is the reason you don't do the early return that you want to
> batch the `folio_is_device_private(folio)` case as well? If so,
> that seems sensible.
Yes.
>
> Is this a real use case that you're supporting with your patchset?
>
>>
>> - if (unlikely(folio_maybe_dma_pinned(folio)))
>> - return -EBUSY;
>> - ClearPageAnonExclusive(page);
>> + if (unlikely(folio_maybe_dma_pinned(folio)))
>> + return -EBUSY;
>> + }
>> +
>> + for (;;) {
>> + ClearPageAnonExclusive(page);
>> + if (--nr_pages == 0)
>> + break;
>> + page++;
>> + }
>
> Maybe ?
>
> while (nr_pages--)
> ClearPageAnonExclusive(page++);
Was following the pattern elsewhere ... I vaguely remember the
for (;;) being faster for some reason?
>
> Best Regards
> Barry
next prev parent reply other threads:[~2026-09-09 7:44 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-01 5:43 [PATCH v2 0/8] Optimize anonymous swapbacked large folio unmapping Dev Jain
2026-09-01 5:43 ` [PATCH v2 1/8] mm/swapfile: add batched version of folio_dup_swap Dev Jain
2026-09-01 5:43 ` [PATCH v2 2/8] mm/swapfile: add batched version of folio_put_swap Dev Jain
2026-09-01 5:43 ` [PATCH v2 3/8] mm: move anon-exclusive batch helper to mm.h Dev Jain
2026-09-01 5:49 ` Barry Song
2026-09-01 6:24 ` Dev Jain
2026-09-02 6:29 ` Barry Song
2026-09-04 3:46 ` Dev Jain
2026-09-01 5:43 ` [PATCH v2 4/8] mm/rmap: Add batched version of folio_try_share_anon_rmap_pte Dev Jain
2026-09-08 21:19 ` Barry Song
2026-09-09 7:44 ` Dev Jain [this message]
2026-09-01 5:43 ` [PATCH v2 5/8] mm/internal: rename swap offset helpers to softleaf offset Dev Jain
2026-09-05 10:42 ` Barry Song
2026-09-05 10:49 ` Barry Song
2026-09-07 5:38 ` Dev Jain
2026-09-07 21:33 ` Barry Song
2026-09-08 5:38 ` Dev Jain
2026-09-08 8:41 ` Garg, Shivank
2026-09-01 5:43 ` [PATCH v2 6/8] mm/internal: add set_softleaf_ptes Dev Jain
2026-09-05 10:52 ` Barry Song
2026-09-01 5:43 ` [PATCH v2 7/8] mm/memory: use set_softleaf_ptes for uffd-wp markers Dev Jain
2026-09-05 10:53 ` Barry Song
2026-09-01 5:43 ` [PATCH v2 8/8] mm/rmap: batch unmap anonymous swap-backed large folios Dev Jain
2026-09-08 21:48 ` Barry Song
2026-09-10 4:39 ` Dev Jain
2026-09-10 4:58 ` Barry Song
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f4edb66c-1891-4d7b-83c2-d8251715fadd@arm.com \
--to=dev.jain@arm.com \
--cc=akpm@linux-foundation.org \
--cc=anshuman.khandual@arm.com \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=baoquan.he@linux.dev \
--cc=chrisl@kernel.org \
--cc=david@kernel.org \
--cc=harry@kernel.org \
--cc=hughd@google.com \
--cc=jannh@google.com \
--cc=kasong@tencent.com \
--cc=lance.yang@linux.dev \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=nphamcs@gmail.com \
--cc=pfalcato@suse.de \
--cc=riel@surriel.com \
--cc=rppt@kernel.org \
--cc=ryan.roberts@arm.com \
--cc=shikemeng@huaweicloud.com \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=youngjun.park@lge.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®