From: Tom Lendacky <thomas.lendacky@amd.com>
To: Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Weijiang Yang <weijiang.yang@intel.com>
Subject: Re: [PATCH v2 05/10] KVM: x86: Rename get_msr_feature() APIs to get_feature_msr()
Date: Mon, 5 Aug 2024 10:36:03 -0500 [thread overview]
Message-ID: <f55a236b-bd22-46a1-cf9d-c990a11d5c38@amd.com> (raw)
In-Reply-To: <20240802181935.292540-6-seanjc@google.com>
On 8/2/24 13:19, Sean Christopherson wrote:
> Rename all APIs related to feature MSRs from get_feature_msr() to
s/get_feature_msr/get_msr_feature/
Thanks,
Tom
> get_feature_msr(). The APIs get "feature MSRs", not "MSR features".
> And unlike kvm_{g,s}et_msr_common(), the "feature" adjective doesn't
> describe the helper itself.
>
> No functional change intended.
>
> Signed-off-by: Sean Christopherson <seanjc@google.com>
next prev parent reply other threads:[~2024-08-05 15:36 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-02 18:19 [PATCH v2 00/10] KVM: x86: Clean up MSR access/failure handling Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 01/10] KVM: SVM: Disallow guest from changing userspace's MSR_AMD64_DE_CFG value Sean Christopherson
2024-08-05 14:42 ` Tom Lendacky
2024-08-02 18:19 ` [PATCH v2 02/10] KVM: x86: Move MSR_TYPE_{R,W,RW} values from VMX to x86, as enums Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 03/10] KVM: x86: Rename KVM_MSR_RET_INVALID to KVM_MSR_RET_UNSUPPORTED Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 04/10] KVM: x86: Refactor kvm_x86_ops.get_msr_feature() to avoid kvm_msr_entry Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 05/10] KVM: x86: Rename get_msr_feature() APIs to get_feature_msr() Sean Christopherson
2024-08-05 15:36 ` Tom Lendacky [this message]
2024-08-02 18:19 ` [PATCH v2 06/10] KVM: x86: Refactor kvm_get_feature_msr() to avoid struct kvm_msr_entry Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 07/10] KVM: x86: Funnel all fancy MSR return value handling into a common helper Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 08/10] KVM: x86: Hoist x86.c's global msr_* variables up above kvm_do_msr_access() Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 09/10] KVM: x86: Suppress failures on userspace access to advertised, unsupported MSRs Sean Christopherson
2024-08-02 18:19 ` [PATCH v2 10/10] KVM: x86: Suppress userspace access failures on unsupported, "emulated" MSRs Sean Christopherson
2024-08-23 23:47 ` [PATCH v2 00/10] KVM: x86: Clean up MSR access/failure handling Sean Christopherson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f55a236b-bd22-46a1-cf9d-c990a11d5c38@amd.com \
--to=thomas.lendacky@amd.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=seanjc@google.com \
--cc=weijiang.yang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®