mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mario Limonciello <mario.limonciello@amd.com>
To: Lifeng Zheng <zhenglifeng1@huawei.com>,
	rafael@kernel.org, lenb@kernel.org, robert.moore@intel.com,
	viresh.kumar@linaro.org, gautham.shenoy@amd.com,
	ray.huang@amd.com, perry.yuan@amd.com, pierre.gondois@arm.com,
	sumitg@nvidia.com
Cc: acpica-devel@lists.linux.dev, linux-acpi@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org,
	linuxarm@huawei.com, jonathan.cameron@huawei.com,
	zhanjie9@hisilicon.com, lihuisong@huawei.com,
	cenxinghai@h-partners.com, hepeng68@huawei.com
Subject: Re: [PATCH v7 0/8] Add functions for getting and setting registers related to autonomous selection in cppc_acpi
Date: Fri, 11 Apr 2025 13:18:14 -0500	[thread overview]
Message-ID: <f6904bb1-f41f-4be9-92bb-92fec509a821@amd.com> (raw)
In-Reply-To: <20250411093855.982491-1-zhenglifeng1@huawei.com>

On 4/11/2025 4:38 AM, Lifeng Zheng wrote:
> The patch series is organized in two parts:
> 
>   - patch 1-6 refactor out the general CPPC register get and set functions
>     in cppc_acpi.c
> 
>   - patches 7-8 add functions for getting and setting values of auto_sel,
>     energy_perf and auto_act_window in cppc_acpi.c
> 
> Changelog:
> 
> v7:
> 
>   - Fix some typos
>   - Add check of null pointer in cppc_get_reg_val(),
>     cppc_get_auto_act_window() and cppc_get_auto_sel()
>   - Replace ternary operator with logical expression in cppc_get_reg_val()
> 
> v6:
> 
>   - Remove the last patch, will resent it in the future after reaching an
>     agreement with Sumit
>   - split patch 3 into 2 smaller patches
>   - Remove the printing of reg_idx in cppc_get_reg_val() and
>     cppc_set_reg_val()
>   - Change the logic for determing whether a register is supported in
>     cppc_get_reg_val() and cppc_set_reg_val()
> 
> v5:
> 
>   - add more explanation to the commit logs and comments
>   - change REG_OPTIONAL from bin to hex
>   - split patch 2 into 3 smaller patches
>   - remove CPPC_REG_VAL_READ() and CPPC_REG_VAL_WRITE() macros
>   - move the modification part in patch 5 into a separate patch
>   - rename the sysfs file from "energy_perf" to
>     energy_performance_preference_val
> 
> v4:
> 
>   - add REG_OPTIONAL and IS_OPTIONAL_CPC_REG to judge if a cpc register is
>     an optional one
>   - check whether the register is optional before CPC_SUPPORTED check in
>     cppc_get_reg_val() and cppc_set_reg_val()
>   - check the register's type in cppc_set_reg_val()
>   - add macros to generally implement registers getting and setting
>     functions
>   - move some logic codes from cppc_cpufreq.c to cppc_acpi.c
>   - replace cppc_get_auto_sel_caps() by cppc_get_auto_sel()
> 
> v3:
> 
>   - change cppc_get_reg() and cppc_set_reg() name to cppc_get_reg_val() and
>     cppc_set_reg_val()
>   - extract cppc_get_reg_val_in_pcc() and cppc_set_reg_val_in_pcc()
>   - return the result of cpc_read() in cppc_get_reg_val()
>   - add pr_debug() in cppc_get_reg_val_in_pcc() when pcc_ss_id < 0
>   - rename 'cpunum' to 'cpu' in cppc_get_reg_val()
>   - move some macros from drivers/cpufreq/cppc_cpufreq.c to
>     include/acpi/cppc_acpi.h with a CPPC_XXX prefix
> 
> v2:
> 
>   - fix some incorrect placeholder
>   - change kstrtoul to kstrtobool in store_auto_select
> 
> ---
> Discussions of previous versions:
> v1: https://lore.kernel.org/all/20241114084816.1128647-1-zhenglifeng1@huawei.com/
> v2: https://lore.kernel.org/all/20241122062051.3658577-1-zhenglifeng1@huawei.com/
> v3: https://lore.kernel.org/all/20241216091603.1247644-1-zhenglifeng1@huawei.com/
> v4: https://lore.kernel.org/all/20250113122104.3870673-1-zhenglifeng1@huawei.com/
> v5: https://lore.kernel.org/all/20250206131428.3261578-1-zhenglifeng1@huawei.com/
> v6: https://lore.kernel.org/all/20250409065703.1461867-1-zhenglifeng1@huawei.com/
> 
> Lifeng Zheng (8):
>    ACPI: CPPC: Add IS_OPTIONAL_CPC_REG macro to judge if a cpc_reg is
>      optional
>    ACPI: CPPC: Optimize cppc_get_perf()
>    ACPI: CPPC: Rename cppc_get_perf() to cppc_get_reg_val()
>    ACPI: CPPC: Extract cppc_get_reg_val_in_pcc()
>    ACPI: CPPC: Add cppc_set_reg_val()
>    ACPI: CPPC: Refactor register value get and set ABIs
>    ACPI: CPPC: Modify cppc_get_auto_sel_caps() to cppc_get_auto_sel()
>    ACPI: CPPC: Add three functions related to autonomous selection
> 
>   drivers/acpi/cppc_acpi.c     | 313 +++++++++++++++++++++--------------
>   drivers/cpufreq/amd-pstate.c |   3 +-
>   include/acpi/cppc_acpi.h     |  30 +++-
>   3 files changed, 219 insertions(+), 127 deletions(-)
> 

Reviewed-by: Mario Limonciello <mario.limonciello@amd.com>

  parent reply	other threads:[~2025-04-11 18:18 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-11  9:38 Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 1/8] ACPI: CPPC: Add IS_OPTIONAL_CPC_REG macro to judge if a cpc_reg is optional Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 2/8] ACPI: CPPC: Optimize cppc_get_perf() Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 3/8] ACPI: CPPC: Rename cppc_get_perf() to cppc_get_reg_val() Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 4/8] ACPI: CPPC: Extract cppc_get_reg_val_in_pcc() Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 5/8] ACPI: CPPC: Add cppc_set_reg_val() Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 6/8] ACPI: CPPC: Refactor register value get and set ABIs Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 7/8] ACPI: CPPC: Modify cppc_get_auto_sel_caps() to cppc_get_auto_sel() Lifeng Zheng
2025-04-11  9:38 ` [PATCH v7 8/8] ACPI: CPPC: Add three functions related to autonomous selection Lifeng Zheng
2025-04-11 18:18 ` Mario Limonciello [this message]
2025-04-14  1:26   ` [PATCH v7 0/8] Add functions for getting and setting registers related to autonomous selection in cppc_acpi zhenglifeng (A)
2025-04-30 20:03   ` Rafael J. Wysocki
2025-04-19  6:50 ` zhenglifeng (A)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f6904bb1-f41f-4be9-92bb-92fec509a821@amd.com \
    --to=mario.limonciello@amd.com \
    --cc=acpica-devel@lists.linux.dev \
    --cc=cenxinghai@h-partners.com \
    --cc=gautham.shenoy@amd.com \
    --cc=hepeng68@huawei.com \
    --cc=jonathan.cameron@huawei.com \
    --cc=lenb@kernel.org \
    --cc=lihuisong@huawei.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linuxarm@huawei.com \
    --cc=perry.yuan@amd.com \
    --cc=pierre.gondois@arm.com \
    --cc=rafael@kernel.org \
    --cc=ray.huang@amd.com \
    --cc=robert.moore@intel.com \
    --cc=sumitg@nvidia.com \
    --cc=viresh.kumar@linaro.org \
    --cc=zhanjie9@hisilicon.com \
    --cc=zhenglifeng1@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®