From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-10.2 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER,MAILING_LIST_MULTI, NICE_REPLY_A,SPF_HELO_NONE,SPF_PASS,URIBL_BLOCKED,USER_AGENT_SANE_1 autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id CE5FEC433E0 for ; Thu, 28 Jan 2021 17:40:48 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id A269364DD8 for ; Thu, 28 Jan 2021 17:40:48 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S232561AbhA1Rkk (ORCPT ); Thu, 28 Jan 2021 12:40:40 -0500 Received: from mx2.suse.de ([195.135.220.15]:35574 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S233220AbhA1RjK (ORCPT ); Thu, 28 Jan 2021 12:39:10 -0500 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.221.27]) by mx2.suse.de (Postfix) with ESMTP id C3034AD2B; Thu, 28 Jan 2021 17:38:25 +0000 (UTC) Subject: Re: [v5 PATCH 05/11] mm: memcontrol: rename shrinker_map to shrinker_info To: Yang Shi , guro@fb.com, ktkhai@virtuozzo.com, shakeelb@google.com, david@fromorbit.com, hannes@cmpxchg.org, mhocko@suse.com, akpm@linux-foundation.org Cc: linux-mm@kvack.org, linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org References: <20210127233345.339910-1-shy828301@gmail.com> <20210127233345.339910-6-shy828301@gmail.com> From: Vlastimil Babka Message-ID: Date: Thu, 28 Jan 2021 18:38:25 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.6.1 MIME-Version: 1.0 In-Reply-To: <20210127233345.339910-6-shy828301@gmail.com> Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 1/28/21 12:33 AM, Yang Shi wrote: > The following patch is going to add nr_deferred into shrinker_map, the change will > make shrinker_map not only include map anymore, so rename it to a more general > name. And this should make the patch adding nr_deferred cleaner and readable and make > review easier. Rename "memcg_shrinker_info" to "shrinker_info" as well. You mean rename struct memcg_shrinker_map, not "memcg_shrinker_info", right? > > Signed-off-by: Yang Shi Acked-by: Vlastimil Babka