From: Minchan Kim <minchan.kim@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: linux-mm <linux-mm@kvack.org>,
LKML <linux-kernel@vger.kernel.org>,
KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>,
Balbir Singh <balbir@linux.vnet.ibm.com>,
Daisuke Nishimura <nishimura@mxp.nes.nec.co.jp>,
Minchan Kim <minchan.kim@gmail.com>
Subject: [PATCH 2/2] memcg: remove charge variable in unmap_and_move
Date: Tue, 11 Jan 2011 17:51:12 +0900 [thread overview]
Message-ID: <f6f15f90ecf0df32586fcc103038fd7ea01acc16.1294735182.git.minchan.kim@gmail.com> (raw)
In-Reply-To: <41390917af25769cd59eb001370b80ef6520a8bb.1294735182.git.minchan.kim@gmail.com>
In-Reply-To: <41390917af25769cd59eb001370b80ef6520a8bb.1294735182.git.minchan.kim@gmail.com>
memcg charge/uncharge could be handled by mem_cgroup_[prepare/end]
migration itself so charge local variable in unmap_and_move lost the role
since we introduced 01b1ae63c2.
In addition, the variable name is not good like below.
int unmap_and_move()
{
charge = mem_cgroup_prepare_migration(xxx);
..
BUG_ON(charge); <-- BUG if it is charged?
..
uncharge:
if (!charge) <-- why do we have to uncharge !charge?
mem_group_end_migration(xxx);
..
}
So let's remove unnecessary and confusing variable.
Suggested-by: Daisuke Nishimura <nishimura@mxp.nes.nec.co.jp>
Cc: Balbir Singh <balbir@linux.vnet.ibm.com>
Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
Signed-off-by: Minchan Kim <minchan.kim@gmail.com>
---
mm/memcontrol.c | 1 +
mm/migrate.c | 9 +++------
2 files changed, 4 insertions(+), 6 deletions(-)
diff --git a/mm/memcontrol.c b/mm/memcontrol.c
index 8ab8410..b1b572f 100644
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -2804,6 +2804,7 @@ static inline int mem_cgroup_move_swap_account(swp_entry_t entry,
/*
* Before starting migration, account PAGE_SIZE to mem_cgroup that the old
* page belongs to.
+ * Note : Should not return -EAGAIN. unmap_and_move depends on it.
*/
int mem_cgroup_prepare_migration(struct page *page,
struct page *newpage, struct mem_cgroup **ptr)
diff --git a/mm/migrate.c b/mm/migrate.c
index 8f0f131..5f2169f 100644
--- a/mm/migrate.c
+++ b/mm/migrate.c
@@ -623,7 +623,6 @@ static int unmap_and_move(new_page_t get_new_page, unsigned long private,
struct page *newpage = get_new_page(page, private, &result);
int remap_swapcache = 1;
int rcu_locked = 0;
- int charge = 0;
struct mem_cgroup *mem = NULL;
struct anon_vma *anon_vma = NULL;
@@ -638,7 +637,7 @@ static int unmap_and_move(new_page_t get_new_page, unsigned long private,
if (unlikely(split_huge_page(page)))
goto move_newpage;
- /* prepare cgroup just returns 0 or -ENOMEM */
+ /* mem_cgroup_prepare_migration never returns -EAGAIN */
rc = -EAGAIN;
if (!trylock_page(page)) {
@@ -662,8 +661,7 @@ static int unmap_and_move(new_page_t get_new_page, unsigned long private,
}
/* charge against new page */
- charge = mem_cgroup_prepare_migration(page, newpage, &mem);
- if (charge == -ENOMEM) {
+ if (mem_cgroup_prepare_migration(page, newpage, &mem)) {
rc = -ENOMEM;
goto unlock;
}
@@ -759,8 +757,7 @@ rcu_unlock:
if (rcu_locked)
rcu_read_unlock();
uncharge:
- if (!charge)
- mem_cgroup_end_migration(mem, page, newpage, rc == 0);
+ mem_cgroup_end_migration(mem, page, newpage, rc == 0);
unlock:
unlock_page(page);
--
1.7.0.4
next prev parent reply other threads:[~2011-01-11 8:51 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-01-11 8:51 [PATCH 1/2] memcg: remove unnecessary BUG_ON Minchan Kim
2011-01-11 8:51 ` Minchan Kim [this message]
2011-01-12 0:38 ` [PATCH 2/2] memcg: remove charge variable in unmap_and_move Daisuke Nishimura
2011-01-12 0:48 ` KAMEZAWA Hiroyuki
2011-01-12 0:38 ` [PATCH 1/2] memcg: remove unnecessary BUG_ON Daisuke Nishimura
2011-01-12 0:47 ` KAMEZAWA Hiroyuki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f6f15f90ecf0df32586fcc103038fd7ea01acc16.1294735182.git.minchan.kim@gmail.com \
--to=minchan.kim@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=balbir@linux.vnet.ibm.com \
--cc=kamezawa.hiroyu@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=nishimura@mxp.nes.nec.co.jp \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®