From: Frank Wang <frank.wang@rock-chips.com>
To: "Heiko Stübner" <heiko@sntech.de>
Cc: Guenter Roeck <linux@roeck-us.net>,
Guenter Roeck <groeck@google.com>,
Guenter Roeck <groeck@chromium.org>,
Douglas Anderson <dianders@chromium.org>,
jwerner@chromium.org, Kishon Vijay Abraham I <kishon@ti.com>,
robh+dt@kernel.org, pawel.moll@arm.com, mark.rutland@arm.com,
ijc+devicetree@hellion.org.uk, Kumar Gala <galak@codeaurora.org>,
linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
linux-usb@vger.kernel.org, linux-rockchip@lists.infradead.org,
Ziyuan Xu <xzy.xu@rock-chips.com>,
Kever Yang <kever.yang@rock-chips.com>,
Tao Huang <huangtao@rock-chips.com>,
william.wu@rock-chips.com, frank.wang@rock-chips.com
Subject: Re: [PATCH v6 2/2] phy: rockchip-inno-usb2: add a new driver for Rockchip usb2phy
Date: Tue, 21 Jun 2016 17:27:33 +0800 [thread overview]
Message-ID: <f70f9c49-9eb7-5dc9-4ff1-eab1481ad66a@rock-chips.com> (raw)
In-Reply-To: <2284777.mdEtFaarym@diego>
Hi Heiko,
On 2016/6/21 17:05, Heiko Stübner wrote:
> Hi Frank,
>
> Am Dienstag, 21. Juni 2016, 15:52:45 schrieb Frank Wang:
>> On 2016/6/20 12:56, Guenter Roeck wrote:
>>> On Sun, Jun 19, 2016 at 8:32 PM, Frank Wang <frank.wang@rock-chips.com>
> wrote:
>>>>> Turns out my problem was one of terminology. Using "suspend" and
>>>>> "resume" to me suggested the common use of suspend and resume
>>>>> functions. That is not the case here. After mentally replacing
>>>>> "suspend" with "power_off" and "resume" with "power_on", you are
>>>>> right, no problem exists. Sorry for the noise.
>>>>>
>>>>> Maybe it would be useful to replace "resume" with "power_on" and
>>>>> "suspend" with "power_off" in the function and variable names to
>>>>> reduce confusion and misunderstandings.
>>>>>
>>>>> Thanks,
>>>>> Guenter
>>>> Well, it does have a bits confusion, however, the phy-port always just
>>>> goes
>>>> to suspend and resume mode (Not power off and power on) in a fact. So
>>>> must
>>>> it be renamed?
>>> Other phy drivers name the functions _power_off and _power_on and
>>> avoid the confusion. The callbacks are named .power_off and .power_on,
>>> which gives a clear indication of its intended purpose. Other drivers
>>> implementing suspend/resume (such as the omap usb phy driver) tie
>>> those functions not into the power_off/power_on callbacks, but into
>>> the driver's suspend/resume callbacks. At least the omap driver has
>>> separate power management functions.
>>>
>>> Do the functions _have_ to be renamed ? Surely not. But, if the
>>> functions are really suspend/resume functions and not
>>> power_off/power_on functions, maybe they should tie to the
>>> suspend/resume functions and not register themselves as
>>> power_off/power_on functions ?
>> As Guenter mentioned above, I doped out two solutions, one is that keep
>> current process but renaming *_resume/*_suspend to
>> *_power_on/*_power_off;
> in a way, naming stuff "power_off", "power_on" actually matches. For one, the
> phy-block goes from unusable to usable by usb-devices and also will power-on a
> phy-supply regulator (often named vcc_host* on Rockchip boards) from the phy-
> core.
>
>> another is that do not assign power_on/power_off
>> functions for phy_ops at phy creating time, then, shorten
>> _SCHEDULE_DELAY_ delay time less that 10 Seconds, and the phy-port
>> suspend/resume mechanism depend on _sm_work_ completely.
> Which in turn would mean that we would always depend on a fully controllable
> phy block. Right now it seems, rk3036, rk3228, rk3368 (probably forgot some)
> have the same type of phy, but with at least the unplug-detection missing.
> In its current form the driver can very well support those (later on) by
> simply working statically (only acting on phy_power callbacks and not going to
> suspend on its own).
>
> Also having the work running in 10-second intervall seems wasteful.
>
>> So which is the better way from your view? or would you like to give
>> other unique perceptions please?
> As obvious from the above, I would prefer just renaming the functions :-)
>
> Heiko
>
Got it, thanks for your comments. I am going to correct and send out a
new version later today, so sorry for trouble you to sign 'Reviewed-by'
again if no any other issues.
BR.
Frank
prev parent reply other threads:[~2016-06-21 9:28 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-06-17 2:09 [PATCH v6 0/2] Add a new Rockchip usb2 phy driver Frank Wang
2016-06-17 2:09 ` [PATCH v6 1/2] Documentation: bindings: add DT documentation for Rockchip USB2PHY Frank Wang
2016-06-17 2:09 ` [PATCH v6 2/2] phy: rockchip-inno-usb2: add a new driver for Rockchip usb2phy Frank Wang
2016-06-17 4:59 ` Guenter Roeck
2016-06-17 6:43 ` Frank Wang
2016-06-17 13:20 ` Guenter Roeck
2016-06-20 1:27 ` Frank Wang
2016-06-20 3:00 ` Guenter Roeck
2016-06-20 3:32 ` Frank Wang
2016-06-20 4:56 ` Guenter Roeck
2016-06-21 7:52 ` Frank Wang
2016-06-21 9:05 ` Heiko Stübner
2016-06-21 9:27 ` Frank Wang [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f70f9c49-9eb7-5dc9-4ff1-eab1481ad66a@rock-chips.com \
--to=frank.wang@rock-chips.com \
--cc=devicetree@vger.kernel.org \
--cc=dianders@chromium.org \
--cc=galak@codeaurora.org \
--cc=groeck@chromium.org \
--cc=groeck@google.com \
--cc=heiko@sntech.de \
--cc=huangtao@rock-chips.com \
--cc=ijc+devicetree@hellion.org.uk \
--cc=jwerner@chromium.org \
--cc=kever.yang@rock-chips.com \
--cc=kishon@ti.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-usb@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=mark.rutland@arm.com \
--cc=pawel.moll@arm.com \
--cc=robh+dt@kernel.org \
--cc=william.wu@rock-chips.com \
--cc=xzy.xu@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®