From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753092AbdBJQEM (ORCPT ); Fri, 10 Feb 2017 11:04:12 -0500 Received: from foss.arm.com ([217.140.101.70]:37856 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752351AbdBJQEJ (ORCPT ); Fri, 10 Feb 2017 11:04:09 -0500 Subject: Re: [PATCH 06/11] iommu: Add iommu_device_set_fwnode() interface To: Joerg Roedel References: <1486639981-32368-1-git-send-email-joro@8bytes.org> <1486639981-32368-7-git-send-email-joro@8bytes.org> <417eee8c-4e1b-57f0-2c00-d6c3926ce66d@arm.com> <20170210152254.GI7339@8bytes.org> Cc: Will Deacon , Lorenzo Pieralisi , Alex Williamson , David Woodhouse , iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org, Joerg Roedel From: Robin Murphy Message-ID: Date: Fri, 10 Feb 2017 16:03:07 +0000 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.7.0 MIME-Version: 1.0 In-Reply-To: <20170210152254.GI7339@8bytes.org> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/02/17 15:22, Joerg Roedel wrote: > Hi Robin, > > On Fri, Feb 10, 2017 at 02:16:54PM +0000, Robin Murphy wrote: >>> +static inline void iommu_device_set_fwnode(struct iommu_device *iommu, >>> + struct fwnode_handle *fwnode) >>> +{ >>> + iommu->fwnode = fwnode; >>> +} >> >> Would it make sense to simply make the ops and fwnode additional >> arguments to iommu_device_register() (permitting fwnode to be NULL)? >> AFAICS they should typically all have the same effective lifetime so >> there doesn't seem to be any real need to handle everything separately. > > Well, it is not yet clear what other information will end up in > 'struct iommu_device', and I don't want to add another parameter to > iommu_device_register for every new struct member. That's a fair point. I think the ops, as a core piece of the whole API, would be sufficiently self-explanatory as part of registration, but then we'd end up with a weird interface with different members initialised through different paths, and I agree that ends up just as ugly. > Also I think having these wrappers is more readable in the code, as it > is clear what the code does without looking up the function prototypes > in the header. Yeah, on reflection explicit initialisation is certainly easier to read than a bunch of arguments handled implicitly by register(), but then from that angle, even more clear would be to simply have the drivers write the relevant struct members directly - I'd be quite happy with that, and we then don't have to add another setter to iommu.h for every new struct member (and risk it looking like Java code...) Robin. > > It might make sense to set the mandatory struct members via > iommu_device_register in the future, but we'll see :) > > > Joerg >